system-config-lvm fails to start citing missing /etc/init.d/lvm2

Bug #1239912 reported by Gary Gapinski on 2013-10-15
166
This bug affects 35 people
Affects Status Importance Assigned to Milestone
system-config-lvm (Ubuntu)
High
Dimitri John Ledkov
Trusty
High
Dimitri John Ledkov

Bug Description

Upon invocation, /usr/bin/system-config-lvm performs «invoke-rc.d lvm2 start», but this results in «invoke-rc.d: unknown initscript, /etc/init.d/lvm2 not found.».

Executing /usr/share/system-config-lvm/system-config-lvm.py succeeds.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: system-config-lvm 1.1.18-1
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
ApportVersion: 2.12.5-0ubuntu2
Architecture: amd64
Date: Mon Oct 14 22:53:16 2013
InstallationDate: Installed on 2013-10-12 (2 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Beta amd64 (20130925.1)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: system-config-lvm
UpgradeStatus: No upgrade log present (probably fresh install)

Gary Gapinski (5wtq-gary) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-lvm (Ubuntu):
status: New → Confirmed

The attachment "A one-line-delete patch that solves the problem." seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Pat Callahan (pat-callahan1) wrote :

the workaround:

sudo /usr/share/system-config-lvm/system-config-lvm.py;

Rich.T. (rich.t.) wrote :

"the workaround:

sudo /usr/share/system-config-lvm/system-config-lvm.py;"

Program launches then terminates with:

http://pastebin.com/EUCsTuuJ

I think system-config-lvm works fine on another 13.10 system of mine; I must check.

The effected system is a recent upgrade from 13.04 -> 13.10; so this may have something to do with it.

Changed in system-config-lvm (Ubuntu):
importance: Undecided → High
Singtoh (singtoh) wrote :

Yeah, this effects me as well. I am running Ubuntu-14.04-Trusty-amd64 fresh install today.

Cheers,

Singtoh

Bryan Gonzalez (bgonza868) wrote :

Posted patch which is similar to skiantoz's but using comments instead of code deletion. Invoking lvm2 to run is not necessary as lvm2 should already be running since boot. The logic is that you would not have installed a management app for the service if the service was not already installed.

@rich.t. The output you posted does not immediately indicate a problem with system-config-lvm.py Rather, it seems that the script was having trouble creating the gui. Maybe there is something wrong with gnome on your installation?

With this patch I am able to run the command to launch the lvm gui as either non-priviledged or as root. 13.10 Saucy

Rolf Leggewie (r0lf) on 2014-04-16
tags: added: i386 trusty
Rolf Leggewie (r0lf) wrote :

This problem had been fixed previously in 1.1.4-4ubuntu1 in karmic, but regressed in saucy when the package version 1.1.18-1 was erroneously synced by Bhavanai Shankar when it should have been merged.

---------------
system-config-lvm (1.1.4-4ubuntu1) karmic; urgency=low

  * In Ubuntu, we use udev rather than an init script to activate lvm2, so
    don't try to invoke the init script (thanks, Andres Mujica; LP:
    #390421).

 -- Colin Watson <email address hidden> Thu, 02 Jul 2009 11:09:51 +0100

Changed in system-config-lvm (Ubuntu):
milestone: none → ubuntu-14.04
Rolf Leggewie (r0lf) wrote :

You really have to wonder if Bhavani even tried the package after his sync. I can't imagine or else he would have had to run into this problem. Intolerable neglect.

Changed in system-config-lvm (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-lvm - 1.1.18-1ubuntu1

---------------
system-config-lvm (1.1.18-1ubuntu1) trusty; urgency=medium

  * Reintroduce a version of my previous patch (thanks, Anton¡o Sch¡fano and
    others):
    - In Ubuntu, we use udev rather than an init script to activate lvm2, so
      don't try to invoke the init script (LP: #1239912).
 -- Colin Watson <email address hidden> Wed, 16 Apr 2014 11:52:56 +0100

Changed in system-config-lvm (Ubuntu Trusty):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers