synaptic crashed with SIGSEGV

Bug #936677 reported by Adolfo Jayme on 2012-02-20
This bug affects 155 people
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Medium
Unassigned

Bug Description

Synaptic closes just after completing update of package information.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: synaptic 0.75.5~exp6
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
NonfreeKernelModules: wl
ApportVersion: 1.91-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Sun Feb 19 20:28:25 2012
ExecutablePath: /usr/sbin/synaptic
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/sbin/synaptic
SegvAnalysis:
 Segfault happened at: 0x8096e77: mov 0x4(%edx),%eax
 PC (0x08096e77) ok
 source "0x4(%edx)" (0x2e312d36) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: synaptic
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: synaptic crashed with SIGSEGV
UpgradeStatus: Upgraded to precise on 2012-02-19 (0 days ago)
UserGroups:

Adolfo Jayme (fitojb) wrote :

StacktraceTop:
 Section (this=<optimized out>) at /usr/include/apt-pkg/cacheiterators.h:158
 RPackage::section (this=0x96c7e40) at rpackage.cc:111
 RPackageViewSections::addPackage (this=0x9501e48, package=0x96c7e40) at rpackageview.cc:96
 RPackageView::refresh (this=0x9501e48) at rpackageview.cc:90
 RPackageLister::openCache (this=0x94f0a28) at rpackagelister.cc:420

Changed in synaptic (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in synaptic (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Michael Vogt (mvo) on 2012-02-29
visibility: private → public
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can reproduce this with the latest apt/synaptic by:
- opening synaptic
- adding a repository (dosn't crash when removing one)
- clicking on reload, after reload finished and the cache is reopened it crashes in:

RPackage::section (this=0x1658120) at rpackage.cc:111
111 const char *s = _package->Section();

Fahad (fahadayaz) wrote :

It seems that it crashes when anything in the repository information has changed. If clicking reload and it's still the same (you can tell by the speed), it will not crash.

Michael Vogt (mvo) on 2012-02-29
Changed in synaptic (Ubuntu):
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

This is fixed in trunk and it will be part of the next sync.

Adolfo Jayme (fitojb) wrote :

Thank you, mvo!

Am 02.03.2012 11:20, schrieb Michael Vogt:
> This is fixed in trunk and it will be part of the next sync.
>

Good to hear!

Thank you for the information,

Sascha

nice, thank you! :)

On 2 March 2012 11:20, Michael Vogt <email address hidden> wrote:

> This is fixed in trunk and it will be part of the next sync.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (941997).
> https://bugs.launchpad.net/bugs/936677
>
> Title:
> synaptic crashed with SIGSEGV
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/936677/+subscriptions
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.75.5

---------------
synaptic (0.75.5) unstable; urgency=low

  * common/rpackagelister.cc:
    - simplify openCache() code to use more modern std::vector features
      and fix crash along the way (LP: #936677)
  * common/sections_trans.cc:
    - add "metapackages", "education", "introspection"
  * debian/rules:
    - do not build multiarch support in Debian to make it work on
      unstable that has no multiarch apt yet

 -- Michael Vogt <email address hidden> Fri, 02 Mar 2012 10:20:59 +0100

Changed in synaptic (Ubuntu):
status: In Progress → Fix Released
Javier Blanco (j2bv16) on 2012-03-05
description: updated
Tom rooze.sen (tomrooze-sen) wrote :

Here Synaptic ok now no more crashes had both the 32 Bit and 64 Bit version.
Thank you and greetings Tom rooze.sen.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers