Ubuntu

synaptic --help complains about the lack of administrative privileges

Reported by Robert Roth on 2011-06-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
synaptic (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: synaptic

When running 'synaptic --help' from the command line, I get a dialog complaining with "Starting without administrative privileges", and after clicking close on the dialog, I get the help in the terminal. The dialog should only appear if the command is not equal to --help, as that command should not require administrative privileges.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: synaptic 0.75.1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Wed Jun 1 12:47:57 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: synaptic
UpgradeStatus: Upgraded to natty on 2011-04-27 (34 days ago)

Robert Roth (evfool) wrote :
Robert Roth (evfool) wrote :

Set the importance to Low, as this is only a minor cosmetic issue.

Changed in synaptic (Ubuntu):
importance: Undecided → Low
Robert Roth (evfool) on 2011-06-01
Changed in synaptic (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: New → In Progress
Robert Roth (evfool) on 2011-06-02
Changed in synaptic (Ubuntu):
assignee: Robert Roth (evfool) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package synaptic - 0.75.2ubuntu1

---------------
synaptic (0.75.2ubuntu1) oneiric; urgency=low

  * merged from debian/unstable, remaining changes:
    - ubuntu icons for supported applications
    - launchpad-integration
    - ubuntu changelog download support
    - support section metapackages
    - x-ubuntu-gettext-domain in desktop file

synaptic (0.75.2) unstable; urgency=low

  [ Michael Vogt ]
  * po/ru.po:
    - updated, thanks to Alexander Sashanov (closes: #614969)
  * po/pt_BR.po:
    - updated, thanks to Sérgio Cipolla (closes: #606447)
  * common/rpackage.{cc,h}:
    - add basic multiarch support, enabled by default, can
      be disabled at build time with
      ./configure --without-apt-multiarch-support
    - no changes on non-multiarch enabled configurations
  * po/et.po:
    - updated, thanks to Mattias Põldaru
  * po/de.po:
    - fix translation of breaks (closes: #622752)
  * po/pt_BR.po:
    - updaed, thanks to Sergio Cipolla
  * updated translations from launchpad

  [ Robert Roth ]
  * Remove statusbar border and add padding (LP: #157574)
  * Moved command line argument parsing and displaying help before
    checking for administrative privileges (LP: #791135)
 -- Michael Vogt <email address hidden> Tue, 21 Jun 2011 16:05:18 +0200

Changed in synaptic (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers