Comment 0 for bug 262915

Package: synaptic
Version: 0.57.5.1
Severity: wishlist

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

This is wishlist as I don't see a real bug here and i'm familiar with
using synaptic. But a new user to debian or synaptic could be confused.

I met one of these new to debian users at "LinuxInfoTag 2005" and he
couldn't see the magic behind the update process and did just update
the package lists on his Sarge box any time.

To improve the usability, synaptic could automagicaly switch to the list
of packages which are upgradeable after the user has fetched the lists.
Or synaptic could just make the entry for the list as bold text or
place a special icon. Something the unexperienced user can see - so he
does the right thing and gets his security updates installed.

Another solution (maybe better) could be a dialog which warns the user:
"there are updates possible - want you now install these packages?
[yes of course], [No thanks, i know what I'm doing]" after he fetched new
package lists or before he quits synaptic.

Thx in advance
Carsten Luedtke

- -- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.13-rc7-1-k7
Locale: LANG=de_DE.UTF-8@euro, LC_CTYPE=de_DE.UTF-8@euro (charmap=UTF-8)

Versions of packages synaptic depends on:
ii apt [libapt-pkg-libc6.3-6 0.6.42.1 Advanced front-end for dpkg
ii libatk1.0-0 1.10.3-1 The ATK accessibility toolkit
ii libc6 2.3.5-7 GNU C Library: Shared libraries an
ii libfontconfig1 2.3.2-1.1 generic font configuration library
ii libfreetype6 2.1.10-1 FreeType 2 font engine, shared lib
ii libgcc1 1:4.0.2-3 GCC support library
ii libglade2-0 1:2.5.1-2 library to load .glade files at ru
ii libglib2.0-0 2.8.3-1 The GLib library of C routines
ii libgtk2.0-0 2.6.10-1 The GTK+ graphical user interface
ii libice6 6.8.2.dfsg.1-9 Inter-Client Exchange library
ii libncurses5 5.5-1 Shared libraries for terminal hand
ii libpango1.0-0 1.8.2-3 Layout and rendering of internatio
ii libsm6 6.8.2.dfsg.1-9 X Window System Session Management
ii libstdc++6 4.0.2-3 The GNU Standard C++ Library v3
ii libvte4 1:0.11.15-2 Terminal emulator widget for GTK+
ii libx11-6 6.8.2.dfsg.1-9 X Window System protocol client li
ii libxft2 2.1.7-1 FreeType-based font drawing librar
ii libxml2 2.6.22-1 GNOME XML library
ii libxrender1 1:0.9.0-2 X Rendering Extension client libra
ii scrollkeeper 0.3.14-10 A free electronic cataloging syste
ii xlibs 6.8.2.dfsg.1-9 X Window System client libraries m
ii zlib1g 1:1.2.3-6 compression library - runtime

Versions of packages synaptic recommends:
ii deborphan 1.7.18 Find orphaned libraries
ii gksu 1.3.6-1 graphical frontend to su
ii libgnome2-perl 1.023-1 Perl interface to the GNOME librar

- -- no debconf information

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFDZ8GLK569vX68PzgRAnuTAJ44dSi4frr8PgZQbKcfzodI8tm3lQCg9mqn
buNpoYfaa6GNh1+reV0tw/I=
=U2ij
-----END PGP SIGNATURE-----