GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed

Bug #1282542 reported by dino99 on 2014-02-20
828
This bug affects 175 people
Affects Status Importance Assigned to Milestone
synaptic (Debian)
Fix Released
Undecided
Unassigned
synaptic (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella
Nominated for Utopic by Alberto Salvia Novella
Nominated for Vivid by Alberto Salvia Novella
Nominated for Wily by Alberto Salvia Novella

Bug Description

Got that new error each time i'm upgrading a package from synaptic

****** comment from https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=743995#39 ****

in my opinion this is caused this way:
- synaptic calls vte_terminal_forkpty which calls __vte_pty_fork
- Now we have a parent process which gets in the variable pid the pid of
  the child process. A call to vte_terminal_watch_child is needed and
  gives no warning.
- But also we have now the child process, which has in variable pid a 0 (man fork(2)).
  In the child process we call now vte_terminal_watch_child with pid=0
  and get therefore the warning.

Therefore I think:
- problem lies in package libvte-2.90-9
- with attached patch the warning could be avoided.

Kind regards,
Bernhard

pid_t
vte_terminal_forkpty(VteTerminal *terminal,
       char **envv, const char *working_directory,
       gboolean lastlog, gboolean utmp, gboolean wtmp)
{
#ifdef HAVE_FORK
        VtePty *pty;
        GPid pid;

        g_return_val_if_fail(VTE_IS_TERMINAL(terminal), -1);

        pty = vte_pty_new(__vte_pty_get_pty_flags(lastlog, utmp, wtmp), NULL);
        if (pty == NULL)
                return FALSE;

        if (!__vte_pty_fork(pty,
                            &pid,
                            NULL)) {
                g_object_unref(pty);
                return FALSE;
        }

        vte_terminal_set_pty_object(terminal, pty);
        // FIXMEchpe is that really right?
        vte_terminal_watch_child(terminal, pid);

        return pid;
#else
        return -1;
#endif
}
******************** available patch : https://bugs.debian.org/cgi-bin/bugreport.cgi?att=1;msg=39;bug=743995;filename=26_avoid-call-to-vte_terminal_watch_child-in-child-process.patch ******************

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: libc-bin 2.18-0ubuntu7
ProcVersionSignature: Ubuntu 3.13.0-10.30-generic 3.13.3
Uname: Linux 3.13.0-10-generic i686
ApportVersion: 2.13.2-0ubuntu5
Architecture: i386
CurrentDesktop: GNOME
Date: Thu Feb 20 13:26:55 2014
Dependencies:
 gcc-4.9-base 4.9-20140217-0ubuntu1
 libc6 2.18-0ubuntu7
 libcap2 1:2.22-1.2ubuntu2
 libgcc1 1:4.9-20140217-0ubuntu1
 multiarch-support 2.18-0ubuntu7
InstallationDate: Installed on 2013-10-25 (117 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386 (20131021.1)
SourcePackage: eglibc
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eglibc (Ubuntu):
status: New → Confirmed
Vinay (vinay-wagh) wrote :

Bug confirmed on Ubuntu 14.04 (64 bit).

-- VInay

John Paul (therealjohnpaul) wrote :

I'm getting this as well on Linux Mint 16 'Petra' Cinnamon 64-bit.

Reviews-10 (allan3) wrote :

Also getting it Trusty Tahr 32

It renders essential features or functionality of the package (or a dependent one) broken.

Changed in eglibc (Ubuntu):
importance: Undecided → High

Getting this also in Trusty Beta 2

dtr (dtr) wrote :

I get this as well on Kubuntu 14.04 64 bit

DH (dave-higherform) wrote :

Also saw this message during each package upgrade in Bodhi 3.0.0 RC, which is based on 14.04

Kevin (raccoonstrait) wrote :

I first noticed this in Synaptic after upgrading to 14.04. Due to other issues, I then re-installed everything except my /home partition. The GLib Critical error is still there. The first notice was after an Ubuntu distro-upgrade. The after one came from Xubuntu install.

Any chance it is some setting in /home?

Kevin (raccoonstrait) wrote :
Download full text (4.5 KiB)

Maybe another clue, this from installing boot-repair, similar but different error message at the end.

sudo apt-get install -y boot-repair && boot-repair
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  boot-sav boot-sav-extra gawk gksu glade2script libcrypt-passwdmd5-perl
  libgksu2-0 syslinux-common
Suggested packages:
  dmraid lvm2 mbr mdadm clean-ubiquity os-uninstaller gawk-doc
The following NEW packages will be installed:
  boot-repair boot-sav boot-sav-extra gawk gksu glade2script
  libcrypt-passwdmd5-perl libgksu2-0 syslinux-common
0 upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,418 kB of archives.
After this operation, 8,862 kB of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty/main gawk i386 1:4.0.1+dfsg-2.1ubuntu2 [730 kB]
Get:2 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu/ saucy/main glade2script all 3.2.2~ppa47~saucy [42.3 kB]
Get:3 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu/ saucy/main boot-sav all 3.199~ppa40~saucy [430 kB]
Get:4 http://us.archive.ubuntu.com/ubuntu/ trusty/universe libgksu2-0 i386 2.0.13~pre1-6ubuntu4 [71.4 kB]
Get:5 http://us.archive.ubuntu.com/ubuntu/ trusty/universe gksu i386 2.0.2-6ubuntu2 [27.5 kB]
Get:6 http://us.archive.ubuntu.com/ubuntu/ trusty/main libcrypt-passwdmd5-perl all 1.3-10 [10.4 kB]
Get:7 http://us.archive.ubuntu.com/ubuntu/ trusty/main syslinux-common all 3:4.05+dfsg-6+deb8u1 [917 kB]
Get:8 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu/ saucy/main boot-repair all 3.199~ppa40~saucy [47.2 kB]
Get:9 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu/ saucy/main boot-sav-extra all 3.199~ppa40~saucy [142 kB]
Fetched 2,418 kB in 5s (408 kB/s)
Selecting previously unselected package gawk.
(Reading database ... 184614 files and directories currently installed.)
Preparing to unpack .../gawk_1%3a4.0.1+dfsg-2.1ubuntu2_i386.deb ...
Unpacking gawk (1:4.0.1+dfsg-2.1ubuntu2) ...
Selecting previously unselected package glade2script.
Preparing to unpack .../glade2script_3.2.2~ppa47~saucy_all.deb ...
Unpacking glade2script (3.2.2~ppa47~saucy) ...
Selecting previously unselected package boot-sav.
Preparing to unpack .../boot-sav_3.199~ppa40~saucy_all.deb ...
Unpacking boot-sav (3.199~ppa40~saucy) ...
Selecting previously unselected package boot-repair.
Preparing to unpack .../boot-repair_3.199~ppa40~saucy_all.deb ...
Unpacking boot-repair (3.199~ppa40~saucy) ...
Selecting previously unselected package boot-sav-extra.
Preparing to unpack .../boot-sav-extra_3.199~ppa40~saucy_all.deb ...
Unpacking boot-sav-extra (3.199~ppa40~saucy) ...
Selecting previously unselected package libgksu2-0.
Preparing to unpack .../libgksu2-0_2.0.13~pre1-6ubuntu4_i386.deb ...
Unpacking libgksu2-0 (2.0.13~pre1-6ubuntu4) ...
Selecting previously unselected package gksu.
Preparing to unpack .../gksu_2.0.2-6ubuntu2_i386.deb ...
Unpacking gksu (2.0.2-6ubuntu2) ...
Selecting previously unselected package libcrypt-passwdmd5-perl.
Preparing to unpack .../libcrypt-passwdmd5-perl_1.3-10_all.deb ...
Unpacki...

Read more...

Squall77it (squall77it) on 2014-04-25
no longer affects: eglibc (Debian)
Mepherotus (mepherotus) wrote :

I had the same bug when i updated from ubuntu gnome 13.10 to ubuntu gnome 14.04, the solution for me was to update the nvidia driver to 331-updates.

oldrocker99 (fhwri99) wrote :

I get this from a fresh installation of Lubntu 14.04 as well. RS690 ATI Radeon 1200/1250/1270.

I also get this from a fresh install of 14.04 (ubuntu). It didn't seem to be doing this when I first installed things, but today it is every time.

thecure (keith-k) wrote :

Confirmed - clean install 14.04 64 bit but after installing several packages.

Changed in eglibc (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in eglibc (Debian):
status: Unknown → New
oldrocker99 (fhwri99) wrote :

14.04 confirmed.

I got this bug when updating Linux Mint 17.

mauriicio (mauriicio) wrote :

Lubuntu 14.04 confirmed.

galen (galen-technomage) wrote :

Bug confirmed on Ubuntu 14.10 Utopic Unicorn ( testing release )

Bug confirmed on Ubuntu GNOME 14.04 x64

boirota (boirota) wrote :

Solution in my samsung notebook nvidia-331-updates installed and removed nvidia-337.

Now Ok.

Mélodie (meets) wrote :

Hi,

I get the same message while installing two packages. I am using Trusty Tahr installed from the mini.iso (net install) to which I added ubuntu-standard, Xorg, Openbox and a bunch of other programs.

The system is a 64bits and the Graphics is Intel. ( Intel Corporation Core Processor Integrated Graphics Controller (rev 02))

oldrocker99 (fhwri99) wrote :

I get the same error whenever I use Synaptic. Kubuntu 14.04.

Vlad Orlov (monsta) wrote :

Shouldn't this bug affect "Synaptic" instead of "eglibc"? It's already changed on Debian bug tracker.

Also it's not clear what functionality this bug affects and what's really broken (if anything). Synaptic seems to work fine even though it displays this message.

dino99 (9d9) wrote :

affected package changed as per Debian bug comments

affects: eglibc (Debian) → synaptic (Debian)
dino99 (9d9) wrote :

follow the Debian bug; Could also be apt or one of its dependency.

affects: eglibc (Ubuntu) → synaptic (Ubuntu)
dino99 (9d9) wrote :
Igor (igor-iurkov) wrote :

Same problem , Ubuntu 14.04

cx11430 (e-brian-g) wrote :

I get the same error now all the time using synaptic.
trust tahr 32

I believe that this is only a matter of time, it doesn't mess up
installations so it is a low priority resolution bug.

On 06/18/2014 12:34 PM, cx11430 wrote:
>
> I get the same error now all the time using synaptic.
> trust tahr 32
>

Just saw this when updating with Synaptic.
Using Trusty 14.04 LTS 64bit. NVIDIA 331.38 proprietary, tested drivers.

tallien (tallien) wrote :

Bluefish stopped working for me after my upgrade to 14.04 (32-bit, NVIDIA), and I had this glib-critical error message too.

When I run Bluefish in terminal now, the error message is:

(bluefish:18130): GLib-ERROR **: /build/buildd/glib2.0-2.40.0/./glib/gmem.c:103: failed to allocate 4125921482 bytes
Trace/breakpoint trap

I don't know whether this is related or not, but I thought I'd mention it here since no one seems to have noticed anything being affected yet.

tallien (tallien) wrote :

From Synaptic, when installing Bluefish after upgrading from 13.10 to 14.04:

(synaptic:5163): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
(Reading database [...] files and directories currently installed.)
Preparing to unpack .../bluefish-data_2.2.5-1_all.deb ...
Unpacking bluefish-data (2.2.5-1) over (2.2.5-1) ...
Preparing to unpack .../bluefish_2.2.5-1_i386.deb ...
Unpacking bluefish (2.2.5-1) over (2.2.5-1) ...
Preparing to unpack .../bluefish-plugins_2.2.5-1_i386.deb ...
Unpacking bluefish-plugins (2.2.5-1) over (2.2.5-1) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Processing triggers for man-db (2.6.7.1-1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for menu (2.1.46ubuntu1) ...
Setting up bluefish-data (2.2.5-1) ...
Setting up bluefish-plugins (2.2.5-1) ...
Setting up bluefish (2.2.5-1) ...
Processing triggers for menu (2.1.46ubuntu1) ...

After this, trying to run Bluefish produced the GLib-ERROR message I mentioned above. It was working fine before on 13.10.

Robin (robingape) wrote :

In reply to Tallien's comments 32 & 33 above, I'd suggest raising a bug against Bluefish.

HTH

tallien (tallien) wrote :

Thanks Robin. I have done so here: https://bugs.launchpad.net/ubuntu/+source/bluefish/+bug/1341811
Apologies to all if the Bluefish information was not relevant to this error.

Changed in synaptic (Ubuntu):
status: Confirmed → Triaged

Hi,

The pid > 0 failed is a minor glitch in 14.04, it is not related.

Best Regards,
Diogo Amorim
Em 13/07/2014 01:25, "tallien" <email address hidden> escreveu:

> Bluefish stopped working for me after my upgrade to 14.04 (32-bit,
> NVIDIA), and I had this glib-critical error message too.
>
> When I run Bluefish in terminal now, the error message is:
>
> (bluefish:18130): GLib-ERROR **:
> /build/buildd/glib2.0-2.40.0/./glib/gmem.c:103: failed to allocate
> 4125921482 bytes
> Trace/breakpoint trap
>
> I don't know whether this is related or not, but I thought I'd mention
> it here since no one seems to have noticed anything being affected yet.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282542
>
> Title:
> (synaptic:3405): GLib-CRITICAL **: g_child_watch_add_full: assertion
> 'pid > 0' failed
>
> Status in “synaptic” package in Ubuntu:
> Confirmed
> Status in “synaptic” package in Debian:
> New
>
> Bug description:
> Got that new error each time i'm upgrading a package from synaptic
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: libc-bin 2.18-0ubuntu7
> ProcVersionSignature: Ubuntu 3.13.0-10.30-generic 3.13.3
> Uname: Linux 3.13.0-10-generic i686
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CurrentDesktop: GNOME
> Date: Thu Feb 20 13:26:55 2014
> Dependencies:
> gcc-4.9-base 4.9-20140217-0ubuntu1
> libc6 2.18-0ubuntu7
> libcap2 1:2.22-1.2ubuntu2
> libgcc1 1:4.9-20140217-0ubuntu1
> multiarch-support 2.18-0ubuntu7
> InstallationDate: Installed on 2013-10-25 (117 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386
> (20131021.1)
> SourcePackage: eglibc
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/1282542/+subscriptions
>

tags: added: utopic

I haven't bluefish (comment 33/34 !) and i have the same message..... ; "WARNING.... g lib watch add full...." and "unknow media type in type all/all etc...(comment 33)

upgrade 13.10 to 14.04

radeon 3850 VESA : CYPRESS Ubuntu Unity + cairo + Docky 64 Bits / Cubuntu Cinnamon cairo Docky 64 bits
ram 6 giga. , i7 930 gigabyte-sniper
Release
 3.13.0.36

the same thing on second config !

 Utopic Gnome Shell + cairo + Docky Gnome 3.9.90 Binutils2.24.51.20140903 Gcc4.9.1 libC2.19 GNu Make4.0

radeon 6850 Gallium 0.4 on AMD Barts 8giga Phenom(tm) II X6 1055T Asus M5A97 rev2.0

Release
 3.13.0.32 -generic 64 Bits

val

Arvind Kumar (phenom-arvind) wrote :

I also have the same problem when i install packages
(synaptic:3035): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed

please do something

Arvin,

I started noticing the glib problem when I tried to run the license
program as part of installing Xilinx ISE 14, so I upgraded my Ubuntu
from 12.4 to 14.4, thinking that would fix the problem, but it didn't
and screwed-up Unity. I might need to install Ubuntu 14.4 from scratch
when I have the time.

Cheers,
Bob

On 9/23/2014 7:17 AM, Arvind Kumar wrote:
> I also have the same problem when i install packages
> (synaptic:3035): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
>
> please do something
>

i have the same problem on my ubuntu 14.10 beta 2
(synaptic:4976): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed

U will have the same prob with 14.04
On Sep 23, 2014 6:51 PM, "Bob Cannataro" <email address hidden> wrote:

> Arvin,
>
> I started noticing the glib problem when I tried to run the license
> program as part of installing Xilinx ISE 14, so I upgraded my Ubuntu
> from 12.4 to 14.4, thinking that would fix the problem, but it didn't
> and screwed-up Unity. I might need to install Ubuntu 14.4 from scratch
> when I have the time.
>
> Cheers,
> Bob
>
> On 9/23/2014 7:17 AM, Arvind Kumar wrote:
> > I also have the same problem when i install packages
> > (synaptic:3035): GLib-CRITICAL **: g_child_watch_add_full: assertion
> 'pid > 0' failed
> >
> > please do something
> >
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1282542
>
> Title:
> (synaptic:3405): GLib-CRITICAL **: g_child_watch_add_full: assertion
> 'pid > 0' failed
>
> Status in “synaptic” package in Ubuntu:
> Triaged
> Status in “synaptic” package in Debian:
> New
>
> Bug description:
> Got that new error each time i'm upgrading a package from synaptic
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: libc-bin 2.18-0ubuntu7
> ProcVersionSignature: Ubuntu 3.13.0-10.30-generic 3.13.3
> Uname: Linux 3.13.0-10-generic i686
> ApportVersion: 2.13.2-0ubuntu5
> Architecture: i386
> CurrentDesktop: GNOME
> Date: Thu Feb 20 13:26:55 2014
> Dependencies:
> gcc-4.9-base 4.9-20140217-0ubuntu1
> libc6 2.18-0ubuntu7
> libcap2 1:2.22-1.2ubuntu2
> libgcc1 1:4.9-20140217-0ubuntu1
> multiarch-support 2.18-0ubuntu7
> InstallationDate: Installed on 2013-10-25 (117 days ago)
> InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release i386
> (20131021.1)
> SourcePackage: eglibc
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/synaptic/+bug/1282542/+subscriptions
>

Diogo (mrchmod) wrote :

My Friends,

This is a short bug, Ubuntu will fix it eventualy, but do not worry
because it does not affect your system relaiability.

Best Regards,
Mr_Chmod @ Portugal
Ubuntu 14.04 TLS + BackBox + Windows 7
On 12-10-2014 14:00, elmossaoui wrote:
> i have the same problem on my ubuntu 14.10 beta 2
> (synaptic:4976): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
>

Diogo (mrchmod) wrote :
Download full text (3.2 KiB)

Yeah, this bug from Synaptic, *started *to *appear *on *Version 13 *I
believe, since I have Ubuntu *12.04 running *on a Backbox *distro *and I
*don't have that stupid pid > 0 failed e**rror. *

Just forget that error, I am more *concerned *in Ubuntu *upgrades*, I am
really *sad *since they launched V12.
Ubuntu 14.04 *last **release *that *should have been* a great version
(/Ubuntu is my preferred Operative System since ever/) it isn't, there
are *bugs everywhere*, *why *can't we have an Ubuntu *release *without
*Unity *like before, *why *can't we have a *login screen* interface
chooser like before.
There are *lots *of *Linux Distributions* with wonderful *login
**screens *running on *Ubuntu V12 *like /*"*/*/Cylon" /*for instance, it
is a *beautiful *Distro, and why? *Because *it is *BASED *on *UBUNTU
*version *12.04*. **
And if we *start *to *revert *stuff in 14.04 LTS to get things like they
were *before *Ubuntu starts to *slowdown *and give stupid errors. **
*I know that this should not be in here I am sorry but I am also sad:

They *should *release *an update for *all the distros* with this error
with a *popup Window saying* "*We are sorry for the inconvenience but
since pid > 0 error from Synaptic aka aptitude is a minimal bug that we
will fix eventually*" - I just wonder when **

Sometimes I think : "have they started to forget the meaning of UBUNTU ? "

_*Maybe someday they will change the distros name from Ubuntu to
something else. Since the meaning of the word stopped on version 12.04
*_************

*Ubuntu*(/ <http://en.wikipedia.org/wiki/Help:IPA_for_English>uː
<http://en.wikipedia.org/wiki/Help:IPA_for_English#Key
<http://en.wikipedia.org/wiki/Help:IPA_for_English#Key>b
<http://en.wikipedia.org/wiki/Help:IPA_for_English#Key
<http://en.wikipedia.org/wiki/Help:IPA_for_English#Key>n
<http://en.wikipedia.org/wiki/Help:IPA_for_English#Key>t
<http://en.wikipedia.org/wiki/Help:IPA_for_English#Key>uː
<http://en.wikipedia.org/wiki/Help:IPA_for_English#Key>/
<http://en.wikipedia.org/wiki/Help:IPA_for_English>/oo-*buun*-too/
<http://en.wikipedia.org/wiki/Wikipedia:Pronunciation_respelling_key>;Zulu
<http://en.wikipedia.org/wiki/Zulu_language>/Xhosa
<http://en.wikipedia.org/wiki/Xhosa_language>pronunciation: [ùɓúntʼú]
<http://en.wikipedia.org/wiki/Help:IPA>) is aNguni
<http://en.wikipedia.org/wiki/Nguni_languages>Bantu
<http://en.wikipedia.org/wiki/Bantu_languages>term roughly translating
to "human kindness." It is an idea from theSouthern African
<http://en.wikipedia.org/wiki/Southern_African>region which means
literally "human-ness," and is often translated as "humanity toward
others," but is often used in a more philosophical sense to mean "the
belief in a universal bond of sharing that connects all humanity".^[2]
<http://en.wikipedia.org/wiki/Ubuntu_%28philosophy%29#cite_note-2>

http://upload.wikimedia.org/wikipedia/commons/transcoded/0/0c/Experience_ubuntu.ogg/Experience_ubuntu.ogg.360p.webm
- This really hurts ...

"SOURCE: http://en.wikipedia.org/wiki/Ubuntu_(philosophy)"

On 12-10-2014 14:00, elmossaoui wrote:
> i have the same problem on my ubuntu 14.10 beta 2
> (synaptic:4976): GLib-CRIT...

Read more...

New Trusty 32 bit 386 install - I see this also. Is it serious? Is there a workaround?

It does not appear to be anything more than a nuisance.

On Sat, 2015-02-28 at 19:14 +0000, emarkay wrote:
> New Trusty 32 bit 386 install - I see this also. Is it serious? Is
> there a workaround?
>

Changed in synaptic (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Confirmed

Whoops! Fat finger changed status accidentally and can't change back to Triaged. Sorry.

Michal Wagner (wagner-michal) wrote :

Ubuntu 14.04.2 LTS Same
problem here

Attila Fenyvesi (fenya25) wrote :

And also in Ubuntu 15.04. It's the same.

atimonin (atimonin) wrote :

Also see it in 14.04 in synaptic

dino99 (9d9) on 2015-06-13
tags: added: vivid wily
dino99 (9d9) wrote :

maybe rebuilding synaptic with libvte-2.91-0 could help

description: updated
Changed in synaptic (Ubuntu):
status: Confirmed → Triaged

Hi all,
bug confirmed on Ubuntu Gnome 14.04 64bit fresh install.

I've noticed no functionality issues, all seems working fine, and I don't have installed bluefish yet.

dino99 (9d9) wrote :

Looks like the #39 Debian's post explain that issue

and libvte-2.91-0 has made the required change:

vte2.91 (0.40.2-1ubuntu1) wily; urgency=low

  * Rebase on Debian, remaining change:
    - debian/patches/91_keep_fds.patch:
      + Keep file descriptors open on vte_fork_pty()

 -- Iain Lane <email address hidden> Mon, 01 Jun 2015 13:35:49 +0100

So please, rebuilt synaptic with libvte-2.91-0

Confirmed on fresh install of Mint 17.2 (Ubuntu 14.04.3 LTS) 64 bit.

ggallozz (ggallozz-gmail) wrote :

Ubuntu Mate 14.04.03 32bits, same problem

kernel name is: Linux
kernel-release is: 3.16.0-46-generic
kernel version is: #62~14.04.1-Ubuntu SMP Tue Aug 11 16:28:19 UTC 2015
machine hardware is: i686
processor type is: i686
hardware platform is: i686
operating system is: GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.3 LTS
Release: 14.04
Codename: trusty

ltore123 (leventtore) wrote :

i killed '' Extracting templates from packages: 51%debconf: apt-extracttemplates failed'' after that syanaptic kept going on

Paulo Villi (paulovilli) wrote :

Having this issue in Linux Mint 17.2 for a few days now and it completely prevents me from applying updates with mint update manager... (tried selecting different individual packages each time hoping the bug affected one of them and not the whole process but it doesn't matter)

Is there a workaround I can try like reinstalling the affected package from a PPA or something? I have security updates pending from this and this has started to worry me :(

(synaptic:20090): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
Configurando shared-mime-info (1.2-0ubuntu3) ...
Failed to rename /usr/share/mime/application/x-dar.xml.new as /usr/share/mime/application/x-dar.xml: Is a directory
dpkg: error processing package shared-mime-info (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
E: Sub-process /usr/bin/dpkg returned an error code (1)
Um pacote falhou na instalação. Tentando recuperar:
Configurando shared-mime-info (1.2-0ubuntu3) ...
Failed to rename /usr/share/mime/application/x-dar.xml.new as /usr/share/mime/application/x-dar.xml: Is a directory
dpkg: error processing package shared-mime-info (--configure):
 sub-processo script post-installation instalado retornou estado de saída de erro 1
Erros foram encontrados durante o processamento de:
 shared-mime-info

Paulo Villi (paulovilli) wrote :

UPDATE: seems like "(synaptic:20090): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed" was not an issue on its own... I tried to delete the folder "/usr/share/mime/application/x-dar.xml" and replacing it with a copy of the file "/usr/share/mime/application/x-dar.xml.new" manually and now mint updates are back to work.

Sorry for not trying this before posting here... :)

PS: since the folder was not opening at all, I believe it was a corrupted file being seen by the system as a folder... fortunately no other damage is noticeable and deleting the folder didn't cause any other issues
PS2: had to use a liveboot Linux Mint pendrive to replace the folder with the file because NEMO (linux mint file explorer) *even when ran with administrative privileges (gksu)* said parent folder "/usr/share/mime/application/" was read only when I tried to copy the file, even though it had just let me delete the folder (go figure!?)

Tahir Imanov (tahir-imanov-19) wrote :

Same bug on Kali 2.0

Jim (JR) Harris (jimrh) wrote :

I'm on Mist 17.1 (didn't know there was a 17.2 - I'll have to go take a peek!)

I am disturbed by the repeated comments, both here and other places, that describe this error as a "nuisance".

Unfortunately, I am not a developer so my ability to investigate (fork) such-and-so is painfully limited. However, I *am* a user with at least a moderate amount of "clue", and I like to keep an eye on my logs as well as the messages that occur when I perform updates.

With respect to myself, (and I am sure this is true for many others as well), when I see *ANY* error message that has the word "CRITICAL**" in it, I naturally assume that something has balled-up in a non-trivial way, and it places my system at (at least) severe risk of something drastic happening.

As a QA engineer of some years standing, if I was testing a product, and it threw a "CRITICAL**" error - even if mistaken - I would flag it as at least a Sev-2, (High, but not critical), bug simply based on the violently scary message it presents. With respect to release, I would also rank it as a Severity-2 priority, (must-fix, ASAP), due to the message.

I fully understand - from the development point-of-view - this bug may be a "nuisance" bug, (pissy message, but no real crisis), but the vast majority of us are *NOT* developers, and having "nuisance" bugs flagged as "CRITICAL**" is potentially dangerous., since it tends to dull the user's vigilance - "Oh, another "CRITICAL" bug? Must be another bogus message. . . . since my system *seems* to be OK. . . . ."

Please, please, please re-think the priority and severity of this bug. It may be trivial to *YOU*, but I can absolutely assure you that it is *NOT* trivial to the rest of us.\

What say ye?

Jim (JR)

dino99 (9d9) on 2015-12-15
tags: removed: utopic
dino99 (9d9) wrote :

These deprecated comments have been fixed with the 0.82.5 package from the xenial archive. So it can be downloaded and then installed/upgraded with "sudo dpkg -i ....."

https://launchpad.net/ubuntu/+source/synaptic

note: as that issue is not a "security" issue, these fixes will not be backported.

synaptic (0.82.5) unstable; urgency=medium

  [ xuzhen ]
  * port from deprecated GdkColor to GdkRGBA
  * port from deprecated GtkFontSelectionDialog to GtkFontChooserDialog
  * get rid of the deprecated gtk_tree_view_set_rules_hint()
  * port from deprecated gdk_cursor_new() to gdk_cursor_new_for_display()
  * port from deprecated GtkHBox/GtkVBox to GtkBox
  * port from deprecated gtk_vscrollbar_new() to gtk_scrollbar_new()
  * get rid of the deprecated GtkStock

 -- Michael Vogt <email address hidden> Sun, 13 Dec 2015 10:46:17 +0100

dino99 (9d9) wrote :
no longer affects: vte
Changed in synaptic (Ubuntu):
status: Triaged → Fix Released
Changed in synaptic (Debian):
importance: Unknown → Undecided
status: New → Fix Released
summary: - (synaptic:3405): GLib-CRITICAL **: g_child_watch_add_full: assertion
- 'pid > 0' failed
+ GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
drMerry (invullen) wrote :

Still affects 15.04...

adrhc (adrhc) wrote :

Still affects 15.10 ...

Mikko (mikser) wrote :

Still affects Linux Mint 17.3 Cinnamon 64-bit (Cinnamon version 2.8.8, Linux Kernel: 3.19.0-32-generic)...

KitchM (tech-frontrowcomputer) wrote :

(synaptic:2898): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed
Today on 14.04 64-bit.

KitchM (tech-frontrowcomputer) wrote :

From Synaptic error message:

E: /var/cache/apt/archives/libgl1-mesa-dri-lts-xenial_11.2.0-1ubuntu2~trusty1_i386.deb: trying to overwrite shared '/etc/drirc', which is different from other instances of package libgl1-mesa-dri-lts-xenial:i386

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.