Ubuntu

swift config doesn't match upstart expectations, required upstart configurations not installed.

Reported by Greg Althaus on 2012-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
swift (Ubuntu)
High
James Page
Precise
High
James Page

Bug Description

In precise beta-1, the swift-object packages put the config files in /etc/swift/object-server.conf, but the upstart script expects the config file to exist in /etc/swift/object-server/object-server.conf. This applies to all the swift-* packages.

Also, the object, container, and account packages are missing replicator, updater, and reaper upstart configs.

summary: - swift config doens't match upstart expectations
+ swift config doesn't match upstart expectations

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/954477/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment

adding a package that has the problem, but this applies to all the swift-* packages

affects: ubuntu → swift (Ubuntu)
Changed in swift (Ubuntu):
importance: Undecided → Medium
James Page (james-page) wrote :

The way that the upstart configurations are generated in the packaging means that the additional upstart configuration files are not build into each of the packages.

Changed in swift (Ubuntu):
status: New → Confirmed
importance: Medium → High
milestone: none → ubuntu-12.04-beta-2
summary: - swift config doesn't match upstart expectations
+ swift config doesn't match upstart expectations, required upstart
+ configurations not installed.
Changed in swift (Ubuntu Precise):
assignee: nobody → James Page (james-page)
James Page (james-page) on 2012-03-15
Changed in swift (Ubuntu Precise):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package swift - 1.4.7-0ubuntu2

---------------
swift (1.4.7-0ubuntu2) precise; urgency=low

  * Fixup upstart configurations (LP: #954477):
    - d/rules: Correctly generate ALL upstart configurations when
      building for Ubuntu.
    - d/*.upstart.in: Update upstart config's to use new conf file locations.
 -- James Page <email address hidden> Thu, 15 Mar 2012 15:34:19 +0000

Changed in swift (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers