sweethome3d does not start

Bug #769038 reported by Stapel on 2011-04-22
This bug affects 9 people
Affects Status Importance Assigned to Milestone
sweethome3d (Debian)
Fix Released
sweethome3d (Ubuntu)

Bug Description

Binary package hint: sweethome3d

I installed the application from the software centre but when I click on the icon it does not start. When I try to run it from the commandline I get the following:

stapel@stapel-VirtualBox:~$ sweethome3d
[warning] /usr/bin/sweethome3d: Unable to locate /usr/lib/jvm/java-6-sun/jre/lib/javaws.jar in /usr/share/java
Exception in thread "main" java.lang.NoClassDefFoundError: javax/jnlp/UnavailableServiceException
Caused by: java.lang.ClassNotFoundException: javax.jnlp.UnavailableServiceException
 at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
 at java.security.AccessController.doPrivileged(Native Method)
 at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
 at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
Could not find the main class: com.eteks.sweethome3d.SweetHome3D. Program will exit.

I am using Ubuntu 11.04, and the application version is 2.6+dfsg-1, which I think is quite outdated.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: sweethome3d 2.6+dfsg-1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Fri Apr 22 17:37:18 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
PackageArchitecture: all
SourcePackage: sweethome3d
UpgradeStatus: Upgraded to natty on 2011-03-25 (28 days ago)

Stapel (wstapelberg) wrote :
Hans Joachim Desserud (hjd) wrote :

I get the same error message when attempting to run sweethome3d on Ubuntu Natty.

PS. See bug 728669 regarding a possible upgrade.

Changed in sweethome3d (Ubuntu):
status: New → Confirmed
Gustavo (beninatig) wrote :

Install Java

In a Terminal window execute:

sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

To accept the license press TAB and ENTER.


Joachim R. (jro) wrote :

I have the same problem with a fresh new iontall of sweethome3d on the eeepc I just upgraded to Natty.
It is strange since sweethome3d is running fine on my desktop where it was installed before I upgraded to Natty.
Both have openjdk 6.

anfi (an-finke) wrote :

I have the same problem. Have a fresh install of ubuntu 11.04 an sweethome3d and I get the same message if I execute sweethome3d in the terminal.

cameleon (el-cameleon-1) wrote :

> sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts
> To accept the license press TAB and ENTER.

Works for me but why isn't it installed automatically???

summary: - Application does not start
+ sweethome3d does not start
Mossroy (mossroy) wrote :

The same bug existed on Debian and has been closed : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=626050

The fix seems to be backported in version 3.1+dfsg-1ubuntu1 of this package, that should be shipped with oneiric : see the changelog in https://launchpad.net/ubuntu/+source/sweethome3d/3.1+dfsg-1ubuntu1
Installing this package on oneiric makes sweethome3d runnable with default jre (openjdk-6), without the need to install sun-java6.
It also works if you install this version on natty (but you have to force the installation with a dpkg --force-depends-version).

Anyway, I noticed that 3D performance was much better with the Sun JDK (at least with the one bundled in the .tgz downloadable on the official site : http://www.sweethome3d.com/fr/download.jsp) than with openjdk-6. I'm not sure if I tested the package sun-java6 of ubuntu (it should be the same as Sun JDK).

I might be wrong, but it seems to me that Sun JDK has some 3D hardware acceleration (and/or optimization) that is not enabled in openjdk-6. I tested openjdk-7 (in a beta version, some time ago), and noticed that the performance was the same as with Sun JDK. See http://www.sweethome3d.com/support/forum/viewthread_thread,1658
Unfortunately, openjdk-7 will not yet be the default jre for oneiric (still openjdk-6)

Changed in sweethome3d (Debian):
status: Unknown → Fix Released
Stapel (wstapelberg) wrote :

I have since upgraded to 12.10 and when I launch it now it does work. I don't know whether this is still a problem for 11.04 though.

Hans Joachim Desserud (hjd) wrote :

This issue does indeed seem to be resolved in Ubuntu 11.10 and later versions. Thus, I'm marking it fix released.

Normally it is possible to request fixes present in newer versions of Ubuntu to be backported [1] to previous versions. However, since 11.04 reached End of Life on October 28, 2012, this is not likely to happen. Please see https://wiki.ubuntu.com/UbuntuBackports for more info on backports.

Changed in sweethome3d (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.