Ubuntu

Very slow openoffice base after update to java-6-sun-1.6.0.24jre

Reported by David Buckley on 2011-02-24
64
This bug affects 12 people
Affects Status Importance Assigned to Milestone
sun-java6 (Debian)
Fix Released
Unknown
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 10.10 kernal 2.6.35-25 gnome 2.32.0
Open office base was very slow using java-6-sun-1.6.0.20jre with accessibility which was the ubuntu 10.10 standard. I found a post that said install java-6-sun-1.6.0.22jre. This fixed the problem and the database was very fast and stable.
On (23 Feb 2011) there was an update on update manager to java-6-sun-1.6.0.24jre which I have installed and know the database is very slow just like it was on version 20. I have tried to go back to version 22 using the file in /var/cache/apt/archives but the system wont let me install an older version.
Many Thanks David

Eduardo Cavalieri (eduardoecp) wrote :

Here's how I solved the problem:

I've installed Libreoffice for Windows and Java (JRE) Windows version using Wine. It's crucial to download the right file, which can be found here (http://appdb.winehq.org/objectManager.php?sClass=version&iId=6626). Java is important because without it the LO Base won't work at all. Now it works great. This is a temporary solution, until they release another version of Libreoffice or JRE.

David Buckley (david-buckley) wrote :

Thanks for the reply
I have also found a temporary solution as follows
Download the version 22 bin file from jre using the links at this site or use the file stored in /var/cache/apt/archive.
Remove version 24 using synaptic restart the machine, remove the network connection, manually install version 22 from the bin file, restart the machine, open synaptic and lock the 2 entries for version 22 from further changes. Reconnect to the network and make 22 the active jre in openoffice via tools, options. The data base now performs very well again.
David

Brock Riedell (kbrcbc) wrote :

I am using Ubuntu 10.04, and have experienced this bug with both the LibreOffice and OpenOffice versions of Base, and both versions 20 and 24 of the Sun JRE. Any suggestions where I can find a version 22 JRE?

Sylvestre Ledru (sylvestre) wrote :

@Brock: http://snapshot.debian.org/package/sun-java6/
Release 22 should be the same between Debian and Ubuntu

Brock Riedell (kbrcbc) wrote :

I found a solution in the LibreOffice mailing list, which installs JRE version 1.6.0_21 and solves the slow performance issue:

(1) Completely uninstall sun-java6-bin and sun-java6-jre using Synaptic;
(2) remove Partners as a source;
(3) add the following two lines to your software sources:
deb http://ppa.launchpad.net/sun-java-community-team/sun-java6/ubuntu Maverick Main
deb-src http://ppa.launchpad.net/sun-java-community-team/sun-java6/ubuntu Maverick Main
(in my case, of course, I needed to use 'ubuntu lucid main' repositories instead)
(4) install sun-java6-bin.
(5) in Open/LibreOffice Tools > Options > Java, select the JRE version 1.6.0_21.

I had all the above problems after upgrade. Need my system for work and the only acceptable solution was to upgrade OpenOffice to 3.3 (from Oracle not from Distro) and to upgrade Java to 24. To connect you have to have the Oracle java connector (from Oracle not from Distro) for MySql then all works like a charm.

Hope this helps.

Good luck!

Sylvestre Ledru (sylvestre) wrote :

It would be nice if anyone could provide a test case which reproduce this issue ...

David Buckley (david-buckley) wrote :

As I wrote on 26 Feb 2011 the easy way to get round this until version 24 works like version 22 is to remove 24 and install version 22 which is available from the jre links on this site but you need to disconnect the network while you install, also lock version 22 before going back on line.
Regarding a test case, version 20 which I think is the default on ubuntu is still installed on my machine and a very quick test can be done by just changing between 20 & 22 in open office.
David

bccoulomb (bc3-142) wrote :

I have the same problem. Clearly it is a conflict between Ubuntu 10.10 and Java24. I had it with OO and it is also present with LibreOffice.
bccoulomb

vichi (vidichi) wrote :

I have the same problem on ubuntu 10.04 LTS (x86_64) Linix 2.6.32-29 and OpenOffice 3.2.0.
I have also a very slow startup of openoffice that OOo is trying to resolve the local hostname on the network...
I the solution explained hereunder solved the startup problem :

http://www.linuxquestions.org/questions/linux-software-2/double-clicking-on-open-office-files-leads-to-very-slow-opening-808048/

vichi.

Sylvestre Ledru (sylvestre) wrote :

We would like a small test case to forward upstream. Ie a few lines of codes which are fast before 24 and slow with 24

Bob Blanchard (blabj) wrote :
Download full text (3.3 KiB)

This happens on 10.04.2 LTS (x86_64) linux 2.6.32-30-generic with OO 3.2.0 as well.

Its not just OO Base.. general OO Basic macro execution in OO Calc spreadsheets execute 4 to 5 times slower than with previous JRE (22).

As a test case - creating a JDBC database connection "datasource1" (be sure to install necessary java class files for particular databse) and use the following macro in a Calc spreadsheet:

REM ***** BASIC *****

Global Pipe_connectedDatabase As Boolean ' Are we connected to the database?
Global Pipe_dConn as Variant
Global Pipe_dStat as Variant

function pipe (f_s as string) as variant
    on error goto err_h

 Dim dataType As Long ' What type of data was returned by the database?
 dim url as String
 dim driver as String
 dim dBase as Variant
 dim oDB as Variant
 dim oManager as Variant
 dim oMetaData as Variant
 dim connArgs(0) As New com.sun.star.beans.PropertyValue
 ' These declarations below are for casting data types around in BASIC
 Dim tmpDouble As Double ' Temporary holder for a double datatype, for inserting into Any
 Dim tmpString As String ' Temporary holder for a string datatype, for inserting into Any

 ' Actual database query
 if Pipe_connectedDatabase = false then
        dBase = createUnoService("com.sun.star.sdb.DatabaseContext")
        oDB = dBase.getByName("datasource1")
        url = oDB.URL
        driver = oDB.Settings.JavaDriverClass
        oManager = createUnoService ("com.sun.star.sdbc.DriverManager")
        connArgs(0).name = "JavaDriverClass"
        connArgs(0).value = driver
        Pipe_dConn = oManager.getConnectionWithInfo (url, connArgs)
        Pipe_connectedDatabase = true
        Pipe_dStat = Pipe_dConn.createStatement()
    end if
 oSet = Pipe_dStat.executeQuery (f_s)

 ' Datatype casting logic
 if oSet.next () then
  ' Get a LONG representation of the type of data that was returned by the
  ' database
  dataType = oSet.getMetaData().getColumnType(1)
  Select Case dataType

   Case com.sun.star.sdbc.DataType.CHAR
    tmpString = RTrim(oSet.getString(1))
    ret_val = tmpString

   Case com.sun.star.sdbc.DataType.SMALLINT
    tmpDouble = oSet.getDouble(1)
    ret_val = tmpDouble

   Case com.sun.star.sdbc.DataType.INTEGER
    tmpDouble = oSet.getDouble(1)
    ret_val = tmpDouble

   Case com.sun.star.sdbc.DataType.DECIMAL
    tmpDouble = oSet.getDouble(1)
    ret_val = tmpDouble

   Case com.sun.star.sdbc.DataType.VARCHAR
    tmpString = RTrim(oSet.getString(1))
    ret_val = tmpString

   Case com.sun.star.sdbc.DataType.DATE
    tmpString = Trim(oSet.getString(1))
    ret_val = tmpString

   Case Else
    ' Insert unknown types as string
    tmpString = RTrim(oSet.getString(1))
    ret_val = tmpString

  End Select

 else
   ret_val = "##NULL##"
 end if
 pipe = ret_val
 exit function
err_h:

 if Pipe_connectedDatabase = true then
  Pipe_dConn.close()
  Pipe_connectedDatabase = false
 endif

 pipe = "##ERROR##"
 exit function
end function

To test it.. in a cell enter: =pipe("select count(*) from sometable")

(sometable being the name of actual database table)

This should return the number of rows and insert it in the cell as a value (If you only get ##ERROR## - suspe...

Read more...

vichi (vidichi) wrote :

I found a temporary solution explained very well here :

http://hardc0l2e.wordpress.com/2011/04/05/libreoffice-openoffice-base-slow/

Java jre 6.21 is installed in the home/bin folder.

Sylvestre Ledru (sylvestre) wrote :

FYI, version 25 of sun-java6 fixes this issue.

Changed in sun-java6 (Debian):
status: Unknown → New
Onesimus (joe-heaton) wrote :

@Sylvestre Ledru

When will version 25 appear in the repositories ?

Sylvestre Ledru (sylvestre) wrote :

I don't know.
You should ask for a sync from debian.

If you go to this link and install version 21 into your home directory
and then set it as default in open office or libreoffice ( tools options
java) it works fine.

I have tried it on both 32 bit and 64 bit and both are fast.

It also works with 10.10 and 11.04 ubuntu and possibly older.

http://hardc0l2e.wordpress.com/2011/04/05/libreoffice-openoffice-base-slow/

David

On Tue, 2011-05-24 at 16:09 +0000, Onesimus wrote:
> @Sylvestre Ledru
>
> When will version 25 appear in the repositories ?
>

Konstantinos Spalas (konnn) wrote :

The solution is indeed the downgrade of jre as told before.

Changed in sun-java6 (Debian):
status: New → Fix Released
Changed in sun-java6 (Ubuntu):
status: New → Confirmed
giuliano69 (giuliano-lotta) wrote :

Tryed with version java 6.26, but same result....

giuliano@voyager2:~$ java -version
java version "1.6.0_26"
Java(TM) SE Runtime Environment (build 1.6.0_26-b03)
Java HotSpot(TM) Server VM (build 20.1-b02, mixed mode)

Same result with Open JKD installed as alternative-java

ONLY version 21 solved the problem.

(did NOT tryed package gij-jre that seems to be ALSO a solution in some forums...)

giuliano69 (giuliano-lotta) wrote :

update...
tried also with last package gij-jre (4.5).... a nightmare.....

stay GLUED to java-6 version 21.... VERY fast

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.