[Lucid] sun-java6-plugin not recognized by firefox anymore

Bug #532174 reported by Philip Muškovac on 2010-03-04
308
This bug affects 66 people
Affects Status Importance Assigned to Milestone
openjdk-6 (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
sun-java6 (Ubuntu)
Medium
Matthias Klose
Lucid
Medium
Matthias Klose

Bug Description

In lucid firefox 3.6 doesn't seem to recognize the plugin in /usr/lib/xulrunner-addons/plugins/ anymore, putting the symlink in /usr/lib/mozilla/plugins/ works, so the following part of the java debian/rules should be changed (line 66ff)

# FIXME: xulrunner-addons only tested on sid, jaunty, karmic
ifeq ($(distribution),Ubuntu)
  browser_plugin_dirs = xulrunner-addons firefox iceape iceweasel mozilla midbrowser xulrunner
  browser_plugin_dirs = xulrunner-addons
else
  browser_plugin_dirs = mozilla
endif

It works fine too if you just remove that.

apt-cache policy sun-java6-plugin
sun-java6-plugin:
  Installed: 6.18-2
  Candidate: 6.18-2
  Version table:
 *** 6.18-2 0
        600 http://archive.canonical.com lucid/partner Packages

Philip Muškovac (yofel) on 2010-03-04
tags: added: lucid
Eddie Hung (eddieh) wrote :

Confirmed this works.

Changed in sun-java6 (Ubuntu):
status: New → Confirmed

I have Sun Java installed, but it is not showing up in the plugins list in Firefox.

Philip Muškovac (yofel) on 2010-03-14
description: updated
Philip Muškovac (yofel) on 2010-03-15
Changed in sun-java6 (Ubuntu):
importance: Undecided → Medium
sara (ms-sara-griffin) wrote :

this also affects me

sara (ms-sara-griffin) wrote :

sudo update-alternatives --install /usr/lib/mozilla/plugins/mozilla-javaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 1

should fix this

sara's command does fix this bug!

Ancoron Luziferis (ancoron) wrote :

confirmed.

Issue the following on AMD64 platforms:

sudo update-alternatives --install /usr/lib/mozilla/plugins/mozilla-javaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so 1

Jonathan Davies (jpds) on 2010-03-24
Changed in sun-java6 (Ubuntu):
milestone: none → ubuntu-10.04-beta-2
Changed in sun-java6 (Ubuntu Lucid):
assignee: nobody → Matthias Klose (doko)

Hi, the following command fixed this issue for me:

sudo update-alternatives --install /usr/lib/mozilla/plugins/mozilla-javaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so 1

I am using Core Due Intel though.

Regards,

Alan

James Troup (elmo) on 2010-03-29
tags: added: regression-potential
Gene (gliverman) wrote :

This fixed a clean install of Lucid beta that was first fully updated (THANKS!):

update-alternatives --install /usr/lib/mozilla/plugins/mozilla-javaplugin.so mozilla-javaplugin.so /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so 1

jatin sachdeva (jatin-sachdeva) wrote :

the command posted above fixed it for me - i can see java under about:plugins in firefox now!

Josef Andersson (northar) wrote :

This is a must fix - if it's hard to install a working Java, new users will be scared away. Right now, some banks here in Sweden need Oracles'/Sun's Java to work properly.

Also many corporate users use Java Citrix Client.

Changed in openjdk-6 (Ubuntu Lucid):
status: New → Confirmed
Matthias Klose (doko) on 2010-04-05
Changed in openjdk-6 (Ubuntu Lucid):
status: Confirmed → Invalid
summary: - [Lucid] sun-java6-plugin not recognized by firefox anymore
+ [Lucid] any java-plugin not recognized by firefox anymore
Philip Muškovac (yofel) wrote :

This doesn't affect the icedtea plugin, it properly adds the alternative for mozilla.

summary: - [Lucid] any java-plugin not recognized by firefox anymore
+ [Lucid] sun-java6-plugin not recognized by firefox anymore
Philip Muškovac (yofel) wrote :

Here's a debdiff that will install the alternative for the mozilla directory if it helps to speed things up.

What about open6-jre? They not recognized too.

Philip Muškovac (yofel) wrote :

@RussianNeuroMancer: Icedtea is the openjdk plugin and if I install it here then it does show in firefox about:plugins. So if it doesn't work for you then you have a different problem.

Alexander Sack (asac) wrote :

yes, drop the xulrunner-addons dir now ... mozilla is good enough

Philip Muškovac (yofel) wrote :

Thanks for uploading

sun-java6 (6.19-0ubuntu3) lucid; urgency=low

  * Install the plugin for mozilla too (LP: #532174)

Date: Mon, 05 Apr 2010 12:35:02 +0200
Changed-By: Philip Muskovac <email address hidden>
Maintainer: Debian Java Maintainers <email address hidden>
Signed-By: Matthias Klose <email address hidden>
https://launchpad.net/ubuntu/lucid/+source/sun-java6/6.19-0ubuntu3

Changed in sun-java6 (Ubuntu Lucid):
status: Confirmed → Fix Released

Hi,
the command using update-alternatives didn't work for me, I had to manually create the link :

sudo ln -sf /usr/lib/jvm/java-6-sun/jre/lib/i386/libnpjp2.so /usr/lib/mozilla/plugins/mozilla-javaplugin.so

I'm using Lucid (fresh installation, only kept my home dir), OpenJDK has been installed prior to Sun JRE.

The above AMD64 solution in a clean install did not work for me, yielding this error:

update-alternatives: error: alternative path /usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so doesn't exist.

The libnpjp2.so file indeed does not exist in that folder, though the path does exist.

Hey, there status of openjdk bug is invalid (by the way, why?), and here https://bugs.launchpad.net/ubuntu/+source/openjdk-6/+bug/555868 nobody answer. Can somebody from Canonincal look at openjdk bug?

Philip Muškovac (yofel) wrote :

@Merle: The file is part of 'sun-java6-bin' - Please make sure you have that package installed. (It should get installed as a depends though...)

@RussianNeuroMancer: OpenJDK (IcedTea) isn't affected by *this* bug. If java doesn't work for you, you probably have a different issue.

I apologize. I realize I may have ended up in the wrong bug. My issue is that the Java applet works in Firefox but not in SeaMonkey. A search in Symantec yields no results for 'sun-java6-bin', however, though that may not be relevant now.

starslights (starslights) wrote :

Hello,

This bug are present on Mavrick 10.10 alpha1 64 bits and crash the whole browser, it affect any browser, not only Firefox...

starslights (starslights) wrote :

Hello,

Yesterday was some update for Mavrick 10.10 for my x86 64 and the bug was fixed after apply it.

Today ,a couple minutes ago, was a update for Lucid 10.04 x86 64 and now the java bug are fixed too,

So thanks very much, be happy that java work now..

Best regards

stars

I wonder when someone take care on openjdk bug from link above?

Frank Gross (f-gross) wrote :

@RussianNeuroMancer, it seems that this has been fixed already. After having some trouble with open-jdk's mozilla plugin, I removed the package via synaptic completely and installed sun-java6-plugin with all it's dependencies. After restarting firefox, the applets I had trouble with under open-jdk worked without problems anymore. Just FYI...

Bruce Edge (bruce-edge) wrote :

Even with the above suggestions, I still get this on any site that attempts to read my java config, eg: http://www.java.com/en/download/help/testvm.xml

java.lang.ClassNotFoundException: testvm2.Main.class
 at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:219)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
 at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:532)
 at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:2940)
 at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1444)
 at java.lang.Thread.run(Thread.java:619)
Caused by: java.net.ConnectException: Connection timed out
 at java.net.PlainSocketImpl.socketConnect(Native Method)
 at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
 at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
 at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
 at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
 at java.net.Socket.connect(Socket.java:529)
 at sun.net.NetworkClient.doConnect(NetworkClient.java:161)
 at sun.net.www.http.HttpClient.openServer(HttpClient.java:394)
 at sun.net.www.http.HttpClient.openServer(HttpClient.java:529)
 at sun.net.www.http.HttpClient.<init>(HttpClient.java:233)
 at sun.net.www.http.HttpClient.New(HttpClient.java:306)
 at sun.net.www.http.HttpClient.New(HttpClient.java:323)
 at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(HttpURLConnection.java:860)
 at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:801)
 at sun.net.www.protocol.http.HttpURLConnection.connect(HttpURLConnection.java:726)
 at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1049)
 at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:373)
 at sun.plugin2.applet.Applet2ClassLoader.getBytes(Applet2ClassLoader.java:535)
 at sun.plugin2.applet.Applet2ClassLoader.access$000(Applet2ClassLoader.java:51)
 at sun.plugin2.applet.Applet2ClassLoader$1.run(Applet2ClassLoader.java:192)
 at java.security.AccessController.doPrivileged(Native Method)
 at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:189)
 ... 6 more

Ancoron Luziferis (ancoron) wrote :

@Thag:

You are into something completely different. This bug just handles the registration of the sun-java plugin.

Looking at the stacktrace you provided I see that you are already using the plugin. But on your side something prevents it from remotely loading classes on demand:
Caused by: java.net.ConnectException: Connection timed out

So do you already checked your firewall rules or e.g. your proxy/nat/routing? Looks like something in between just drops the packets that the plugin sends.

Bruce Edge (bruce-edge) wrote :

You're right. I just changed from using a proxy .pac file to an explicit proxy addr in the java control panel and it works now.

So, java does not work with proxy pac files!!!

Maybe this little bit will save someone else the weeks I've spent on this.

Download full text (3.2 KiB)

>>> http://healthpor.ru

- There is no reason to feel depressed if you, like so many other men today, have hit the rough spot of your sexual life when you cannot seem to be performing as well as you used to do. Your agitation and frustration are easily understood, and still you should know that with the modern development of worldwide pharmacological industries it is but natural that there is bound to be a solution for your own needs when it comes down to solving your erectile dysfunction problems.

- We suggest you getting erectile dysfunction drugs from our online drugstore cheaply, easily and without much to-do. You will always be taken care of and attended to with extreme care, and you will have the possibility of choosing from a wide range of erectile dysfunction products to find a solution that will best suit your particular needs.

- The whole world puts great trust in those famous diamond shaped pills, and if you are not an exception we would like to revise some basic points that speak in favor of putting your male health in the hands of those magical tablets.
Firstly, there is no need for regular therapy – those blue pills have to be taken directly before the planned sexual contact, and extra convenience shines through when you come to realize that the pills will not start working unless sufficient sexual stimulation is provided.

- Secondly, this erectile dysfunction solution is known for its extremely low adverse side effects profile, which makes it available for all age groups of patients. Besides, it really does not matter how old you are when it goes about taking erectile dysfunction pills – just make sure that you do not overdose, and they will work for you at their best!

- Finally, those fabulous pills do not only provide you with stable erection that can be maintained for as long as you need it – they also help you to achieve unheard sensitivity during the sexual act as well as make your genitals look much more sizey!

- Think of all those benefits of taking erectile dysfunction pills and the effect you can produce on your loved one – and do not hesitate to make your order and / or refills right away!

--- > http://healthpor.ru < ---

 _V______C________L
 ___I_______I_______E
 _____A_______A_______V
 _______G_______L_______I
 _________R_______I_______T
 ___________A_______S_______R
 _____________________________A

   You should try this just to feel confidence your ancestors felt, while performing an original sin. Super stiffness all night and no harmful side effects at all! Try now and show your babe some action!
-
 - - -
--------- http://healthpor.ru
 - - -
-
                                             ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers