Ubuntu

java plugin not working in firefox 3 on ubuntu 8.04

Reported by Diego Collaziol on 2007-12-04
280
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
epiphany-browser (Ubuntu)
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned
icedtea-gcjwebplugin (Ubuntu)
Undecided
Matthias Klose
sun-java5 (Ubuntu)
Undecided
Unassigned
sun-java6 (Ubuntu)
Undecided
Unassigned

Bug Description

Java viltual keyboard are not working on bank sites. Used to work on kubuntu 7.10 up to date. I'm using kubuntu hardy packages from 04/12/07.
Java is not working on Firefox3 too.
Pls advice about what info you need.

Alexander Sack (asac) wrote :

which java package did you install?

Changed in firefox:
status: New → Incomplete

I reinstaled gutsy from beggining and all is working by default. I
cannot remember what package I used that time, almost sure sun-java6

Diego

2008/1/3, Alexander Sack <email address hidden>:
> which java package did you install?
>
> ** Changed in: firefox (Ubuntu)
> Status: New => Incomplete
>
> --
> java not working in firefox on kubuntu 8.04
> https://bugs.launchpad.net/bugs/173966
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I can confirm the bug for Ubuntu 8.10 clean install, with firefox 3.0.
In Firefox 2 you can choose between 4 different java things.
In Firefox 3 you must do a manual installation, but the link with more details just drops you on the java website.

On Sun, Feb 03, 2008 at 11:13:09PM -0000, amedee wrote:
> I can confirm the bug for Ubuntu 8.10 clean install, with firefox 3.0.
> In Firefox 2 you can choose between 4 different java things.
> In Firefox 3 you must do a manual installation, but the link with more details just drops you on the java website.
>

yes, some packages do not yet have the files linked to the proper
place.

firefox 3 plugins should be linked to /usr/lib/xulrunner-addons/plugins/

 affects ubuntu/sun-java6
 status confirmed
 affects ubuntu/sun-java5
 status confirmed

Thanks,

 - Alexander

Alexander Sack (asac) wrote :

On Sun, Feb 03, 2008 at 11:13:09PM -0000, amedee wrote:
> I can confirm the bug for Ubuntu 8.10 clean install, with firefox 3.0.
> In Firefox 2 you can choose between 4 different java things.
> In Firefox 3 you must do a manual installation, but the link with more details just drops you on the java website.
>

forgot to invalidate the firefox targets.

 affects ubuntu/firefox
 status invalid
 affects ubuntu/firefox-3.0
 status invalid

 - Alexander

Changed in firefox:
status: Incomplete → Invalid

Alexander,

If you know of a workaround for the problem, could you post some details?

Chris

I can confirm this bug.

===============
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb7d7c767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb7d7c8b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb545929d]
#3 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb55498ce]
#4 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb5526067]
#5 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb5526318]
#6 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb552661f]
#7 [0xb5d0becd]
#8 [0xb5d04edd]
#9 [0xb5d04edd]
#10 [0xb5d02249]
#11 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c40d]
#12 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x6310378]
#13 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c2a0]
#14 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x363) [0x6272153]
#15 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb7d1d96d]
#16 [0xb5d0becd]
#17 [0xb5d04d77]
#18 [0xb5d02249]
#19 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c40d]
java_vm: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Could not read ack from child process
Plugin: Java VM process has died.
plugin: java process died due to signal 6
  a core file was generated
Could not start JavaVM!

VM did not start up properly

tomaszko (kossut) wrote :

true mates no java applets

Hi,

Not strictly true for me, I do have some applets via the IcedTea plugin.
The applet test pages (http://www.java.com/en/download/help/testvm.xml)
appear ok but the one I need most fails silently with "Applet not
initialized"

Chris

On Tue, 2008-02-26 at 20:37 +0000, tomaszko wrote:
> true mates no java applets
>

Hi,

Not strictly true for me, I do have some applets via the IcedTea plugin.
The applet test pages (http://www.java.com/en/download/help/testvm.xml)
appear ok but the one I need most fails silently with "Applet not
initialized"

Chris

Download full text (4.5 KiB)

I did some more debugging and found that it is not working for the e-trade realtime quote streamer probably because of a problem with Iced Tea itself - this is the error log;

GCJ PLUGIN: thread 0x805f070: plugin_in_pipe_callback: setting status load: class etrade.mcaster.Streamer not found.
load: class etrade.mcaster.Streamer not found.
java.lang.ClassNotFoundException: etrade.mcaster.Streamer
  PIPE: plugin read: status load: class etrade.mcaster.Streamer not found.
GCJ PLUGIN: thread 0x805f070: plugin_in_pipe_callback return
 at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:201)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:323)
 at sun.applet.AppletClassLoader.loadClass(AppletClassLoader.java:145)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:268)
 at sun.applet.AppletClassLoader.loadCode(AppletClassLoader.java:644)
 at sun.applet.AppletPanel.createApplet(AppletPanel.java:796)
 at sun.applet.AppletPanel.runLoader(AppletPanel.java:725)
 at sun.applet.AppletPanel.run(AppletPanel.java:379)
 at java.lang.Thread.run(Thread.java:674)
Caused by: java.net.SocketException: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: Default, provider: SunJSSE, class: sun.security.ssl.DefaultSSLContextImpl)
 at javax.net.ssl.DefaultSSLSocketFactory.throwException(SSLSocketFactory.java:196)
 at javax.net.ssl.DefaultSSLSocketFactory.createSocket(SSLSocketFactory.java:216)
 at sun.net.www.protocol.https.HttpsClient.afterConnect(HttpsClient.java:383)
 at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:185)
 at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1020)
 at java.net.HttpURLConnection.getResponseCode(HttpURLConnection.java:397)
 at sun.net.www.protocol.https.HttpsURLConnectionImpl.getResponseCode(HttpsURLConnectionImpl.java:338)
 at sun.applet.AppletClassLoader.getBytes(AppletClassLoader.java:302)
 at sun.applet.AppletClassLoader.access$100(AppletClassLoader.java:62)
 at sun.applet.AppletClassLoader$1.run(AppletClassLoader.java:191)
 at java.security.AccessController.doPrivileged(Native Method)
 at sun.applet.AppletClassLoader.findClass(AppletClassLoader.java:188)
 ... 8 more
Caused by: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: Default, provider: SunJSSE, class: sun.security.ssl.DefaultSSLContextImpl)
 at java.security.Provider$Service.newInstance(Provider.java:1262)
 at sun.security.jca.GetInstance.getInstance(GetInstance.java:236)
 at sun.security.jca.GetInstance.getInstance(GetInstance.java:164)
 at javax.net.ssl.SSLContext.getInstance(SSLContext.java:142)
 at javax.net.ssl.SSLContext.getDefault(SSLContext.java:85)
 at javax.net.ssl.SSLSocketFactory.getDefault(SSLSocketFactory.java:119)
 at javax.net.ssl.HttpsURLConnection.getDefaultSSLSocketFactory(HttpsURLConnection.java:344)
 at javax.net.ssl.HttpsURLConnection.<init>(HttpsURLConnection.java:302)
 at sun.net.www.protocol.https.HttpsURLConnectionImpl.<init>(HttpsURLConnectionImpl.java:85)
 at sun.net.www.protocol.https.Handler.openConnection(Handler.java:62)
 at sun.net.www.protocol.https.Handler...

Read more...

mexlinux (mcanedo) wrote :

I can confirm that FF3 and Java6 works at Hardy Alpha 6 only after applying both proposed solutions:
$ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
$ cd /usr/lib/firefox-addons/plugins/
$ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.so

On Sat, March 8, 2008 02:24, mexlinux wrote:
> I can confirm that FF3 and Java6 works at Hardy Alpha 6 only after
> applying both proposed solutions:
> $ sudo sed -i 's/XINERAMA/FAKEEXTN/g'
> /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
> $ cd /usr/lib/firefox-addons/plugins/
> $ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.so

I can confirm that it still does not work for me after applying these
proposed solutions.
Hardy, Firefox 3 beta 3.

Example: Facebook Touchgraph Browser gives java.lang.NullPointerException

--
Amedee

> mexlinux typed :
> I can confirm that FF3 and Java6 works at Hardy Alpha 6 only after applying both proposed solutions:
> $ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
> $ cd /usr/lib/firefox-addons/plugins/
> $ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.s

I confirm this works after changing the environment variable in address 'about:config' of Firefox3, from 'javaplugin_oji', to 'libjavaplugin_oji'. Other java variables default!

Glenn (glenn-v) wrote :

Amedee, the error your getting sounds like a different error than everyone else's. (It seems your java is working, just throwing errors because the applets.) Try this page to test it out http://www.java.com/en/download/help/testvm.xml

Also, did you install from the repositories, or did you install java manually (from the sun java website)?

I have this problem with Firefox 3.0, kubuntu-kde4 and java 6.0 SE what I installed straight by Firefox. Any Java games doesn't work in Firefox.

On Sat, March 8, 2008 17:50, explosion wrote:
>> mexlinux typed :
>> I can confirm that FF3 and Java6 works at Hardy Alpha 6 only after
>> applying both proposed solutions:
>> $ sudo sed -i 's/XINERAMA/FAKEEXTN/g'
>> /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
>> $ cd /usr/lib/firefox-addons/plugins/
>> $ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.s
>
> I confirm this works after changing the environment variable in address
> 'about:config' of Firefox3, from 'javaplugin_oji', to
> 'libjavaplugin_oji'. Other java variables default!

I can confirm that I still have java.lang.NullPointerException after
applying this change.

--
Amedee

Amedee Van Gasse (amedee) wrote :

On Sat, March 8, 2008 19:00, Glenn Vording wrote:
> Amedee, the error your getting sounds like a different error than
> everyone else's. (It seems your java is working, just throwing errors
> because the applets.) Try this page to test it out
> http://www.java.com/en/download/help/testvm.xml

The Java test page works. It's just the applets that don't work. Like the
touchgraph browser, my bank software,...

> Also, did you install from the repositories, or did you install java
> manually (from the sun java website)?

I installed both.

--
Amedee

Amedee Van Gasse (amedee) wrote :

On Sat, March 8, 2008 19:00, Glenn Vording wrote:
> Amedee, the error your getting sounds like a different error than
> everyone else's. (It seems your java is working, just throwing errors
> because the applets.) Try this page to test it out
> http://www.java.com/en/download/help/testvm.xml
>
> Also, did you install from the repositories, or did you install java
> manually (from the sun java website)?

Which Java should I install?
I will uninstall every Java if you tell me which Java I must install.

--
Amedee

TDB (michael-baranov) wrote :

> I can confirm that FF3 and Java6 works at Hardy Alpha 6 only after applying both proposed solutions:
> $ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
> $ cd /usr/lib/firefox-addons/plugins/
> $ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.s
After applying those fixes on Java 5, the applets work most of the time.
Sometimes the don't, sometimes they hang Firefox with 100% CPU consumption.

Michael.

Amedee, it would probably be best to use the java in the repositories, because that's what the bug reporter is using, and that's what the commands are trying to fix. Also, it helps with bug testing for the hardy java package.

Tim (willc0de4food) wrote :

>I can confirm that FF3 and Java6 works at Hardy Alpha 6 only after applying both proposed solutions:
>$ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
>$ cd /usr/lib/firefox-addons/plugins/
>$ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.so

on a new install of 8.04 alpha 6 with firefox 3.0b4, i installed java through the browser's plugin finder and after executing the above commands java works

On Fri, March 14, 2008 03:09, Tim wrote:
>>I can confirm that FF3 and Java6 works at Hardy Alpha 6 only after
>> applying both proposed solutions:
>>$ sudo sed -i 's/XINERAMA/FAKEEXTN/g'
>> /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
>>$ cd /usr/lib/firefox-addons/plugins/
>>$ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.so
>
> on a new install of 8.04 alpha 6 with firefox 3.0b4, i installed java
> through the browser's plugin finder and after executing the above
> commands java works

Thank you, I will try to confirm your finding within a few days or weeks.

--
Amedee

$ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
$ cd /usr/lib/firefox-addons/plugins/
$ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.so

I want to confirm, that this works with Hardy Alpha 6, Mozilla 3 Beta 4.

aleksm@chimp:/usr/lib/firefox-addons/plugins$ ls -l
total 0
lrwxrwxrwx 1 root root 43 2008-03-17 21:00 firefox-3.0-javaplugin.so -> /etc/alternatives/firefox-3.0-javaplugin.so
aleksm@chimp:/usr/lib/firefox-addons/plugins$ java -fullversion
java full version "1.6.0_04-b12"
aleksm@chimp:/usr/lib/firefox-addons/plugins$

Thank you!! Alex.

Jonas H (jonash) wrote :

$ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
$ cd /usr/lib/firefox-addons/plugins/
$ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.so

I confirm this works with Ubuntu Hardy latest (Tu, 18th March 08) updates in Firefox 3.0b4 with java 5 and 6 plugin.
Thanks!

Aaron Whitehouse (luna-tick) wrote :

I am using FF 3 beta 4 on a fully up-to-date Ubuntu Hardy install. Java 6 did not work (installed through the browser or through synaptic).

$ sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so
$ cd /usr/lib/firefox-addons/plugins/
$ sudo ln -s /etc/alternatives/firefox-3.0-javaplugin.so

fixed my problem. Thanks!

Can we update the bug name to something more appropriate - it seems to affect more than Kubuntu.

Matti Lindell (mlind) wrote :

Firefox 3 seems to require registering plugin in /usr/lib/xulrunner-addons/plugins/. Both sun-java5 and sun-java6 'browser_plugin_dirs' need updating.

Matti Lindell (mlind) on 2008-03-22
Changed in epiphany-browser:
status: New → Invalid
Scott Beamer (angrykeyboarder) wrote :

So I'm having the same problem here with Hardy i386 and Firefox 3.

Why is this bug still marked "invalid"?

Scott Beamer (angrykeyboarder) wrote :

Disregard my previous statement,. I misread.

MikeBee (michaelbeeson) wrote :

i concur. this was also the case in gutsy with firefox 2.

on a default install, i added the java6 mozilla plugin, but it was not listed in about:plugins under firefox 3 beta.

i had to create a symbolic link in ~/.mozilla/plugins for it to work. this would be very frustrating for newbies as all the gui windows indicated that the plugin was installed correctly, however firefox never picked it up from the /etc/alternatives/ directory or the symbolic link under /usr/mozilla/plugins (or similar?)

Matthias Klose (doko) wrote :

fixed in icedtea-gcjwebplugin_1.0-0ubuntu3

Changed in icedtea-gcjwebplugin:
assignee: nobody → doko
status: New → Fix Released

not a u-r-e issue, and we've changed to java7 there now anyway.

Changed in ubuntu-restricted-extras:
status: New → Invalid
Scott Beamer (angrykeyboarder) wrote :

This is the sun-java6-plugin. It's the icedtea-java7-plugin.

Scott Beamer (angrykeyboarder) wrote :

Disregard previous statement. I just noticed it's all of them. :)

StratosJL (stratosjl) wrote :

I just installed icedtea-gcjwebplugin_1.0-0ubuntu3, and I still had to make the manual link in order to get it to work.

Matthias Klose (doko) wrote :

what does

  ls -l /usr/lib/xulrunner-addons/plugins/
  ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
  update-alternatives --list xulrunner-1.9-javaplugin.so
  update-alternatives --config xulrunner-1.9-javaplugin.so
  ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
  ls -l /usr/lib/xulrunner-addons/plugins/

show?

Download full text (3.5 KiB)

root@xabbu:/etc/ssmtp # ls -l /usr/lib/xulrunner-addons/plugins/
total 24
lrwxrwxrwx 1 root root 46 2008-03-21 09:59 flashplugin-alternative.so -> /etc/alternatives/xulrunner-addons-flashplugin
-rw-r--r-- 1 root root 15512 2008-03-13 19:41 libnullplugin.so
-rw-r--r-- 1 root root 7720 2008-03-13 19:41 libunixprintplugin.so
lrwxrwxrwx 1 root root 43 2008-03-21 09:52 mplayerplug-in-dvx.so -> ../../mozilla/plugins/mplayerplug-in-dvx.so
lrwxrwxrwx 1 root root 44 2008-03-21 09:52 mplayerplug-in-dvx.xpt -> ../../mozilla/plugins/mplayerplug-in-dvx.xpt
lrwxrwxrwx 1 root root 42 2008-03-21 09:52 mplayerplug-in-qt.so -> ../../mozilla/plugins/mplayerplug-in-qt.so
lrwxrwxrwx 1 root root 43 2008-03-21 09:52 mplayerplug-in-qt.xpt -> ../../mozilla/plugins/mplayerplug-in-qt.xpt
lrwxrwxrwx 1 root root 42 2008-03-21 09:52 mplayerplug-in-rm.so -> ../../mozilla/plugins/mplayerplug-in-rm.so
lrwxrwxrwx 1 root root 43 2008-03-21 09:52 mplayerplug-in-rm.xpt -> ../../mozilla/plugins/mplayerplug-in-rm.xpt
lrwxrwxrwx 1 root root 39 2008-03-21 09:52 mplayerplug-in.so -> ../../mozilla/plugins/mplayerplug-in.so
lrwxrwxrwx 1 root root 43 2008-03-21 09:52 mplayerplug-in-wmp.so -> ../../mozilla/plugins/mplayerplug-in-wmp.so
lrwxrwxrwx 1 root root 44 2008-03-21 09:52 mplayerplug-in-wmp.xpt -> ../../mozilla/plugins/mplayerplug-in-wmp.xpt
lrwxrwxrwx 1 root root 40 2008-03-21 09:52 mplayerplug-in.xpt -> ../../mozilla/plugins/mplayerplug-in.xpt
[1]+ Done emacs ssmtp.conf
root@xabbu:/etc/ssmtp # ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
ls: cannot access /etc/alternatives/xulrunner-1.9-javaplugin.so: No such file or directory
root@xabbu:/etc/ssmtp # update-alternatives --list xulrunner-1.9-javaplugin.so
No alternatives for xulrunner-1.9-javaplugin.so.
root@xabbu:/etc/ssmtp # update-alternatives --config xulrunner-1.9-javaplugin.so
No alternatives for xulrunner-1.9-javaplugin.so.
root@xabbu:/etc/ssmtp # ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
ls: cannot access /etc/alternatives/xulrunner-1.9-javaplugin.so: No such file or directory
root@xabbu:/etc/ssmtp # ls -l /usr/lib/xulrunner-addons/plugins/
total 24
lrwxrwxrwx 1 root root 46 2008-03-21 09:59 flashplugin-alternative.so -> /etc/alternatives/xulrunner-addons-flashplugin
-rw-r--r-- 1 root root 15512 2008-03-13 19:41 libnullplugin.so
-rw-r--r-- 1 root root 7720 2008-03-13 19:41 libunixprintplugin.so
lrwxrwxrwx 1 root root 43 2008-03-21 09:52 mplayerplug-in-dvx.so -> ../../mozilla/plugins/mplayerplug-in-dvx.so
lrwxrwxrwx 1 root root 44 2008-03-21 09:52 mplayerplug-in-dvx.xpt -> ../../mozilla/plugins/mplayerplug-in-dvx.xpt
lrwxrwxrwx 1 root root 42 2008-03-21 09:52 mplayerplug-in-qt.so -> ../../mozilla/plugins/mplayerplug-in-qt.so
lrwxrwxrwx 1 root root 43 2008-03-21 09:52 mplayerplug-in-qt.xpt -> ../../mozilla/plugins/mplayerplug-in-qt.xpt
lrwxrwxrwx 1 root root 42 2008-03-21 09:52 mplayerplug-in-rm.so -> ../../mozilla/plugins/mplayerplug-in-rm.so
lrwxrwxrwx 1 root root 43 2008-03-21 09:52 mplayerplug-in-rm.xpt -> ../../mozilla/plugins/mplayerplug-in-rm.xpt
lrwxrwxrwx 1 root root 39 2008-03-21 09:52 mplayerplug-in.so -> ../....

Read more...

Download full text (4.5 KiB)

Matthias Klose wrote:
> what does
>
> ls -l /usr/lib/xulrunner-addons/plugins/
> ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
> update-alternatives --list xulrunner-1.9-javaplugin.so
> update-alternatives --config xulrunner-1.9-javaplugin.so
> ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
> ls -l /usr/lib/xulrunner-addons/plugins/
>
> show?
>

$ ls -l /usr/lib/xulrunner-addons/plugins/
total 28
lrwxrwxrwx 1 root root 46 2008-03-22 03:16 flashplugin-alternative.so
-> /etc/alternatives/xulrunner-addons-flashplugin
-rw-r--r-- 1 root root 15512 2008-03-13 11:41 libnullplugin.so
-rw-r--r-- 1 root root 3944 2008-03-13 15:33
librhythmbox-itms-detection-plugin.so
lrwxrwxrwx 1 root root 44 2008-03-21 19:22 libtotem-basic-plugin.so
-> ../../totem/default/libtotem-basic-plugin.so
lrwxrwxrwx 1 root root 45 2008-03-21 19:22 libtotem-basic-plugin.xpt
-> ../../totem/default/libtotem-basic-plugin.xpt
lrwxrwxrwx 1 root root 46 2008-03-21 19:22 libtotem-complex-plugin.so
-> ../../totem/default/libtotem-complex-plugin.so
lrwxrwxrwx 1 root root 47 2008-03-21 19:22
libtotem-complex-plugin.xpt ->
../../totem/default/libtotem-complex-plugin.xpt
lrwxrwxrwx 1 root root 43 2008-03-21 19:22 libtotem-cone-plugin.so ->
../../totem/default/libtotem-cone-plugin.so
lrwxrwxrwx 1 root root 44 2008-03-21 19:22 libtotem-cone-plugin.xpt
-> ../../totem/default/libtotem-cone-plugin.xpt
lrwxrwxrwx 1 root root 42 2008-03-21 19:22 libtotem-gmp-plugin.so ->
../../totem/default/libtotem-gmp-plugin.so
lrwxrwxrwx 1 root root 43 2008-03-21 19:22 libtotem-gmp-plugin.xpt ->
../../totem/default/libtotem-gmp-plugin.xpt
lrwxrwxrwx 1 root root 44 2008-03-21 19:22 libtotem-mully-plugin.so
-> ../../totem/default/libtotem-mully-plugin.so
lrwxrwxrwx 1 root root 45 2008-03-21 19:22 libtotem-mully-plugin.xpt
-> ../../totem/default/libtotem-mully-plugin.xpt
lrwxrwxrwx 1 root root 50 2008-03-21 19:22
libtotem-narrowspace-plugin.so ->
../../totem/default/libtotem-narrowspace-plugin.so
lrwxrwxrwx 1 root root 51 2008-03-21 19:22
libtotem-narrowspace-plugin.xpt ->
../../totem/default/libtotem-narrowspace-plugin.xpt
-rw-r--r-- 1 root root 7720 2008-03-13 11:41 libunixprintplugin.so
$ ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
ls: cannot access /etc/alternatives/xulrunner-1.9-javaplugin.so: No such
file or directory
$ update-alternatives --list xulrunner-1.9-javaplugin.so
No alternatives for xulrunner-1.9-javaplugin.so.
$ update-alternatives --config xulrunner-1.9-javaplugin.so
No alternatives for xulrunner-1.9-javaplugin.so.
$ ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
ls: cannot access /etc/alternatives/xulrunner-1.9-javaplugin.so: No such
file or directory
$ ls -l /usr/lib/xulrunner-addons/plugins/
total 28
lrwxrwxrwx 1 root root 46 2008-03-22 03:16 flashplugin-alternative.so
-> /etc/alternatives/xulrunner-addons-flashplugin
-rw-r--r-- 1 root root 15512 2008-03-13 11:41 libnullplugin.so
-rw-r--r-- 1 root root 3944 2008-03-13 15:33
librhythmbox-itms-detection-plugin.so
lrwxrwxrwx 1 root root 44 2008-03-21 19:22 libtotem-basic-plugin.so
-> ../../totem/default/libtotem-basic-plugin.so
lrwxr...

Read more...

Matthias Klose (doko) wrote :

are you sure that icedtea-gcjwebplugin is installed at all?

StratosJL (stratosjl) wrote :
Download full text (4.4 KiB)

After I installed the plugin icedtea-gcjwebplugin_1.0-0ubuntu3 and the required packages, I made a symlink in /usr/lib/firefox-addons/plugins
to ln -s /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/gcjwebplugin.so

My system is a 8.04 beta, after an online upgrade from 7.10 64bit.

The commands you asked give the following output:

stratos@homepc:~$ ls -l /usr/lib/xulrunner-addons/plugins/
σύνολο 44
lrwxrwxrwx 1 root root 46 2008-03-21 21:16 flashplugin-alternative.so -> /etc/alternatives/xulrunner-addons-flashplugin
lrwxrwxrwx 1 root root 45 2008-03-23 12:22 libjavaplugin.so -> /etc/alternatives/xulrunner-1.9-javaplugin.so
-rw-r--r-- 1 root root 21120 2008-03-13 20:34 libnullplugin.so
-rw-r--r-- 1 root root 5400 2008-03-22 23:57 librhythmbox-itms-detection-plugin.so
-rw-r--r-- 1 root root 10936 2008-03-13 20:34 libunixprintplugin.so
lrwxrwxrwx 1 root root 43 2008-03-21 21:07 mplayerplug-in-dvx.so -> ../../mozilla/plugins/mplayerplug-in-dvx.so
lrwxrwxrwx 1 root root 44 2008-03-21 21:07 mplayerplug-in-dvx.xpt -> ../../mozilla/plugins/mplayerplug-in-dvx.xpt
lrwxrwxrwx 1 root root 42 2008-03-21 21:07 mplayerplug-in-qt.so -> ../../mozilla/plugins/mplayerplug-in-qt.so
lrwxrwxrwx 1 root root 43 2008-03-21 21:07 mplayerplug-in-qt.xpt -> ../../mozilla/plugins/mplayerplug-in-qt.xpt
lrwxrwxrwx 1 root root 42 2008-03-21 21:07 mplayerplug-in-rm.so -> ../../mozilla/plugins/mplayerplug-in-rm.so
lrwxrwxrwx 1 root root 43 2008-03-21 21:07 mplayerplug-in-rm.xpt -> ../../mozilla/plugins/mplayerplug-in-rm.xpt
lrwxrwxrwx 1 root root 39 2008-03-21 21:07 mplayerplug-in.so -> ../../mozilla/plugins/mplayerplug-in.so
lrwxrwxrwx 1 root root 43 2008-03-21 21:07 mplayerplug-in-wmp.so -> ../../mozilla/plugins/mplayerplug-in-wmp.so
lrwxrwxrwx 1 root root 44 2008-03-21 21:07 mplayerplug-in-wmp.xpt -> ../../mozilla/plugins/mplayerplug-in-wmp.xpt
lrwxrwxrwx 1 root root 40 2008-03-21 21:07 mplayerplug-in.xpt -> ../../mozilla/plugins/mplayerplug-in.xpt

stratos@homepc:~$ ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
lrwxrwxrwx 1 root root 57 2008-03-23 12:22 /etc/alternatives/xulrunner-1.9-javaplugin.so -> /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/gcjwebplugin.so

stratos@homepc:~$ update-alternatives --list xulrunner-1.9-javaplugin.so
/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/gcjwebplugin.so

stratos@homepc:~$ sudo update-alternatives --config xulrunner-1.9-javaplugin.so
There is only 1 program which provides xulrunner-1.9-javaplugin.so
(/usr/lib/jvm/java-6-openjdk/jre/lib/amd64/gcjwebplugin.so). Nothing to configure.

stratos@homepc:~$ ls -l /etc/alternatives/xulrunner-1.9-javaplugin.so
lrwxrwxrwx 1 root root 57 2008-03-23 15:03 /etc/alternatives/xulrunner-1.9-javaplugin.so -> /usr/lib/jvm/java-6-openjdk/jre/lib/amd64/gcjwebplugin.so

stratos@homepc:~$ ls -l /usr/lib/xulrunner-addons/plugins/
σύνολο 44
lrwxrwxrwx 1 root root 46 2008-03-21 21:16 flashplugin-alternative.so -> /etc/alternatives/xulrunner-addons-flashplugin
lrwxrwxrwx 1 root root 45 2008-03-23 12:22 libjavaplugin.so -> /etc/alternatives/xulrunner-1.9-javaplugin.so
-rw-r--r-- 1 root root 21120 2008-03-13 20:34 libnullplugin.so
-rw-r--r-- 1 root root 5400 2008-03-22 23...

Read more...

Matthias Klose (doko) wrote :

icedtea-gcjwebplugin_1.0-0ubuntu3 works as expected; your manual symlink is not required.

Pjotr12345 (computertip) wrote :

I can confirm this bug. Impossible to get Sun Java working in Firefox 3 on Hardy, although Sun Java JRE 6 and the plugin are installed as part of ubuntu-restricted-extras.

Greetz, Pjotr.

StratosJL (stratosjl) wrote :

The first time you visit a java site, firefox asks for the plugin.
After installing the plugin, firefox does not ask for it, but still nothing is happening.
After making the symlink as well, it works..

Derick Eisenhardt (zephyrxero) wrote :

I also confirm that neither sun-java5 nor 6 are working in Firefox in Hardy. If I goto Sun's java test page [http://www.java.com/en/download/help/testvm.xml] it says I do not have the plugin even though it is installed.

Pjotr12345 (computertip) wrote :

In Hardy, this issue with Sun Java is with *all* available browsers. Not only Firefox 3, but also Firefox 2, Konqueror, Opera, Epiphany.

So it's not a Firefox thing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sun-java6 - 6-05-0ubuntu1

---------------
sun-java6 (6-05-0ubuntu1) hardy; urgency=low

  * New upstream bug fix release.
    This was released today on https://jdk-distros.dev.java.net/developer.html.
    Distributions are not allowed to package the released versions published
    at http://java.sun.com/javase/downloads and have to wait for the
    availability of the DLJ bundles. No need to file reports like LP: #199477.
  * Install all desktop files in /usr/share/applications.
  * sun-java6-jdk: Add java*-sdk provides.
  * Adjust plugin links for xulrunner-1.9. LP: #173966, #198633.

 -- Matthias Klose <email address hidden> Tue, 25 Mar 2008 23:33:13 +0000

Changed in sun-java6:
status: Confirmed → Fix Released
Matti Lindell (mlind) wrote :

Also fixed in sun-java5 (1.5.0-15-0ubuntu1).

Changed in sun-java5:
status: Confirmed → Fix Released
Pjotr12345 (computertip) wrote :

No problems anymore. Thanks guys! :-)

@ Matthias Klose
i test fx3 trunk nightlies & i still have this problem with icedtea-gcjwebplugin_1.0-0ubuntu5 x86.
it is extremely frustrating because afaict it should be working.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008040504 Minefield/3.0pre - Build ID: 2008040504

oops, addendum to my previous post.
i forgot to mention this is also with openjdk-6-jre 6b08-0ubuntu6.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008041004 Minefield/3.0pre - Build ID: 2008041004

John Vivirito (gnomefreak) wrote :

echos you are seeing the same issue as the reporter or simular?

David Jaša (dejv) wrote :

I had the same problem with sun-java6-jre today until I manually added symlink to /etc/alternatives/firefox-javaplugin.so in /usr/lib/xulrunner-addons/plugins.

@ John Vivirito
no i am not seeing those same issues. the plugin does not show up in about:plugins though.

@ David Jaša
i was going to try to create that symlink, but i have no firefox-javaplugin.so anywhere. (probably a difference betwen openjdk/gcjwebplugin & sun-java).

i noticed in fx trunk that there is this option in about:config:
java.java_plugin_library_name
its a string. by default it is set to: javaplugin_oji

perhaps this is why it isn't recognized by fx trunk?? (i tried changing it to various things such gcjwebplugin but nothing worked, but maybe i didn't try the right name).

after updating the database & a search with "mlocate javaplugin" showed:
/etc/alternatives/xulrunner-1.9-javaplugin.so
/usr/lib/mozilla/plugins/xulrunner-1.9-javaplugin.so
/usr/lib/openoffice/program/sunjavaplugin.so
/usr/lib/xulrunner-addons/plugins/libjavaplugin.so
/var/lib/dpkg/alternatives/xulrunner-1.9-javaplugin.so

John Vivirito (gnomefreak) wrote :

Echos you should see it in firefox-2.0 profile also try to set it with update-alternatives command.
if this doesnt help please file a seperate bug report for your problem as it is not the same as the issue on this bug report.

i actually test & use fx trunk as my default browser, so i don't use fx 2.0. also, i forgot to mention that the plugin does not show up in konqueror's about:plugins either. i even added more directories to where it searches for plugins.

i've never used update-alternatives before. i read its commands & options but i'm not sure how you want me to use it. like this:
sudo update-alternatives --set /usr/lib/jvm/java-6-openjdk/jre/lib/i386/gcjwebplugin.so javaplugin_oji
?

John Vivirito (gnomefreak) wrote :

that way should work.

@ John Vivirito
ok, i tried that and go this output:
No alternatives for /usr/lib/jvm/java-6-openjdk/jre/lib/i386/gcjwebplugin.so.

then i realized that the "alternative" must be a file in the /etc/alternatives dir. (which makes sense. ;) give me a break, i've never used update-alternatives before).

so i only found one java plugin in there, so then i tried:
sudo update-alternatives --set xulrunner-1.9-javaplugin.so javaplugin_oji
and got:
update-alternatives: Cannot find alternative `javaplugin_oji'.
(which i'm sure means i don't have that file (javaplugin_oji.so) on my system. an mlocate search didn't reveal one either).

so then i noticed that i had copied gcjwebplugin.so file to /usr/lib/mozilla/plugins (where it wasn't being detected by fx). so then i thought, i'm 99% sure i tried this before but i'll try it again any way. i copied the file (gcjwebplugin.so) to /usr/lib/firefox/plugins and voila! it now shows up in about:plugins.

but for some reason it still isn't showing up in konqueror's about:plugins. is there something that hasn't been implemented yet that makes it incompatible with konqueror?

cypher (guohuo85) wrote :

go to /usr/lib/firefox-addons/plugins$

and do:

sudo ln -s /etc/alternatives/firefox-javaplugin.so

I am using firefox beta 4 and ubuntu gutsy 7.1 my applet works already. If you are seeking to get your java up on firefox

if you cannot find firefox-javaplugin.so maybe you can try
ls -l | grep firefox
to get all the files that are related to firefox
probably one of them is the firefox javaplugin link

just swap my given firefox-javaplugin.so for that file that you found and try if it works.
hopefully this helped
Thanks to those who posted above that leaded me to /etc/alternatives and /usr/lib/firefox-addons/plugins I would never have figured out where the plugins are myself

Pjotr12345 (computertip) wrote :

I have found a perhaps better solution, at least for 32-bit-Ubuntu.

The thing is, that Sun Java JRE is no longer in ubuntu-restricted-extras. It has been replaced by OpenJDK and the Icedtea plugin. But those don't work as well as Sun Java.

These are the steps I followed:

1. I installed ubuntu-restricted-extras on a clean installation of the Release Candidate of 8.04 (32-bit edition)

2. Afterwards, simply installing Sun Java JRE and plugin is not enough. First you have to completely remove OpenJDK and the Icedtea plugin in Synaptic. Only then you should install Sun Java JRE and plugin.

Then everything works fine again (at least on my computers).

It's a pity that Sun Java JRE has been replaced in ubuntu-restricted-extras. Now a lot of people will have to do this manual correction afterwards.

Greetz, Pjotr.

On Mon, April 21, 2008 14:16, Pjotr12345 wrote:
> I have found a perhaps better solution, at least for 32-bit-Ubuntu.
>
> The thing is, that Sun Java JRE is no longer in ubuntu-restricted-
> extras. It has been replaced by OpenJDK and the Icedtea plugin. But
> those don't work as well as Sun Java.
>
> These are the steps I followed:
>
> 1. I installed ubuntu-restricted-extras on a clean installation of the
> Release Candidate of 8.04 (32-bit edition)
>
> 2. Afterwards, simply installing Sun Java JRE and plugin is not enough.
> First you have to completely remove OpenJDK and the Icedtea plugin in
> Synaptic. Only then you should install Sun Java JRE and plugin.
>
> Then everything works fine again (at least on my computers).
>
> It's a pity that Sun Java JRE has been replaced in ubuntu-restricted-
> extras. Now a lot of people will have to do this manual correction
> afterwards.

That is not an acceptable solution. It should either work correctly out of
the box, or not be installed at all. The current situation causes
confusion.

I suggest removing OpenJDK and the Icedtea plugin from Ubuntu until all
bugs are solved. The next version of ubuntu ships in two weeks, this bug
just cannot be shipped to millions of users.

Two weeks? Hardy ships in 3 days from what I'm seeing, as well as what the countdown shows.

Amedee Van Gasse (amedee) wrote :

On Mon, April 21, 2008 15:24, dj_peng wrote:
> Two weeks? Hardy ships in 3 days from what I'm seeing, as well as what
> the countdown shows.

That means it was 11 days ago that I visited the Ubuntu site.
Anyway it just proves my point: this bug needs URGENT fixing. Or shit wil
hit the fan. We don't want to irritate our users.

pbhj (pbhj) wrote :

OK, using FF 3 Beta 4, I had to go to:

/usr/lib/xulrunner-addons/plugins

and as root do

ln -s /usr/lib/j2se/1.4/jre/plugin/amd64/mozilla/libjavaplugin_oji.so

that installed what about plugins describes as "Blackdown Java-Linux Java(TM) Plug-in 1.4.2" .. thanks for the suggestions that were all useless for me but spurred me on to find the answer!!!

Pjotr12345 (computertip) wrote :

@pbhj:
Blackdown java is outdated, less functional and probably unsafe (unpatched).

Why don't you choose Sun Java 6 JRE and plugin? Fully safe, up to date and functional. Simply follow this instruction for Ubuntu 8.04:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/173966/comments/59

groovete (post04) wrote :

Removing OpenJDK and the Icedtea plugin from Ubuntu solved the problem for me!

deeperror (deeperror) wrote :

When I remove the Icedtea plugin It seems that some javascripts don't work properly.
http://www.verizonwireless.com/b2c/index.html
The drop down menus do not work.

After removing Icedtea plugin logmein.com and the java.com sites work 100%.

When I install Icedtea these two sites do not work. And on logmein.com I get this in the error console.

Failed to load XPCOM component: /usr/lib/xulrunner-1.9b5/components/libpyloader.so
Failed to load XPCOM component: /usr/lib/xulrunner-1.9b5/components/pyabout.py

Patricio (patricio-stwing) wrote :

I removed Icedtea and OpenJDK, but java in FF2 still not working. By the way some info:
patricio@patricio-desktop:~$ sudo update-alternatives --config java

There are 2 alternatives which provide `java'.

  Selection Alternative
-----------------------------------------------
 + 1 /usr/lib/jvm/java-6-sun/jre/bin/java
* 2 /usr/bin/gij-4.2

Press enter to keep the default[*], or type selection number:

Pavel Mlčoch (pavkamlc) wrote :

Mayby can help http://www.java.com/en/download/help/enable_browser.xml
Java must be enabled in the browser. After I purge all javas and only install java6-plugin, It doesnt work. After enable in browser, java applets works.

Alfas (alfonsasstonis) wrote :

I tried all suggestions I could find. Java applets do not work :(.

I have kubuntu 8.04.1
2.6.24-19-generic #1 SMP Wed Jun 18 14:15:37 UTC 2008 x86_64 GNU/Linux
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008061017 Firefox/3.0

Any ideas?

James Stansell (jamesstansell) wrote :

Alfas, the only java plugin available for 64-bit systems is icedtea-gcjwebplugin. Some applets work, but it's not surprising if the ones you are interested in don't work.

The only option currently available, as far as I know, is to run a hybrid 32bit system. I haven't done that myself, but the 64-bit users forum at ubuntuforums.org would be a good place to start.

-james.

Alfas (alfonsasstonis) wrote :

Thanks James. If I only knew it a day before then it would save my self a lot of time, effort and saved from frustration. I can work around that when I know what is available. BTW it still does not run on Konqueror, but it is start.

Alfas (alfonsasstonis) wrote :

I was wrong. It works on Konqueror too. Just needed to enable it form Tools->HTML Settings menu.

Dan Ackerson (dan.ackerson) wrote :

confirmed - JRE 6 plugin doesn't work in FF3 until you completely remove OpenJDK and Icedtea packages

Alfas (alfonsasstonis) wrote :

First:
Confirmed - after installing Icedtea plugin and OpenJDK Java applets works on FF3 (Sun JDK 6 is installed on this computer too).
Now it works on one computer, but I can not install it on another :(.

When I try to install icedtea-gcjwebpluign it shows BREAK (install).
I have Ubuntu 8.04.1
Linux alfas-laptop 2.6.24-19-generic #1 SMP Fri Jul 11 21:01:46 UTC 2008 x86_64 GNU/Linux

Any ideas how to fix this?

Alfas wrote:
> First:
> Confirmed - after installing Icedtea plugin and OpenJDK Java applets works on FF3 (Sun JDK 6 is installed on this computer too).
> Now it works on one computer, but I can not install it on another :(.
>
> When I try to install icedtea-gcjwebpluign it shows BREAK (install).
> I have Ubuntu 8.04.1
> Linux alfas-laptop 2.6.24-19-generic #1 SMP Fri Jul 11 21:01:46 UTC 2008 x86_64 GNU/Linux
>
> Any ideas how to fix this?
>
>
Can you give me the exact error you get when attempting to install?

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

Alfas (alfonsasstonis) wrote :

I tried installing icedtea-gcjwebpluign with Adept Manager from menu :).
When I select icedtea-gcjwebpluign and click install it shows in red BREAK (install). I assume some packages are conflicting, but I could not find what is wrong.
Can you give me any instructions how to get more detailed information about the error? Maybe some command line options?

Sean (mareshah) wrote :

I dont quite know what I am to do having sent a bug report
regards

Brian Wootton (brian-meg) wrote :

I've just installed Intrepid from CD onto a 64 b amd and imbedded java don't work in my FF3, is there any definitive
update to fix this problem yet please? I'm a bit fed up with poking about in the dark.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers