a serious bug in enumerate=false mode

Bug #585885 reported by Timo Aaltonen
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sssd (Ubuntu)
Fix Released
High
Unassigned
Lucid
Won't Fix
High
Unassigned

Bug Description

Binary package hint: sssd

from the upstream release notes of 1.0.6:

  * Fix a serious bug when operating in enumerate=false mode
     o This configuration would occasionally result in periods of several minutes where the backend was operating at 100% CPU.

so 1.0.6 fixes this. Needs an SRU to lucid.

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

the full changelog:

https://fedorahosted.org/sssd/wiki/Releases/Notes-1.0.6

Jakub Hrozek (2):

    * Do not schedule enumeration after a cleanup
    * Do not check entries during cleanup task

Stephen Gallagher (2):

    * Revert "Change default for enumeration to TRUE"
    * Release version 1.0.6

Changed in sssd (Ubuntu):
importance: Undecided → High
Changed in sssd (Ubuntu Lucid):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sssd - 1.0.6-0ubuntu1

---------------
sssd (1.0.6-0ubuntu1) maverick; urgency=low

  * New upstream bugfix release.
    - Fix a serious bug when operating in enumerate=false mode. This
      configuration would occasionally result in periods of several
      minutes where the backend was operating at 100% CPU. (LP: #585885)
 -- Timo Aaltonen <email address hidden> Wed, 26 May 2010 17:09:11 +0300

Changed in sssd (Ubuntu):
status: New → Fix Released
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

I've uploaded 1.0.6-0ubuntu1~lucid1 to lucid-proposed.

Changed in sssd (Ubuntu Lucid):
status: New → In Progress
Revision history for this message
Timo Aaltonen (tjaalton) wrote :

note that this bug was brought to our attention by upstream, and they released 1.0.6 for us (the fix had been already in 1.1.0 released in March 22nd)

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted sssd into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in sssd (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Martin Pitt (pitti) wrote :

Any testers?

Revision history for this message
Timo Aaltonen (tjaalton) wrote :

Martin, this was uploaded due to upstream alarming us that the current package is broken. It was reported on the upstream irc channel (I think), here's the announce email:

https://fedorahosted.org/pipermail/sssd-devel/2010-May/003775.html

so I don't know if it's possible to find the users who reported this upstream..

Revision history for this message
Martin Pitt (pitti) wrote :

A confirmation that the current package still works (thus a regression test) would also help a lot.

Revision history for this message
Martin Pitt (pitti) wrote :

As nobody at all tested this package, I removed it from lucid-proposed again.

Changed in sssd (Ubuntu Lucid):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers