sssd: Add DEP8 tests

Bug #1793882 reported by Andreas Hasenack on 2018-09-22
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sssd (Ubuntu)
Wishlist
Andreas Hasenack
Xenial
Undecided
Andreas Hasenack
Bionic
Undecided
Andreas Hasenack

Bug Description

Please add DEP8 tests.

Related branches

Iain Lane (laney) wrote :

It'd be good to forward these to Debian / Timo please.

Timo Aaltonen (tjaalton) wrote :

a merge proposal is already on salsa, I just haven't had time to do anything about it

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sssd - 1.16.3-1ubuntu1

---------------
sssd (1.16.3-1ubuntu1) cosmic; urgency=medium

  * Add DEP8 tests (LP: #1793882):
    - d/t/{ldap-user-group-ldap-auth,control,login.exp,util}: LDAP DEP8 test
    - d/t/{util,login.exp,ldap-user-group-krb5-auth,control}: krb5 DEP8 test

 -- Andreas Hasenack <email address hidden> Sat, 22 Sep 2018 15:35:01 +0200

Changed in sssd (Ubuntu):
status: In Progress → Fix Released
Changed in sssd (Ubuntu Bionic):
assignee: nobody → Andreas Hasenack (ahasenack)
status: New → In Progress

Hello Andreas, or anyone else affected,

Accepted sssd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sssd/1.16.1-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in sssd (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Andreas Hasenack (ahasenack) wrote :

The new bionic sssd dep8 tests ran, and are all green:

http://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#sssd

Copy & paste:
sssd (1.16.1-1ubuntu1 to 1.16.1-1ubuntu1.1)
Maintainer: Ubuntu Developers
0 days old
Not touching package due to block request by freeze (contact #ubuntu-release if update is needed)
autopkgtest for freeipa/4.7.0~pre1+git20180411-2ubuntu2: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
autopkgtest for sssd/1.16.1-1ubuntu1.1: amd64: Pass, arm64: Pass, armhf: Pass, i386: Pass, ppc64el: Pass, s390x: Pass
Not considered

Bionic verification successful.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sssd - 1.16.1-1ubuntu1.1

---------------
sssd (1.16.1-1ubuntu1.1) bionic; urgency=medium

  * d/p/fix-id-out-of-range-lookup.patch: CACHE_REQ: Do not fail the domain
    locator plugin if ID outside the domain range is looked up. Thanks to
    Jakub Hrozek <email address hidden>. (LP: #1807246)
  * d/t/common-tests, d/t/control, d/t/ldap-user-group-krb5-auth,
    d/t/ldap-user-group-ldap-auth, d/t/login.exp, d/t/util: add DEP8
    tests for kerberos and LDAP (LP: #1793882)

 -- Andreas Hasenack <email address hidden> Wed, 16 Jan 2019 13:58:03 -0200

Changed in sssd (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for sssd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in sssd (Ubuntu Xenial):
assignee: nobody → Andreas Hasenack (ahasenack)
status: New → In Progress

Hello Andreas, or anyone else affected,

Accepted sssd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sssd/1.13.4-1ubuntu1.13 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in sssd (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed-xenial

Also good on Xenial
http://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#sssd

...
ldap-user-group-ldap-auth PASS
ldap-user-group-krb5-auth PASS
...

Setting verification-done

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sssd - 1.13.4-1ubuntu1.13

---------------
sssd (1.13.4-1ubuntu1.13) xenial; urgency=medium

  [Orion Poplawski]
  * Add upstream HBAC patch. Closes LP: #1722936.

  [Andreas Hasenack]
  * d/t/{common-tests,control,ldap-user-group-*-auth,login.exp,util}: add DEP8
    tests from later releases of Ubuntu (LP: #1793882)

 -- Andreas Hasenack <email address hidden> Fri, 08 Feb 2019 15:08:44 -0200

Changed in sssd (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers