Comment 0 for bug 1684295

Pamela Skutnik (pam-s) wrote :

This is Ubuntu 16.04.2 LTS

sssd is configured to connect to two domains, our TPAD directory and Active Directory. sssd starts up at boot time. As soon as I ssh login (with any id, AD, TPAD or local), sssd fails with the error message in the title. After that, we can only login with local ids, not TPAD or AD ids.

****************
Here is the output from systemctl status sssd after the failure:
root@dcmilphlum128:~# systemctl status sssd
â sssd.service - System Security Services Daemon
   Loaded: loaded (/lib/systemd/system/sssd.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2017-04-19 16:40:08 EDT; 7min ago
  Process: 119143 ExecStart=/usr/sbin/sssd -D -f (code=exited, status=0/SUCCESS)
 Main PID: 119145 (code=exited, status=1/FAILURE)

Apr 19 16:39:47 dcmilphlum128.edc.nam.gm.com sssd[be[119187]: Starting up
Apr 19 16:39:51 dcmilphlum128.edc.nam.gm.com sssd[be[119191]: Starting up
Apr 19 16:39:57 dcmilphlum128.edc.nam.gm.com sssd[be[119206]: Starting up
Apr 19 16:40:08 dcmilphlum128.edc.nam.gm.com sssd[119145]: Exiting the SSSD. Could not restart critical service [tpad].
Apr 19 16:40:08 dcmilphlum128.edc.nam.gm.com sssd[119149]: Shutting down
Apr 19 16:40:08 dcmilphlum128.edc.nam.gm.com sssd[119148]: Shutting down
Apr 19 16:40:08 dcmilphlum128.edc.nam.gm.com sssd[be[119146]: Shutting down
Apr 19 16:40:08 dcmilphlum128.edc.nam.gm.com systemd[1]: sssd.service: Main process exited, code=exited, status=1/FAILURE
Apr 19 16:40:08 dcmilphlum128.edc.nam.gm.com systemd[1]: sssd.service: Unit entered failed state.
Apr 19 16:40:08 dcmilphlum128.edc.nam.gm.com systemd[1]: sssd.service: Failed with result 'exit-code'.

******************
Also, in kern.log I have four of these (I have retries set to 3):
Apr 19 16:39:59 dcmilphlum128 kernel: [ 6205.937807] sssd_be[12218]: segfault at 0 ip 00007fecb32b6b94 sp 00007ffce49a2230 error 4 in libsss_util.so[7fecb32a2000+6c000]
Apr 19 16:40:02 dcmilphlum128 kernel: [ 6206.980725] sssd_be[12253]: segfault at 0 ip 00007f302de29b94 sp 00007fffca943cc0 error 4 in libsss_util.so[7f302de15000+6c000]
Apr 19 16:40:05 dcmilphlum128 kernel: [ 6211.036205] sssd_be[12256]: segfault at 0 ip 00007fd196169b94 sp 00007ffd624249f0 error 4 in libsss_util.so[7fd196155000+6c000]
Apr 19 16:40:07 dcmilphlum128 kernel: [ 6225.081902] sssd_be[12257]: segfault at 0 ip 00007fd1f669bb94 sp 00007ffdd8e5bf80 error 4 in libsss_util.so[7fd1f6687000+6c000]

*******************
My sssd package are at 1.13.4:
sssd 1.13.4-1ubuntu1.1 amd64
sssd-ad 1.13.4-1ubuntu1.1 amd64
sssd-ad-common 1.13.4-1ubuntu1.1 amd64
sssd-common 1.13.4-1ubuntu1.1 amd64
sssd-ipa 1.13.4-1ubuntu1.1 amd64
sssd-krb5 1.13.4-1ubuntu1.1 amd64
sssd-krb5-common 1.13.4-1ubuntu1.1 amd64
sssd-ldap 1.13.4-1ubuntu1.1 amd64
sssd-proxy 1.13.4-1ubuntu1.1 amd64
sssd-tools 1.13.4-1ubuntu1.1 amd64

***************
I upgraded all the sssd packages to 1.13.4-1ubuntu1.4 and had the same problem.

I downgraded them to 1.12.5-2 and was NOT able to reproduce the problem.

I attached my sssd.conf file.