Squid crashes with "assertion failed" mem->swapout.sio

Bug #392077 reported by Ioannis Stoilis on 2009-06-25
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Squid
Unknown
Unknown
squid3 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: squid3

Squid3 commonly crashes several times a day with no apparent reason. Up until now I used squid which worked fine. This happens after upgrading to squid3.

In /var/log/squid3/cache.log, the last lines are:
2009/06/25 13:10:51| ctx: exit level 0
2009/06/25 13:10:51| clientParseRequestMethod: Unsupported method in request '^C'
2009/06/25 13:10:51| clientProcessRequest: Invalid Request
2009/06/25 13:12:52| assertion failed: store_swapout.cc:317: "mem->swapout.sio == self"

In syslog, this is reported:
Squid Parent: child process 20916 exited due to signal 6

# lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
# apt-cache policy squid3
squid3:
  Installed: 3.0.STABLE8-3
  Candidate: 3.0.STABLE8-3
  Version table:
 *** 3.0.STABLE8-3 0
        500 http://gr.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

siknasa9 (randy-curry666) wrote :

Also happening on Lucid X86_64 every time I boot.

Amos Jeffries (yadi) on 2010-06-16
summary: - Squid crashes with "assertion failed"
+ Squid crashes with "assertion failed" mem->swapout.sio
Dave Walker (davewalker) on 2011-11-20
Changed in squid3 (Ubuntu):
importance: Undecided → High

Confirmed by at least 3 Ubuntu users in this bug report:

http://pad.lv/392077

However, the report is rather old, so its possible this has been fixed in newer releases. Here is the original description from the original reporter:

Squid3 commonly crashes several times a day with no apparent reason. Up until now I used squid which worked fine. This happens after upgrading to squid3.

In /var/log/squid3/cache.log, the last lines are:
2009/06/25 13:10:51| ctx: exit level 0
2009/06/25 13:10:51| clientParseRequestMethod: Unsupported method in request '^C'
2009/06/25 13:10:51| clientProcessRequest: Invalid Request
2009/06/25 13:12:52| assertion failed: store_swapout.cc:317: "mem->swapout.sio == self"

In syslog, this is reported:
Squid Parent: child process 20916 exited due to signal 6

# lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
# apt-cache policy squid3
squid3:
  Installed: 3.0.STABLE8-3
  Candidate: 3.0.STABLE8-3
  Version table:
 *** 3.0.STABLE8-3 0
        500 http://gr.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

Please confirm this is still present in the current releases.

Clint Byrum (clint-fewbar) wrote :

Please if any users experience additional similar forward a full stack trace to the upstream bug!

Changed in squid3 (Ubuntu):
status: New → Triaged
tags: added: upstream

Marking as duplicate of newer bug report since traces there are more recent.

*** This bug has been marked as a duplicate of bug 3852 ***

Changed in squid:
importance: Unknown → Medium
status: Unknown → Invalid
Changed in squid3 (Ubuntu):
status: Triaged → Fix Committed
Amos Jeffries (yadi) on 2015-12-04
Changed in squid:
importance: Medium → Unknown
status: Invalid → Unknown
Robie Basak (racb) wrote :

This bug appears still open upstream, so I'll reopen it here. However, it looks like upstream don't have enough information to address the bug, so I'm marking this bug as Incomplete in Ubuntu also.

If you have further information to help developers fix the bug, then please participate here and at http://bugs.squid-cache.org/show_bug.cgi?id=3852.

Changed in squid3 (Ubuntu):
status: Fix Committed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.