squid's maintainer scripts call start/stop directly instead of using invoke-rc.d

Bug #726348 reported by Clint Byrum on 2011-02-28
42
This bug affects 5 people
Affects Status Importance Assigned to Milestone
squid (Ubuntu)
Medium
Unassigned
Lucid
High
Clint Byrum

Bug Description

Binary package hint: squid

This was brought up in bug #717397 by Steve Langasek.

The restart, start, stop, reload, etc. commands must not be directly called in maintainer scripts. invoke-rc.d should be used to properly maintain policy and deal with some oddness between upstart jobs and sysvinit scripts during transitions.

In particular, the restart command does not re-read the upstart job file, so changes to the job file will not result in a fixed service. The same goes for default configuration files and such.

Steve Langasek (vorlon) on 2011-03-08
Changed in squid (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE9-2.1ubuntu4

---------------
squid (2.7.STABLE9-2.1ubuntu4) natty; urgency=low

  * Simplify postinst script and use invoke-rc.d per policy. Also use
    stop/start to make sure new job file is reloaded. (LP: #726348).
 -- Clint Byrum <email address hidden> Tue, 08 Mar 2011 05:19:18 -0800

Changed in squid (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in squid (Ubuntu Lucid):
status: New → Confirmed
Clint Byrum (clint-fewbar) wrote :

This causes all kinds of problems when people try to update their 10.04 squid because they don't always get the new job file, so restart fails for the same reason as bug #573853 , which the latest lucid-updates version of squid is meant to fix.

Changed in squid (Ubuntu Lucid):
status: Confirmed → In Progress
assignee: nobody → Clint Byrum (clint-fewbar)
importance: Undecided → High
Changed in squid (Ubuntu Lucid):
status: In Progress → Fix Committed

Hello Clint, or anyone else affected,

Accepted squid into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Clint Byrum (clint-fewbar) wrote :

clint@test-squid:~$ sudo service squid status
squid start/running, process 575
clint@test-squid:~$ sudo apt-get install squid
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  squidclient squid-cgi logcheck-database resolvconf smbclient winbind
The following packages will be upgraded:
  squid
1 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.
Need to get 0B/818kB of archives.
After this operation, 0B of additional disk space will be used.
Preconfiguring packages ...
(Reading database ... 15126 files and directories currently installed.)
Preparing to replace squid 2.7.STABLE7-1ubuntu12.4 (using .../squid_2.7.STABLE7-1ubuntu12.5_amd64.deb) ...
Unpacking replacement squid ...
Processing triggers for ureadahead ...
Setting up squid (2.7.STABLE7-1ubuntu12.5) ...
squid stop/waiting
squid start/running, process 724
squid stop/waiting
squid start/running, process 777

This works great. marking verification-done

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package squid - 2.7.STABLE7-1ubuntu12.5

---------------
squid (2.7.STABLE7-1ubuntu12.5) lucid-proposed; urgency=low

  * Simplify postinst script and use invoke-rc.d per policy. Also use
    stop/start to make sure new job file is reloaded. (LP: #726348).
 -- Clint Byrum <email address hidden> Fri, 09 Dec 2011 10:40:09 -0800

Changed in squid (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers