xshm support missing

Bug #329038 reported by Michael Haupt on 2009-02-13
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
squeak-vm (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by Séverin Lemaignan

Bug Description

Binary package hint: squeak-vm

The VM in this package seems to be compiled without support for the X shared memory extension. I suggest to change this, as it affects at least one package (etoys). The corresponding bug is https://bugs.launchpad.net/ubuntu/+source/etoys/+bug/301190 - its effect is that Etoys cannot be started out of the box.

Steve Dee (mrdomino) wrote :

I can confirm this on Ubuntu 8.10. Etoys fails to start with default configuration.

Changed in squeak-vm:
status: New → Confirmed
kni (kni) wrote :

Confirm, the same thing is with Ubuntu 9.04 alpha 5. Etoys fails to start, because X shared memory extension support missed in squeak-vm.

Séverin Lemaignan (skadge) wrote :

What can be done to solve this bug which affect the final release of Jaunty as well? since it seems unlikely that a recompiled version of squeak-vm is to be proposed within the Jaunty cycle (but I may be wrong?), I think we could at least offer a "patched" version of the etoys launch script, without the -xshm option, as proposed on https://bugs.launchpad.net/ubuntu/+source/etoys/+bug/301190.

I see this issue as important: we have today a packaged application that can simply not be launched in Ubuntu without a workaround inaccessible for the main targets of the software: educators and children.

Hi,

2009/5/18 Séverin Lemaignan <email address hidden>:
> What can be done to solve this bug which affect the final release of
> Jaunty as well? since it seems unlikely that a recompiled version of
> squeak-vm is to be proposed within the Jaunty cycle (but I may be
> wrong?),

I'm not sure; this would have to be dealt with by the squeak-vm maintainer(s).

> I think we could at least offer a "patched" version of the
> etoys launch script, without the -xshm option, as proposed on
> https://bugs.launchpad.net/ubuntu/+source/etoys/+bug/301190.

Agree. As a workaround, this seems to be fine.

Best,

Michael

Luke Faraone (lfaraone) wrote :

This is fixed in Lucid, and the workaround has been backported to previous releases. If you wish this to be fixed in an earlier release, please follow steps 1-3 of https://wiki.ubuntu.com/StableReleaseUpdates#Procedure .

Changed in squeak-vm (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers