Version 3.2 of SQL Ledger now available

Bug #1537461 reported by Maik Wagner on 2016-01-24
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sql-ledger (Ubuntu)
Undecided
RJ Clay

Bug Description

Hello Nigel,

I would like to let you know that version 3.2 of SQL Ledger has been released. Could you prepare a package for the 16.04 LTS release?

Regards,

Maik

tags: added: upgrade-software-version
RJ Clay (rjclay) on 2017-08-06
Changed in sql-ledger (Ubuntu):
status: New → Confirmed
RJ Clay (rjclay) wrote :

This package was orphaned in Debian and I am looking at adopting it. As part of that, I have attempted to update the packaging to be for upstream v3.2.5, which resulted in the following new issues:

1) The existing latex-cmdline-option patch did not apply as is to the new upstream. That will need to
   be resolved in order to proceed.

2) More importantly; it results in a following new Lintian Error:

E: sql-ledger source: source-is-missing js/calendar.js line length is 1212 characters (>512)

- That 'js/calendar.js' file is also public domain, so besides resolving the 'source-is-missing' issue, the debian/copyright file will need to be updated for it.

Maik Wagner (mtwagner) wrote :

Dear RJ Clay,

I am very glad that somebody is looking at maintaining this package. Are you looking to primarily support Ubuntu or Debian.

As upstream (DWS Systems) doesn't have its own github.com or other source code repository would it be possible to unpack the upstream tarball in launchpad.net and apply the missing files there?

If you are interested I completed some language packs for this application as well and I quite enjoy using SQL Ledger.

Would you mind sharing how to reproduce these bugs?

RJ Clay (rjclay) wrote :

On Mon, 02 Oct 2017 11:44:41 -0400
"Maik Wagner" <email address hidden> wrote:

> I am very glad that somebody is looking at maintaining this package.
> Are you looking to primarily support Ubuntu or Debian.

   I'm primaraly a packager for Debian but keep in mind that is traditionally via Debian that applications and updates to those applications are done. OTOH; if I were not interested in the status of SQL-Ledger in Ubuntu, I would not have been reviewing the bugs present for it there.

> As upstream (DWS Systems) doesn't have its own github.com or other
> source code repository

   There not being a public repository for upstream is definitely an issue.

> would it be possible to unpack the upstream
> tarball in launchpad.net and apply the missing files there?

   There is the Debian packaging repository, currently at:
https://anonscm.debian.org/gitweb/?p=collab-maint/sql-ledger.git.

   That will be changing at some point, possibly, due to infrastructure changes at Debian.
   There is also this packaging repository at GitHub, mirrored from the Debian one, where there is
   a branch for packaging v3.2.5:
https://github.com/rocasa/pkg-sql-ledger

   And regarding the missing sourse files issue itself; other applications use something like that same file, so need to see how they handle it.

> If you are interested I completed some language packs for this
> application as well and I quite enjoy using SQL Ledger.

   Shouldn't something like that be sent to upstream?

> Would you mind sharing how to reproduce these bugs?

   You mean, those lintian errors? A minimal command line for that is as follows (where my system
is set to automatically run Lintian after the build and also includes an apropriate '-e" option): debuild -rfakeroot -us -uc
   That, of course, is on an extracted sql-ledger archive with an apropriate debian/ directory.

RJ Clay (rjclay) on 2018-07-08
Changed in sql-ledger (Ubuntu):
assignee: nobody → RJ Clay (rjclay)
RJ Clay (rjclay) wrote :

Note that version 3.2.6-1 of the sql-ledger package was uploaded to Debian unstable on 6 July 2018, at which point I also became the maintainer. Barring any issues, I anticipate the new version of the package to transition to Ubuntu on or after Wednesday, 11 July 2018.

Robert James Clay
 <email address hidden>
 <email address hidden>

RJ Clay (rjclay) on 2018-07-09
Changed in sql-ledger (Ubuntu):
status: Confirmed → Fix Released
RJ Clay (rjclay) wrote :

Apologies; note that my gmail email address is <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers