[Dapper] Sound-juicer crashes after editing gconf keys

Bug #38300 reported by ian marcinkowski on 2006-04-05
18
Affects Status Importance Assigned to Milestone
Sound Juicer
Fix Released
Medium
sound-juicer (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

In order to obtain properly tagged/named files, I'm required to go into gconf and manually edit the file-naming scheme that sound-juicer uses (which is a bug in its self, IMO).

Since doing a fresh Dapper Flight 6 install last week, I havn't ripped any CDs, until now.

After going editing the file_pattern and path_pattern keys, sound-juicer now crashes when I try to access the preferences dialog even though I've changed the gconf keys back to their default settings.

The following is generated by bug buddy:

Backtrace was generated from '/usr/bin/sound-juicer'

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1226471744 (LWP 4074)]
[New Thread -1236771920 (LWP 4076)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xffffe410 in __kernel_vsyscall ()
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb72da48b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7dc1672 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
#3 <signal handler called>
#4 0xb7428101 in g_utf8_validate () from /usr/lib/libglib-2.0.so.0
#5 0xb752a4f9 in gconf_engine_set_string () from /usr/lib/libgconf-2.so.4
#6 0xb752d8b5 in gconf_client_set_string () from /usr/lib/libgconf-2.so.4
#7 0x08055514 in prefs_file_option_changed ()
#8 0xb74eb423 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#9 0xb74df79f in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#10 0xb74ee4de in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#11 0xb74efae9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#12 0xb74efe59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#13 0xb7906ecb in gtk_combo_box_get_column_span_column ()
   from /usr/lib/libgtk-x11-2.0.so.0
#14 0xb7907076 in gtk_combo_box_set_active ()
   from /usr/lib/libgtk-x11-2.0.so.0
#15 0x08055a08 in prefs_edit_profile_clicked ()
#16 0x080560b7 in on_edit_preferences_cb ()
#17 0xb74eb423 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#18 0xb74df79f in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#19 0xb74ee4de in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#20 0xb74efae9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#21 0xb74efe59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#22 0xb7a765ad in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#23 0xb79a31af in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#24 0xb79a3481 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
#25 0xb7999c34 in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
#26 0xb7994540 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#27 0xb74df16f in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#28 0xb74df79f in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#29 0xb74ee9d8 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#30 0xb74ef856 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#31 0xb74efe59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#32 0xb7a7678f in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#33 0xb7992cbd in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#34 0xb79930cb in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#35 0xb7836e1c in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
#36 0xb74057d7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#37 0xb7408896 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#38 0xb7408bb8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#39 0xb79923c6 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#40 0x08055160 in main ()

Thread 2 (Thread -1236771920 (LWP 4076)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb725e8b4 in poll () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.
#2 0xb74086e8 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3 0xb7408bb8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4 0xb74a870e in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5 0xb7421472 in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6 0xb72d4341 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#7 0xb72684de in clone () from /lib/tls/i686/cmov/libc.so.6
No symbol table info available.

Thread 1 (Thread -1226471744 (LWP 4074)):
#0 0xffffe410 in __kernel_vsyscall ()
No symbol table info available.
#1 0xb72da48b in __waitpid_nocancel ()
   from /lib/tls/i686/cmov/libpthread.so.0
No symbol table info available.
#2 0xb7dc1672 in libgnomeui_module_info_get ()
   from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3 <signal handler called>
No symbol table info available.
#4 0xb7428101 in g_utf8_validate () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#5 0xb752a4f9 in gconf_engine_set_string () from /usr/lib/libgconf-2.so.4
No symbol table info available.
#6 0xb752d8b5 in gconf_client_set_string () from /usr/lib/libgconf-2.so.4
No symbol table info available.
#7 0x08055514 in prefs_file_option_changed ()
No symbol table info available.
#8 0xb74eb423 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#9 0xb74df79f in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#10 0xb74ee4de in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#11 0xb74efae9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#12 0xb74efe59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#13 0xb7906ecb in gtk_combo_box_get_column_span_column ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#14 0xb7907076 in gtk_combo_box_set_active ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#15 0x08055a08 in prefs_edit_profile_clicked ()
No symbol table info available.
#16 0x080560b7 in on_edit_preferences_cb ()
No symbol table info available.
#17 0xb74eb423 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#18 0xb74df79f in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#19 0xb74ee4de in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#20 0xb74efae9 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#21 0xb74efe59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#22 0xb7a765ad in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#23 0xb79a31af in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#24 0xb79a3481 in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#25 0xb7999c34 in gtk_menu_reorder_child () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#26 0xb7994540 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#27 0xb74df16f in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#28 0xb74df79f in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#29 0xb74ee9d8 in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#30 0xb74ef856 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#31 0xb74efe59 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
No symbol table info available.
#32 0xb7a7678f in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#33 0xb7992cbd in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#34 0xb79930cb in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#35 0xb7836e1c in _gdk_events_queue () from /usr/lib/libgdk-x11-2.0.so.0
No symbol table info available.
#36 0xb74057d7 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#37 0xb7408896 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#38 0xb7408bb8 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#39 0xb79923c6 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#40 0x08055160 in main ()
No symbol table info available.
#0 0xffffe410 in __kernel_vsyscall ()

Daniel Holbach (dholbach) wrote :

Thanks for your bug report. Which values did you put in there?

Changed in sound-juicer:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info

I changed:
base_uri
from: file:///home/ian -to- file:///home/ian/Desktop
device
from: <no value> -to- /dev/hdd (though I changed this back after this bug reared it's head)
file_pattern
from: %tn - %tt -to- %aA - %aT - %tN - %tT
paranoia
from: 8 -to- 255

I've since changed all values back to their defaults and sound-juicer is still crashing.

Sebastien Bacher (seb128) wrote :

Could you get a backtrace with libglib2.0-0-dbg installed?

I installed libglib2.0-0-dbg and got a rather small backtrace:

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1226017088 (LWP 17330)]

[New Thread -1236235344 (LWP 17336)]

(sound-juicer:17330): GLib-GObject-WARNING **: value "6.000000" of type `gfloat' is invalid or out of range for property `quality' of type `gfloat'
Could not fully determine drive profile 0: Error reading disc information

** (sound-juicer:17330): WARNING **: Error getting media type

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1226017088 (LWP 17330)]
0xb7497101 in g_utf8_validate () from /usr/lib/libglib-2.0.so.0

Reading the middle section, I just remembered that I changed the vorbis quality in the 'lossy' profile from 0.2 (or something) to 6. Perhaps that has something to do with the crashing.

The segfault happens right when I try to access the prefs dialog.

Sebastien Bacher (seb128) wrote :

The quality value is probably a different issue. Can you try to get a backtrace after update libglib2.0-0-dbg? The dbg package was not a debug one for some days but that is fixed now

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1226189120 (LWP 1548)]
0xb746d151 in IA__g_utf8_validate (str=<value optimized out>, max_len=-1,
    end=0x0) at gutf8.c:1561
1561 gutf8.c: No such file or directory.
        in gutf8.c

Download full text (4.9 KiB)

(gdb) thread apply all bt

Thread 2 (Thread -1236104272 (LWP 22286)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb72eb8c4 in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7495788 in g_main_context_iterate (context=0x8230060, block=1,
    dispatch=1, self=0x822f8f8) at gmain.c:2849
#3 0xb7495c58 in IA__g_main_loop_run (loop=0x82300e0) at gmain.c:2751
#4 0xb753570e in link_thread_io_context () from /usr/lib/libORBit-2.so.0
#5 0xb74ae582 in g_thread_create_proxy (data=0x822f8f8) at gthread.c:582
#6 0xb7361341 in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#7 0xb72f54ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread -1225894208 (LWP 22281)):
#0 0xb74b5151 in IA__g_utf8_validate (str=<value optimized out>, max_len=-1,
    end=0x0) at gutf8.c:1561
#1 0xb75b74f9 in gconf_engine_set_string () from /usr/lib/libgconf-2.so.4
#2 0xb75ba8b5 in gconf_client_set_string () from /usr/lib/libgconf-2.so.4
#3 0x08055514 in prefs_file_option_changed ()
#4 0xb7578423 in IA__g_cclosure_marshal_VOID__VOID (closure=0x84e2a08,
    return_value=0x0, n_param_values=1, param_values=0xbfc9300c,
    invocation_hint=0xbfc92efc, marshal_data=0x80554d7) at gmarshal.c:77
#5 0xb756c79f in IA__g_closure_invoke (closure=0x84e2a08,
    return_value=0x203e62, n_param_values=2113122, param_values=0x203e62,
---Type <return> to continue, or q <return> to quit---
    invocation_hint=0x203e62) at gclosure.c:490
#6 0xb757b2ea in signal_emit_unlocked_R (node=0x83b8b40, detail=0,
    instance=0x83d3a60, emission_return=0x0, instance_and_params=0xbfc9300c)
    at gsignal.c:2438
#7 0xb757cb19 in IA__g_signal_emit_valist (instance=0x83d3a60, signal_id=253,
    detail=0, var_args=<value optimized out>) at gsignal.c:2197
#8 0xb757ce89 in IA__g_signal_emit (instance=0x203e62, signal_id=2113122,
    detail=2113122) at gsignal.c:2241
#9 0xb7993ecb in gtk_combo_box_get_column_span_column ()
   from /usr/lib/libgtk-x11-2.0.so.0
#10 0xb7994076 in gtk_combo_box_set_active () from /usr/lib/libgtk-x11-2.0.so.0
#11 0x08055a08 in prefs_edit_profile_clicked ()
#12 0x080560b7 in on_edit_preferences_cb ()
#13 0xb7578423 in IA__g_cclosure_marshal_VOID__VOID (closure=0x83ff058,
    return_value=0x0, n_param_values=1, param_values=0xbfc9358c,
    invocation_hint=0xbfc9347c, marshal_data=0x8055b6b) at gmarshal.c:77
#14 0xb756c79f in IA__g_closure_invoke (closure=0x83ff058,
    return_value=0x203e62, n_param_values=2113122, param_values=0x203e62,
    invocation_hint=0x203e62) at gclosure.c:490
#15 0xb757b2ea in signal_emit_unlocked_R (node=0x81d7e78, detail=0,
    instance=0x8070f78, emission_return=0x0, instance_and_params=0xbfc9358c)
    at gsignal.c:2438
#16 0xb757cb19 in IA__g_signal_emit_valist (instance=0x8070f78, signal_id=184,
---Type <return> to continue, or q <return> to quit---
    detail=0, var_args=<value optimized out>) at gsignal.c:2197
#17 0xb757ce89 in IA__g_signal_emit (instance=0x203e62, signal_id=2113122,
    detail=2113122) at gsignal.c:2241
#18 0xb7b035ad in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
#19 0xb7a301af in gtk_menu_shell_activate_item ()
   from /usr/lib/libgtk-x11...

Read more...

Sebastien Bacher (seb128) wrote :

So according to the backtrace the interesting value is optimized ...

Maybe you could rebuild the gconf2 package with debug (https://wiki.ubuntu.com/DebuggingProgramCrash) to figure what gconf key is the issue?

Sebastien Bacher (seb128) wrote :
Changed in sound-juicer:
status: Needs Info → Confirmed
Changed in sound-juicer:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Comment from upstream:

"Hm, I can't replicate this at all. :/

Can someone who can grab the source and start by printing the values of active
and pattern in prefs_file_option_changed()?"

Is anybody still have that issue with edgy?

Sebastien Bacher (seb128) wrote :

anybody still having the issue?

I'm not having this problem anymore. This problem disappeared a while ago, though I don't think I did anything special.

*shrug*

I'm still running Dapper if that matters.

Sebastien Bacher (seb128) wrote :

Marking as fixed then. Feel free to reopen if you get the issue again

Changed in sound-juicer:
status: Confirmed → Fix Released
Changed in sound-juicer:
status: Confirmed → Needs Info
Changed in sound-juicer:
status: Needs Info → Fix Released
Changed in sound-juicer:
status: Fix Released → Confirmed
Changed in sound-juicer:
status: Confirmed → Fix Released
Changed in sound-juicer:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.