[Kubuntu 18.04]Device notifier pretends it cannot mount usb device while actually mounting it

Bug #1762163 reported by YAFU
104
This bug affects 23 people
Affects Status Importance Assigned to Milestone
solid (Ubuntu)
Undecided
Unassigned

Bug Description

There is a Fix proposed from comment 36

https://bugs.kde.org/show_bug.cgi?id=370975
====
I have this problem when trying to mount any removable device or internal disk partition, either from Dolphin or from removable device manager in panel. It always shows an error message when you try to mount the device first time, the device is not opened in Dolphin but it is mounted correctly. Then at the second attempt it does not show error message and device is opened in Dolphin.
The messages that I get in Spanish:
From Dolphin:
"Ocurrió un error al acceder a «Carpeta personal», el sistema respondió: El dispositivo ya está montado: Device /dev/sdb3 is already mounted at `/media/yafu/PART 1'."

From removable device manager in panel a window message titled "Error Cliente KIO ?" and "Formato de URL erroneo" message.

By the way, in a recent Dolphin update, when you mount partitions from the small folder/home icon to the left of the Dolphin address bar (that icon only appears if you have Panels > Places disabled), every time you Mount a device from there that menu is filled enormously with "Umount <<Partition X>>" items. Really annoying.

===
Related messages in English:
"Error KIO Client" with the text "malformed URL"

"An error occurred while accessing 'Home', the system responded: The device is already mounted: Device /dev/sdl1 is already mounted at '/media/myuser/disk title'.

Revision history for this message
YAFU (yafu) wrote :

The is an update:
https://bugs.kde.org/show_bug.cgi?id=370975

Problem is not udisk, is Solid component. Patch available there (Comment 50)
https://bugs.kde.org/show_bug.cgi?id=370975#c50

affects: udisks2 (Ubuntu) → solid (Ubuntu)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in solid (Ubuntu):
status: New → Confirmed
Revision history for this message
Anton Petrusevich (apetr) wrote :

I updated KDE to 5.12.5 from Backports PPA and problem is still persists.

Revision history for this message
Ian Proudler (ikp1) wrote :

I have just completed a fresh installed of Kubuntu 18.04 which contains Plasma version 5.12.6. The problem is still present.

Revision history for this message
Janghou (janghou) wrote :

FYI, I have this problem with ext4 formatted USB drives, not with fat32 drives.

Revision history for this message
Claudio Lanconelli (claudiolanconelli) wrote :

The bug is fixed in solid 5.46, back port it to 5.44 for bionic 18.04 LTS, please

https://cgit.kde.org/solid.git/commit/?id=d735708ff11c40ee6b9bee64544250d55067403f

Revision history for this message
Curtis Gedak (gedakc) wrote :

This issue with mounting and displaying "Malformed URL" is still a problem with Kubuntu 18.04.4 LTS Bionic Beaver with all updates applied as of today (Feb 17, 2020).

There is a confusing history of bug reports and patches for this issue, as follows:

USB Drives Give Malformed URL From Device Notifier
https://www.kubuntuforums.net/showthread.php/73500-USB-Drives-Give-Malformed-URL-From-Device-Notifier

Plugging in usb drive gives malformed url from device notifer
https://bugs.kde.org/show_bug.cgi?id=391381

device notifier pretends it cannot mount usb device while actually mounting it
https://bugs.kde.org/show_bug.cgi?id=370975

Backport fix for 391706 into Frameworks 5.44
https://phabricator.kde.org/T9525

Backport automount fix into Bionic
https://bugs.launchpad.net/ubuntu/+source/solid/+bug/1762433

Backport fix for KDE bug 391706 into Frameworks 5.44
https://bugs.launchpad.net/ubuntu/+source/solid/+bug/1789292

It would be helpful to myself and other kubuntu 18.04 users if the issue could be fixed soon.

Revision history for this message
Curtis Gedak (gedakc) wrote :

Thank you Claudio Lanconelli for your post #6 which indicated where a patch could be found.

I created a PPA that has that upstream fix applied to the current Kubuntu 18.04 solid package. See:

https://launchpad.net/~gedakc/+archive/ubuntu/solid-1804-ppa

In my testing the updated packages in my PPA did indeed fix the problem as described in this bug report.

Please feel free to try my PPA and let me know if it works for you.

Revision history for this message
Claudio Lanconelli (claudiolanconelli) wrote :

I tried your PPA and it fixes the issue, thank you Curtis.

Revision history for this message
Curtis Gedak (gedakc) wrote :

Thanks Claudio for confirming that my PPA with the upstream Solid patch fixes the issue.

Thanks also YAFU for creating this bug report. I just noticed that you had also included a link to the upstream patch to the Solid package.

When I tried to track down the cause there were many related bug reports, such as those listed in post #7. This made it difficult to discover what the cause and fix might be.

It would be great if this upstream fix could be applied to the official Kubuntu repositories.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.