Not able to change software origins in software-properties-kde - TypeError: coercing to Unicode: need string or buffer, NoneType found

Bug #768363 reported by jovan dragisic on 2011-04-21
98
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Software Properties
Fix Released
Undecided
Unassigned
python-apt (Ubuntu)
High
Stéphane Graber
software-properties (Ubuntu)
High
Stéphane Graber

Bug Description

Kubuntu (11.04)Natty Narwahl, 32 bit Not able to get the software properties dialog.

Bug reproducible? Yes.

Steps to reproduce:

1. Open KPackageKit
2. Choose the "Edit origins button"
3. Fill in the policykit dialog
4. Nothing happens.

The expected result would be to get a graphical window on which One could add repositories, or, much more importantly, change the download server.

Running kdesudo kde-software properties gives out the following message:

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/mreto/.config/ibus/bus
Traceback (most recent call last):
  File "/usr/bin/software-properties-kde", line 122, in <module>
    app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=file, attachWinID=attachWinID)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 129, in __init__
    self.init_distro()
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 258, in init_distro
    checkbox = QCheckBox(utf8(template.description),
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/I18nHelper.py", line 46, in utf8
    return unicode(str, 'latin1')
TypeError: coercing to Unicode: need string or buffer, NoneType found
Application asked to unregister timer 0x22000009 which is not registered in this thread. Fix application.
Application asked to unregister timer 0x63000006 which is not registered in this thread. Fix application.

Additional information on demand.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-properties-kde 0.80.8
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Thu Apr 21 16:05:47 2011
InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta i386 (20110418)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

jovan dragisic (jdragisic) wrote :
Deput (deput1) on 2011-04-21
Changed in software-properties:
status: New → Opinion
status: Opinion → Invalid
Paul Loughman (snowhog) wrote :

Status Invalid!! Based on what?

This is a bug - it is valid. I happens here on my NN 32-bit, KDE 4.6.2, fully updated. KPackagekit and Muon both won't open the Software Sources for editing.

jovan dragisic (jdragisic) wrote :

lolol

Paul White (paulw2u) wrote :

Paul L, I can confirm the bug and the steps you took to reproduce it.

metamarket (cancel-allow) wrote :

I can confirm bug and steps to (Kubuntu 11.04/i386). software-properties-GTK works just fine.

Deput (deput1) wrote :

Paul L., It's just my fault

Changed in software-properties:
status: Invalid → New
jovan dragisic (jdragisic) wrote :

True, the gtk package, once downloaded, works fine.

Easy to reproduce.

summary: - Not able to change software origins
+ Not able to change software origins in software-properties-kde
Changed in software-properties (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
summary: - Not able to change software origins in software-properties-kde
+ Not able to change software origins in software-properties-kde -
+ TypeError: coercing to Unicode: need string or buffer, NoneType found
tags: added: python27

Oh, I clicked accidentally on something. So, back how it was, sorry.

Changed in software-properties:
status: New → Fix Committed
status: Fix Committed → New
oldos2er (oldos2er) wrote :

I think I'm experiencing the same bug. Kubuntu 11.04, 64-bit, KDE 4.6.2. Terminal output:

ann@ann-Dell-XPS410:~$ kdesu software-properties-kde
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/ann/.config/ibus/bus
Traceback (most recent call last):
  File "/usr/bin/software-properties-kde", line 122, in <module>
    app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=file, attachWinID=attachWinID)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 129, in __init__
    self.init_distro()
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 258, in init_distro
    checkbox = QCheckBox(utf8(template.description),
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/I18nHelper.py", line 46, in utf8
    return unicode(str, 'latin1')
TypeError: coercing to Unicode: need string or buffer, NoneType found
Application asked to unregister timer 0x22000009 which is not registered in this thread. Fix application.
Application asked to unregister timer 0x63000006 which is not registered in this thread. Fix application.

Romain Perier (rperier) wrote :

The Gtk and the KDE frontends have exactly the same problem, except the KDE frontend should not crash. See the fix in attachment.
Then have a look at https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/769364

tags: added: patch
tags: added: iso-testing

thanks for the path romian perier but what file do i put the patch in

Romain Perier (rperier) wrote :

Oh sorry I did not say how to apply it (also it's not really clean). See the new patch in attachment.

To apply it, execute the following commands from a terminal:
$ apt-get source software-properties-kde
$ cd software-properties-0.80.8
$ patch -p1 < patch.diff

Now execute software-properties-kde locally from this directory:
$ kdesudo ./software-properties-kde

It should not crash anymore

Felix Geyer (debfx) on 2011-04-24
Changed in software-properties (Ubuntu):
milestone: none → ubuntu-11.04
importance: Medium → High
tags: added: kubuntu
Felix Geyer (debfx) wrote :

This is caused by python-apt 0.7.100.3ubuntu5 which adds a section to /usr/share/python-apt/templates/Ubuntu.info without a _Description key.

Running software-properties-gtk with kdesudo doesn't bring up double entries
in the list in Kubuntu. The bug probably affects the KDE and the Gnome ways
in different ways.

On Sun, Apr 24, 2011 at 2:14 PM, Romain Perier <email address hidden>wrote:

> see also https://bugs.launchpad.net/ubuntu/+source/software-
> properties/+bug/768469
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/768363
>
> Title:
> Not able to change software origins in software-properties-kde -
> TypeError: coercing to Unicode: need string or buffer, NoneType found
>
> Status in The apt sources.list editor used in Ubuntu (and Kubuntu):
> New
> Status in “software-properties” package in Ubuntu:
> Confirmed
>
> Bug description:
> Kubuntu (11.04)Natty Narwahl, 32 bit Not able to get the software
> properties dialog.
>
> Bug reproducible? Yes.
>
> Steps to reproduce:
>
> 1. Open KPackageKit
> 2. Choose the "Edit origins button"
> 3. Fill in the policykit dialog
> 4. Nothing happens.
>
> The expected result would be to get a graphical window on which One
> could add repositories, or, much more importantly, change the download
> server.
>
> Running kdesudo kde-software properties gives out the following
> message:
>
>
> QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No
> such file or directory
> QFileSystemWatcher: failed to add paths: /home/mreto/.config/ibus/bus
> Traceback (most recent call last):
> File "/usr/bin/software-properties-kde", line 122, in <module>
> app = SoftwarePropertiesKDE(datadir=data_dir, options=options,
> file=file, attachWinID=attachWinID)
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
> line 129, in __init__
> self.init_distro()
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
> line 258, in init_distro
> checkbox = QCheckBox(utf8(template.description),
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/I18nHelper.py",
> line 46, in utf8
> return unicode(str, 'latin1')
> TypeError: coercing to Unicode: need string or buffer, NoneType found
> Application asked to unregister timer 0x22000009 which is not registered
> in this thread. Fix application.
> Application asked to unregister timer 0x63000006 which is not registered
> in this thread. Fix application.
>
> Additional information on demand.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: software-properties-kde 0.80.8
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> Architecture: i386
> Date: Thu Apr 21 16:05:47 2011
> InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta i386 (20110418)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-properties
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/software-properties/+bug/768363/+subscribe
>

Romain Perier (rperier) wrote :

Well, it does not bring up double entries for you but I can reproduce the bug for the Gtk and the Kde frontend...

jovan dragisic (jdragisic) wrote :

Yes, I left out the "for me" part in my previous post. Sorry.

On Sun, Apr 24, 2011 at 2:48 PM, Romain Perier <email address hidden>wrote:

> Well, it does not bring up double entries for you but I can reproduce
> the bug for the Gtk and the Kde frontend...
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/768363
>
> Title:
> Not able to change software origins in software-properties-kde -
> TypeError: coercing to Unicode: need string or buffer, NoneType found
>
> Status in The apt sources.list editor used in Ubuntu (and Kubuntu):
> New
> Status in “software-properties” package in Ubuntu:
> Confirmed
>
> Bug description:
> Kubuntu (11.04)Natty Narwahl, 32 bit Not able to get the software
> properties dialog.
>
> Bug reproducible? Yes.
>
> Steps to reproduce:
>
> 1. Open KPackageKit
> 2. Choose the "Edit origins button"
> 3. Fill in the policykit dialog
> 4. Nothing happens.
>
> The expected result would be to get a graphical window on which One
> could add repositories, or, much more importantly, change the download
> server.
>
> Running kdesudo kde-software properties gives out the following
> message:
>
>
> QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No
> such file or directory
> QFileSystemWatcher: failed to add paths: /home/mreto/.config/ibus/bus
> Traceback (most recent call last):
> File "/usr/bin/software-properties-kde", line 122, in <module>
> app = SoftwarePropertiesKDE(datadir=data_dir, options=options,
> file=file, attachWinID=attachWinID)
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
> line 129, in __init__
> self.init_distro()
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
> line 258, in init_distro
> checkbox = QCheckBox(utf8(template.description),
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/I18nHelper.py",
> line 46, in utf8
> return unicode(str, 'latin1')
> TypeError: coercing to Unicode: need string or buffer, NoneType found
> Application asked to unregister timer 0x22000009 which is not registered
> in this thread. Fix application.
> Application asked to unregister timer 0x63000006 which is not registered
> in this thread. Fix application.
>
> Additional information on demand.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: software-properties-kde 0.80.8
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> Architecture: i386
> Date: Thu Apr 21 16:05:47 2011
> InstallationMedia: Kubuntu 11.04 "Natty Narwhal" - Beta i386 (20110418)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-properties
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/software-properties/+bug/768363/+subscribe
>

Changed in software-properties (Ubuntu):
assignee: nobody → Stéphane Graber (stgraber)
status: Confirmed → Fix Committed
Changed in python-apt (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
assignee: nobody → Stéphane Graber (stgraber)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.80.9

---------------
software-properties (0.80.9) natty; urgency=low

  * In "Updates" tab (qt and gtk), ignore all deb-src templates.
    (LP: #768363, LP: #768469)
 -- Stephane Graber <email address hidden> Sun, 24 Apr 2011 13:37:52 -0400

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.7.100.3ubuntu6

---------------
python-apt (0.7.100.3ubuntu6) natty; urgency=low

  * Add missing _Description entry to Ubuntu.info for new deb-src entries.
    (LP: #768363)
 -- Stephane Graber <email address hidden> Sun, 24 Apr 2011 13:24:53 -0400

Changed in python-apt (Ubuntu):
status: Fix Committed → Fix Released
Heimen Stoffels (vistaus) wrote :

What fix? It isn't fixed. I still get this error:

vistausss@vistausss-hp:~/fromsvngit/choqok$ kdesudo software-properties-kde
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: Bestand of map bestaat niet
QFileSystemWatcher: failed to add paths: /home/vistausss/.config/ibus/bus
Traceback (most recent call last):
  File "/usr/bin/software-properties-kde", line 122, in <module>
    app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=file, attachWinID=attachWinID)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 129, in __init__
    self.init_distro()
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 258, in init_distro
    checkbox = QCheckBox(utf8(template.description),
  File "/usr/lib/python2.7/dist-packages/softwareproperties/kde/I18nHelper.py", line 46, in utf8
    return unicode(str, 'latin1')
TypeError: coercing to Unicode: need string or buffer, NoneType found
Application asked to unregister timer 0x22000009 which is not registered in this thread. Fix application.
Application asked to unregister timer 0x63000006 which is not registered in this thread. Fix application.
vistausss@vistausss-hp:~/fromsvngit/choqok$

I'm updated, so that's not the problem.

alfabravoteam (alfabravoteam) wrote :
Download full text (4.6 KiB)

Vistaus, check again. I was updated til 1 hour ago and the updates were not
there yet. Now I read your mail and python-apt, python-apt-common and
software-properties-kde appear in software updates.

It is the problem, trust them.

PS. BTW, I used the patch.diff and it worked. It means the problem was
actually addressed. Updating, I'll let you know if something unussual
happens.

On Sun, Apr 24, 2011 at 4:35 PM, Vistaus <email address hidden> wrote:

> What fix? It isn't fixed. I still get this error:
>
> vistausss@vistausss-hp:~/fromsvngit/choqok$ kdesudo
> software-properties-kde
> QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed:
> Bestand of map bestaat niet
> QFileSystemWatcher: failed to add paths: /home/vistausss/.config/ibus/bus
> Traceback (most recent call last):
> File "/usr/bin/software-properties-kde", line 122, in <module>
> app = SoftwarePropertiesKDE(datadir=data_dir, options=options,
> file=file, attachWinID=attachWinID)
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
> line 129, in __init__
> self.init_distro()
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
> line 258, in init_distro
> checkbox = QCheckBox(utf8(template.description),
> File
> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/I18nHelper.py",
> line 46, in utf8
> return unicode(str, 'latin1')
> TypeError: coercing to Unicode: need string or buffer, NoneType found
> Application asked to unregister timer 0x22000009 which is not registered in
> this thread. Fix application.
> Application asked to unregister timer 0x63000006 which is not registered in
> this thread. Fix application.
> vistausss@vistausss-hp:~/fromsvngit/choqok$
>
> I'm updated, so that's not the problem.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/768363
>
> Title:
> Not able to change software origins in software-properties-kde -
> TypeError: coercing to Unicode: need string or buffer, NoneType found
>
> Status in The apt sources.list editor used in Ubuntu (and Kubuntu):
> New
> Status in “python-apt” package in Ubuntu:
> Fix Released
> Status in “software-properties” package in Ubuntu:
> Fix Released
>
> Bug description:
> Kubuntu (11.04)Natty Narwahl, 32 bit Not able to get the software
> properties dialog.
>
> Bug reproducible? Yes.
>
> Steps to reproduce:
>
> 1. Open KPackageKit
> 2. Choose the "Edit origins button"
> 3. Fill in the policykit dialog
> 4. Nothing happens.
>
> The expected result would be to get a graphical window on which One
> could add repositories, or, much more importantly, change the download
> server.
>
> Running kdesudo kde-software properties gives out the following
> message:
>
>
> QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No
> such file or directory
> QFileSystemWatcher: failed to add paths: /home/mreto/.config/ibus/bus
> Traceback (most recent call last):
> File "/usr/bin/software-properties-kde", line 122, in <module>
> app = SoftwarePropertiesKDE(datadir=data_dir, options=options,
> file=file, atta...

Read more...

alfabravoteam (alfabravoteam) wrote :
Download full text (4.9 KiB)

Confirm that the update works in Kubuntu Natty x64.

2011/4/24 Andrés Salcedo <email address hidden>

> Vistaus, check again. I was updated til 1 hour ago and the updates were not
> there yet. Now I read your mail and python-apt, python-apt-common and
> software-properties-kde appear in software updates.
>
> It is the problem, trust them.
>
> PS. BTW, I used the patch.diff and it worked. It means the problem was
> actually addressed. Updating, I'll let you know if something unussual
> happens.
>
>
> On Sun, Apr 24, 2011 at 4:35 PM, Vistaus <email address hidden> wrote:
>
>> What fix? It isn't fixed. I still get this error:
>>
>> vistausss@vistausss-hp:~/fromsvngit/choqok$ kdesudo
>> software-properties-kde
>> QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed:
>> Bestand of map bestaat niet
>> QFileSystemWatcher: failed to add paths: /home/vistausss/.config/ibus/bus
>> Traceback (most recent call last):
>> File "/usr/bin/software-properties-kde", line 122, in <module>
>> app = SoftwarePropertiesKDE(datadir=data_dir, options=options,
>> file=file, attachWinID=attachWinID)
>> File
>> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
>> line 129, in __init__
>> self.init_distro()
>> File
>> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py",
>> line 258, in init_distro
>> checkbox = QCheckBox(utf8(template.description),
>> File
>> "/usr/lib/python2.7/dist-packages/softwareproperties/kde/I18nHelper.py",
>> line 46, in utf8
>> return unicode(str, 'latin1')
>> TypeError: coercing to Unicode: need string or buffer, NoneType found
>> Application asked to unregister timer 0x22000009 which is not registered
>> in this thread. Fix application.
>> Application asked to unregister timer 0x63000006 which is not registered
>> in this thread. Fix application.
>> vistausss@vistausss-hp:~/fromsvngit/choqok$
>>
>> I'm updated, so that's not the problem.
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>> https://bugs.launchpad.net/bugs/768363
>>
>> Title:
>> Not able to change software origins in software-properties-kde -
>> TypeError: coercing to Unicode: need string or buffer, NoneType found
>>
>> Status in The apt sources.list editor used in Ubuntu (and Kubuntu):
>> New
>> Status in “python-apt” package in Ubuntu:
>> Fix Released
>> Status in “software-properties” package in Ubuntu:
>> Fix Released
>>
>> Bug description:
>> Kubuntu (11.04)Natty Narwahl, 32 bit Not able to get the software
>> properties dialog.
>>
>> Bug reproducible? Yes.
>>
>> Steps to reproduce:
>>
>> 1. Open KPackageKit
>> 2. Choose the "Edit origins button"
>> 3. Fill in the policykit dialog
>> 4. Nothing happens.
>>
>> The expected result would be to get a graphical window on which One
>> could add repositories, or, much more importantly, change the download
>> server.
>>
>> Running kdesudo kde-software properties gives out the following
>> message:
>>
>>
>> QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No
>> such file or directory
>> QFileSystemWatcher: failed to add paths: /home/mreto/.config/ibu...

Read more...

oldos2er (oldos2er) wrote :

Fixed for me, thank you!

Yes, its fixed, updated right now. Thanks.

jovan dragisic (jdragisic) wrote :

Fixed.

Heimen Stoffels (vistaus) wrote :

@alfabravoteam: No, I really was fully updated. Even software-properties-kde got updated, but the problem still appeared. Now after a reboot and again doing updates, it works. That's not really convenient. Starts to look like Windows :P But anyway, it's fixed now and that's all that counts.

Changed in software-properties:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers