duplicate entries in the updates section with python-apt-common 0.7.100.3ubuntu5 upgrade

Bug #768469 reported by Doug McMahon on 2011-04-21
122
This bug affects 19 people
Affects Status Importance Assigned to Milestone
python-apt (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned
software-properties (Ubuntu)
High
Unassigned
Natty
High
Unassigned

Bug Description

The software properties updates section has double entries

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-properties-gtk 0.80.8
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38.2-ck3-nolt i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Thu Apr 21 13:16:45 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110413)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-properties
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Rohit R (rr0hit) wrote :

I could not reproduce the bug. I think the double entries are present in /etc/apt/sources.list

Try opening /etc/apt/sources.list in a text editor and comment out one of the double entries. The problem should be solved afterwards.

Please let us know if the problem persists or not. Setting to incomplete for now.

Changed in software-properties (Ubuntu):
status: New → Incomplete
Doug McMahon (mc3man) wrote :

Not sure there - attaching the sources.list as provided in beta2 (also see the same in a slightly older install
Also went ahead and wiped out the sources.list enterilt, then let software-properties rebuild with just the min.
Still see as shown in screen - note that the "none" box cannot be checked , neither can the 2nd entry for each

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

And finally am using this simple version with updates enabled, still doesn't change from screen shot

terry_gardener (terry-gardener) wrote :

this is also affect me getting the exact same problem.

Changed in software-properties (Ubuntu):
status: Incomplete → Confirmed
Van Riales (vriales) wrote :

Have this too. Double entries in software-manager updates.

Juan Carlos (arareka-ha) wrote :

Here too, the same problem

Eric Appleman (erappleman) wrote :

Double entries confirmed. I thought they were a source entry at first.

Doug McMahon (mc3man) wrote :

It's caused by one or more of these 6 packages, should be simple to narrow down
Upgraded the following packages:
aptdaemon (0.41+bzr614-0ubuntu3) to 0.41+bzr646-0ubuntu2
python-apt (0.7.100.3ubuntu4) to 0.7.100.3ubuntu5
python-apt-common (0.7.100.3ubuntu4) to 0.7.100.3ubuntu5
python-aptdaemon (0.41+bzr614-0ubuntu3) to 0.41+bzr646-0ubuntu2
python-aptdaemon-gtk (0.41+bzr614-0ubuntu3) to 0.41+bzr646-0ubuntu2
python-aptdaemon.gtk3widgets (0.41+bzr614-0ubuntu3) to 0.41+bzr646-0ubuntu2
python-aptdaemon.gtkwidgets (0.41+bzr614-0ubuntu3) to 0.41+bzr646-0ubuntu2

Doug McMahon (mc3man) wrote :

It is the python-apt-common package that does this

summary: - duplicate entries in the updates section
+ duplicate entries in the updates section with python-apt-common
+ 0.7.100.3ubuntu5 upgrade
MAIKO (maikko) wrote :

same issue for me !

Erick Brunzell (lbsolost) wrote :

Also experienced this with both the 20110422 and 20110423 i386 iso-testing images.

tags: added: iso-testing
typo (gnomeuser8) wrote :
David Levin (dslevin) wrote :

I have the exact same issue. I commented out the duplicated and it did not fix it.

Doug McMahon (mc3man) wrote :

These are just additional entries for the deb-src of the various updates, likely from the extra deb-src entries in the template.
Seems pretty harmless, can't do anything with them anyway though they're not needed in the template to get those source files.
Remove the entries from Ubuntu.info.in and SS goes back to 'normal' except for the none option (which also does nothing here

I've the same problem here with my fully-updated Natty. Each option is displayed twice. Also, the second option of each pair can't be checked or unchecked.

Moreover, I've a None option which I don't know what is, and I can't check it.

I attach an screenshot to illustrate the problem.

For your reference, this is the contents of my /etc/apt/sources.list file. Also, /etc/apt/sources.list.d directory is empty.

As you can see, I only have "deb" records actived. I haven't got any "deb-src" records actived.

Like #11 says, python-apt-common 0.7.100.3ubuntu5 introduces the regression. Downgrading to 0.7.100.3ubuntu4 is a workaround to solve the issue.

Changed in python-apt (Ubuntu):
status: New → Confirmed

Opening python-apt task since the issue seems to be introduced by the latest version of python-apt-common.

Stéphane Graber (stgraber) wrote :

It actually seems to be a software-properties bug that wasn't visible before the latest python-apt change.

Since the last python-apt upload, most "templates" now exist twice, once for binary entries, once for source entries.

software-properties shouldn't show all of them twice. I have a small patch for this that I'm testing now to make sure we don't get a different behavior from what we had in 10.10.

Closing python-apt task as it's not a python-apt issue. software-properties ask python-apt for all existing templates and that's indeed what it receives.

Changed in python-apt (Ubuntu):
status: Confirmed → Invalid
Changed in software-properties (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in software-properties (Ubuntu Natty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.80.9

---------------
software-properties (0.80.9) natty; urgency=low

  * In "Updates" tab (qt and gtk), ignore all deb-src templates.
    (LP: #768363, LP: #768469)
 -- Stephane Graber <email address hidden> Sun, 24 Apr 2011 13:37:52 -0400

Changed in software-properties (Ubuntu Natty):
status: Fix Committed → Fix Released

Seems to works great. Thanks, Stephane!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers