software-properties-gtk crashed with UnicodeDecodeError in __init__(): 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)

Bug #721778 reported by Blümchen Blau on 2011-02-19
194
This bug affects 28 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Martin Pitt

Bug Description

Crash right after login. Therefore - no more information to give. :-)

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: software-properties-gtk 0.80.2
ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
Uname: Linux 2.6.38-4-generic i686
Architecture: i386
Date: Sat Feb 19 02:26:31 2011
ExecutablePath: /usr/bin/software-properties-gtk
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-properties-gtk -n -t 58720385
ProcEnviron:
 LANGUAGE=de_AT:de:en_GB:en
 PATH=(custom, no user)
 LANG=de_AT.UTF-8
 LC_MESSAGES=de_AT.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-properties-gtk', '-n', '-t', '58720385']
SourcePackage: software-properties
Title: software-properties-gtk crashed with UnicodeDecodeError in __init__(): 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)
UserGroups:

Related branches

Blümchen Blau (bluemchen-blau) wrote :
tags: removed: need-duplicate-check
Julien Lavergne (gilir) on 2011-02-20
visibility: private → public
Changed in software-properties (Ubuntu):
status: New → Confirmed
Bartmann (bartmix) wrote :

If i want to add a new software source the app crash.

allxsan (allxsan) wrote :

hello Bartmann

here I have the same problem with natty daily cd (Ubuntu, Xubuntu, Kubuntu, Lubuntu.. )
I have some spare hard disk just for testing
so I rsync the iso images (x86 and AMD64) 3/5 times every week and try a new installation

dino99 (9d9) wrote :

on natty i386 updated i've this issue when i click on "add" button into the third parties repo tab of synaptic

GodNobody (godnobody) wrote :

Same problem here,

trying to add a repo will cause the crash

As a workaround you can comment out the lines 61,62,63 in the file /usr/share/pyshared/softwareproperties/gtk/DialogAdd.py

It works then.

Hi,

Fine it works now.
------Originalnachricht------
Von: Thorsten Reinbold
Absender:<email address hidden>
An:Bartmann Christof
Antwort an:Bug 721778
Betreff: [Bug 721778] Re: software-properties-gtk crashed withUnicodeDecodeError in __init__(): 'ascii' codec can't decodebyte 0xc2 in position 2: ordinal not in range(128)
Gesendet: 28. Feb. 2011 16:02

As a workaround you can comment out the lines 61,62,63 in the file
/usr/share/pyshared/softwareproperties/gtk/DialogAdd.py

It works then.

--
You received this bug notification because you are a direct subscriber
of the bug.
https://bugs.launchpad.net/bugs/721778

Title:
  software-properties-gtk crashed with UnicodeDecodeError in__init__():
  'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in
  range(128)

Status in “software-properties” package in Ubuntu:
  Confirmed

Bug description:
  Crash right after login. Therefore - no more information to give. :-)

  ProblemType: Crash
  DistroRelease: Ubuntu 11.04
  Package: software-properties-gtk 0.80.2
  ProcVersionSignature: Ubuntu 2.6.38-4.31-generic 2.6.38-rc5
  Uname: Linux 2.6.38-4-generic i686
  Architecture: i386
  Date: Sat Feb 19 02:26:31 2011
  ExecutablePath: /usr/bin/software-properties-gtk
  InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
  InterpreterPath: /usr/bin/python2.7
  PackageArchitecture: all
  ProcCmdline: /usr/bin/python /usr/bin/software-properties-gtk -n -t 58720385
  ProcEnviron:
   LANGUAGE=de_AT:de:en_GB:en
   PATH=(custom, no user)
   LANG=de_AT.UTF-8
   LC_MESSAGES=de_AT.utf8
   SHELL=/bin/bash
  PythonArgs: ['/usr/bin/software-properties-gtk', '-n', '-t', '58720385']
  SourcePackage: software-properties
  Title: software-properties-gtk crashed with UnicodeDecodeError in__init__(): 'ascii' codec can't decode byte 0xc2 in position 2: ordinal not in range(128)
  UserGroups:

To unsubscribe from this bug, go to:
https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/721778/+subscribe

Sent via BlackBerry from E-Plus

Julien Lavergne (gilir) wrote :

I uploaded a possible fix to my PPA (https://launchpad.net/~gilir/+archive/unstable). To add it, you can add manually this line to your sources.list :
deb http://ppa.launchpad.net/gilir/unstable/ubuntu natty main
Hopefully, you should be able to add PPA easier after the upgrade :)

tags: added: bugpattern-needed

Julien, this seems to work well.

tags: added: bugpattern-written
removed: bugpattern-needed
Martin Pitt (pitti) wrote :

Thanks for this! I can replicate the crash here, the problem is the mixing of unicode and str here. As set_label() eventually expects an UTF-8 str, I think it's cleaner to explicitly encode the Unicode as UTF-8:

- "repository, for example '%s'.") % ("<i>%s</i>" % example)
+ "repository, for example '%s'.") % ("<i>%s</i>" % example).encode('UTF-8')

I committed this to bzr now.

Changed in software-properties (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Martin Pitt (pitti)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.80.3

---------------
software-properties (0.80.3) natty; urgency=low

  * softwareproperties/gtk/DialogAdd.py: Fix UnicodeDecodeError in "Add
    source" dialog. (LP: #721778)
 -- Martin Pitt <email address hidden> Wed, 02 Mar 2011 13:13:46 +0100

Changed in software-properties (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers