Switch to new HTTPS-capable domains for PPAs

Bug #1959015 reported by Colin Watson
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Fix Released
Medium
Unassigned
Jammy
Fix Released
Medium
Unassigned

Bug Description

As described in bug 1473091, PPAs are now being served from new domains that aren't under launchpad.net and so can safely serve HTTPS without risk of compromising Launchpad session cookies. The old domains will keep working indefinitely, but nevertheless it would be good if we could arrange for add-apt-repository to use the new domains as of 22.04.

The changes are:

 * http://ppa.launchpad.net/https://ppa.launchpadcontent.net/ (or http:// works too, but we should prefer https://)
 * https://private-ppa.launchpad.net/https://private-ppa.launchpadcontent.net/

Tags: fr-2003

Related branches

Colin Watson (cjwatson)
summary: - Switch to new HTTPS-capable domain for PPAs
+ Switch to new HTTPS-capable domains for PPAs
tags: added: rls-jj-incoming
tags: added: fr-2003
Changed in software-properties (Ubuntu Jammy):
importance: Undecided → Medium
tags: removed: rls-jj-incoming
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.99.18

---------------
software-properties (0.99.18) jammy; urgency=medium

  [ Colin Watson ]
  * Use new HTTPS-capable PPA domains (LP: #1959015).

 -- Brian Murray <email address hidden> Mon, 07 Feb 2022 10:33:15 -0800

Changed in software-properties (Ubuntu Jammy):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers