Add Ubuntu Pro banner to Livepatch page

Bug #1934439 reported by Robert Ancell
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Fix Released
Wishlist
Robert Ancell
Xenial
New
Wishlist
Robert Ancell
Bionic
Fix Released
Wishlist
Robert Ancell
Focal
Fix Released
Wishlist
Robert Ancell

Bug Description

[Impact]
Add a banner to the Livepatch page to invite users to join the Ubuntu Pro for Desktop. Note that this is not shown in current releases, as this feature only applies to older versions.

[Test Case]
1. Open Software Properties.
2. Go to Livepatch tab.
Expected result:
A banner is shown directing the user to Ubuntu Pro.
The banner can be dismissed, and doesn't return when restarting software-properties.

[Regression Potential]
Some risk of introducing a new bug, however the change is quite small and doesn't have any complex interactions.

Revision history for this message
Robert Ancell (robert-ancell) wrote :
Revision history for this message
Robert Ancell (robert-ancell) wrote :
Revision history for this message
Robert Ancell (robert-ancell) wrote :
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Information required for implementation:
- Where does the link go to, http://ubuntu.com/desktop/pro?
- Does the banner only show if you haven't already attached this machine to Ubuntu Advantage?
- When closing the banner, does it return next time?
- Does it make sense for this to be in the "Livepatch" tab - should that tab be renamed to "Ubuntu Pro" at the same time?
- When will this feature no-longer be a preview? Will that require a second SRU or can we determine that at runtime?

Revision history for this message
Sebastien Bacher (seb128) wrote :

Hey Robert, I'm going to share some thoughts but ideally confirmation would come from design

> - Does the banner only show if you haven't already attached this machine to Ubuntu Advantage?

I guess it makes sense to only show it when the service isn't already in use

> - When closing the banner, does it return next time?

The design on miro has a note 'Users should be able to permanently dismis this', they didn't specify how, by asking the question when dismissing I guess?

> Does it make sense for this to be in the "Livepatch" tab - should that tab be renamed to "Ubuntu Pro" at the same time?

I think you pointed out during the first discussions that the banner would make more sense in the updates tab, we should get design to comment about that. Renaming sounds like an alternative

Revision history for this message
Lech Sandecki (lsandecki) wrote :

Thanks for sharing that, Robert.

I like the idea to rename the Livepatch tab to Ubuntu Pro and this is the design that I think is planned for 21.10. That said, the idea of adding that banner to the 'software updates' card is worth discussing if it's as easy to implement as the current design.

Dismissing the banner is ok and I don't think it should return. I also don't think that we need to make it automatically disappear if you attached your desktop. At this stage, I am not even sure if you will be aware when a subscription got attached, but for 21.10 you will have to know that.

The link would most probably take you to ubuntu.com/advantage. Hopefully, it can be updated at a later stage if we see a need for a dedicated /desktop/pro page.

By 21.10 we should have a target design ready and it will be implemented by another SRU. I don't expect any other "non-beta" conversion to happen between now and 21.10 therefore I don't see a need for smart beta-status management.

hope it helps!

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Thanks for the feedback. Which distribution(s) should this be targetting?

Revision history for this message
Lech Sandecki (lsandecki) wrote :

It's for xenial, bionic and focal

no longer affects: software-properties (Ubuntu Hirsute)
no longer affects: software-properties (Ubuntu Impish)
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Lech - the Xenial version doesn't have a Livepatch page, should it be placed somewhere else?

Changed in software-properties (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in software-properties (Ubuntu Focal):
assignee: nobody → Robert Ancell (robert-ancell)
description: updated
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks Robert, I saw that you uploaded to bionic and focal now, any reason to not merge to impish? If technically the feature doesn't apply to the current serie maybe we should just merge with a default setting to false so we just need to turn the option on for the next LTS if needed?

Revision history for this message
Robert Ancell (robert-ancell) wrote :

A couple of points about putting it into Impish:
- What mechanism can we use to determine if it should show?
- Since the banner refers to a beta feature, it will be replaced at some point with a new banner, is it worth bringing that into Impish or waiting for the more complete feature.

Revision history for this message
Sebastien Bacher (seb128) wrote :

> - What mechanism can we use to determine if it should show?

I don't think we have one atm which is why I was suggesting to just change the key default so false there

> is it worth bringing that into Impish

I'm just trying to anticipate a discussion with the SRU team and extra delays due to it but let me ask them directly instead

Revision history for this message
Brian Murray (brian-murray) wrote :

When considering these changes for an SRU I'd like to see the code changes landed in Impish so we don't lose track of them for J. That being said if they are in fact going to be replaced at some point, they don't necessarily need to be in the archive and just having them committed to the VCS would be fine with me.

Changed in software-properties (Ubuntu):
importance: Undecided → Wishlist
Changed in software-properties (Ubuntu Xenial):
importance: Undecided → Wishlist
Changed in software-properties (Ubuntu Bionic):
importance: Undecided → Wishlist
Changed in software-properties (Ubuntu Focal):
importance: Undecided → Wishlist
Revision history for this message
Brian Murray (brian-murray) wrote :

I'm accepting this for Focal now but would like to see it uploaded for Jammy too.

tags: added: rls-jj-incoming
Changed in software-properties (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Robert, or anyone else affected,

Accepted software-properties into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.99.9.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in software-properties (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Robert, or anyone else affected,

Accepted software-properties into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.24.32.17 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Tested software-properties-gtk 0.96.24.32.17 on bionic. Confirmed banner shows with correct link and can be dismissed.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Revision history for this message
Robert Ancell (robert-ancell) wrote :

Tested software-properties-gtk 0.99.9.8 on focal. Confirmed banner shows with correct link and can be dismissed.

tags: added: verification-done-focal
removed: verification-needed verification-needed-focal
Changed in software-properties (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in software-properties (Ubuntu Xenial):
assignee: nobody → Robert Ancell (robert-ancell)
tags: removed: rls-jj-incoming
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Robert, or anyone else affected,

Accepted software-properties into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/software-properties/0.96.24.32.18 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
removed: verification-done-bionic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.99.9.8

---------------
software-properties (0.99.9.8) focal; urgency=medium

  [ Corey Bryant ]
  * cloudarchive: Enable support for the Yoga Ubuntu Cloud Archive on
    20.04 (LP: #1948806).

  [ Chad Smith ]
  * utils: prefer /var/lib/ubuntu-advantage/status.json over ua status
    - Handle absent /var/lib/ubuntu-advantage/status.json for non-root
      users (LP: #1939732)
    - print unexcepted errors and if _schema_version not equal to 0.1

software-properties (0.99.9.7) focal; urgency=medium

  * Show Ubuntu Pro banner on Livepatch page (LP: #1934439)

software-properties (0.99.9.6) focal; urgency=medium

  * Show ESM support status (LP: #1920836)

 -- Corey Bryant <email address hidden> Tue, 26 Oct 2021 08:27:56 -0400

Changed in software-properties (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for software-properties has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Robert Ancell (robert-ancell) wrote :

Tested software-properties-gtk 0.96.24.32.18 on bionic. Confirmed banner shows with correct link and can be dismissed.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.99.16

---------------
software-properties (0.99.16) jammy; urgency=medium

  * Show Ubuntu Pro banner on Livepatch page (LP: #1934439)

 -- Robert Ancell <email address hidden> Wed, 17 Nov 2021 16:17:44 +1300

Changed in software-properties (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.96.24.32.18

---------------
software-properties (0.96.24.32.18) bionic; urgency=medium

  [ Chad Smith ]
  * utils: prefer /var/lib/ubuntu-advantage/status.json over ua status
    - Handle absent /var/lib/ubuntu-advantage/status.json for non-root
      users (LP: #1939732)
    - print unexpected errors and if _schema_version not equal to 0.1

software-properties (0.96.24.32.17) bionic; urgency=medium

  * Show Ubuntu Pro banner on Livepatch page (LP: #1934439)

 -- Robert Ancell <email address hidden> Fri, 05 Nov 2021 16:44:17 +1300

Changed in software-properties (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers