Comment 8 for bug 1381050

Bruno Nova (brunonova) wrote :

I updated to -proposed and tested but, unfortunately, the bug isn't fixed!
The other bug is fixed, though.

Adding a key in "/home/$USER/TransferĂȘncias" didn't work. Nothing happened after authenticating as admin.
However, if I run software-properties-dbus manually (by executing "sudo python3 /usr/lib/software-properties/software-properties-dbus"), it works.

After further investigation, I would say that software-properties-dbus is started in the C locale (non UTF-8), making it fail in paths with special characters.
I checked the file "/proc/$software-properties-dbus-PID/environ", and it's almost empty. It only contains the variables DBUS_STARTER_ADDRESS and DBUS_STARTER_BUS_TYPE, but no locale related variables.

@Michael, that's probably why I said that the fix with your changes worked (https://code.launchpad.net/~brunonova/software-properties/lp1381050/+merge/238873/comments/613431).
It seems that your simplification doesn't work after all. :)

@Michael, check the diff here: https://code.launchpad.net/~brunonova/software-properties/lp1381050/+merge/238873
Adding that line fixes this bug, I've checked it now.
Do you want to make this change yourself, or shall I do it?