Ubuntu

Some contents not translated

Reported by Timo Jyrinki on 2007-04-05
2
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Undecided
Unassigned

Bug Description

New bug description:
The "Add..." and "Edit..." buttons are not translated in software-properties-gtk. Furthermore, the Add dialog is not translated at all, and Add CD-ROM -dialog has "Scanning CDROM" untranslated.

(old description, ignore:
The "Add..." and "Edit..." buttons are not translated in software-properties-gtk, even when using also the KDE language packs (which currently erronously include the software-properties translation, it is being moved to general language-pack). I'm using the daily langpacks from http://people.ubuntu.com/~pitti/langpacks/daily/feisty/ which do include all the translations that are translatable.

Furthermore, the Add dialog is not translated at all. And Add CD-ROM -dialog has "Scanning CDROM" untranslated.

As the last thing, "Main Server" and "Server for (xxx)" are not translate
)

Sebastian Heinlein (glatzor) wrote :

Fixed in my local branch - rev 520. Was causes by reusing gtk default buttons, which are not marked translatable by default in glade.

main server and server for ... are provided by python-apt. but I will move this functionality back to software-properties after the feisty release.

scannint cdrom should be provided by apt.

cheers,

sebastian

Changed in software-properties:
status: Unconfirmed → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

Thanks for those. Huh, there seems to be endless amount of l10n bugs. The "main server" etc. are not included in any translations at the moment, possibly a bug in python-apt. I reported it as bug 103917 now, since it worked in edgy where the translations came from update-manager.mo.

Scanning CDROM is found in synaptic translation (not apt), I think it is related to this bug still ie. the translation should be fetched from synaptic.mo by software-properties, am I right? ( msgunfmt synaptic.mo | grep -A 2 Scanning ). This also worked in edgy, but there the Scanning CDROM was included in _both_ synaptic.mo and update-manager.mo, now only synaptic.

Also, what I think is related to this bug still is this "Add dialog" (not Add CD-ROM, but the one where you can add an APT-line). The whole translations about "APT-line includes the location"... etc. are seemingly gone at the moment, so they should be added back to some package's pot file, they used to be there in some package at some point of feisty development since I have translated / checked those for feisty too. In edgy, they too were in update-manager's translations.

I will mark this back to "Confirmed" until I know if I should file separate bugs of these two remaining issues that don't have their own bug yet.

Changed in software-properties:
status: Fix Committed → Confirmed
Sebastian Heinlein (glatzor) wrote :

python-apt is now fixed to in my branch.

collecting bugs in a single report only results in confusion.

the missing strings of the add dialog seems to be Rosetta problem.

cdrom dialogs needs some further investigation. the string is part of my software-properties pot file. I was wrong on this.

Timo Jyrinki (timo-jyrinki) wrote :

The missing translations are now easier to check as http://people.ubuntu.com/~pitti/langpacks/daily/feisty/ now include the software-properties.mo in the common language pack as it should be (bug 105280).

Thanks for the finding out how to fix the button issues.

Not sure of if the missing strings of the add dialog is a Rosetta problem, since the translations are included in the software-properties.mo files, just not used. For example:

msgid ""
"<big><b>Enter the complete APT line of the repository that you want to add "
"as source</b></big>\n"
"\n"
"The APT line includes the type, location and components of a repository, for "
"example <i>\"deb http://ftp.debian.org sarge main\"</i>."
msgstr ""
"<big><b>Kirjoita haluamasi ohjelmalähteen koko APT-rivi</b></big>\n"
"\n"
"APT-rivi sisältää kanavan tyypin, sijainnin ja sisällön, esimerkiksi <i>"
"\"deb http://ftp.debian.org sarge main\"</i>."

(/usr/share/locale-langpack/fi/LC_MESSAGES/software-properties.mo)

Changed in software-properties:
status: Confirmed → Fix Committed
Timo Jyrinki (timo-jyrinki) wrote :

Modified description, the remaining three problems in the new description are still there in gutsy.

description: updated
Timo Jyrinki (timo-jyrinki) wrote :

0.60 seems to have fixed these problems, thanks a lot! The actual .pot file is though in queue for gutsy still, but is "Approved" and includes all the correct strings. So it's a matter of time only, Carlos is hoping they'll catch up with the queue this week.

Changed in software-properties:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers