package python3-software-properties (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man1/add-apt-repository.1.gz', which is also in package python-software-properties 0.83

Bug #1021122 reported by crf on 2012-07-05
122
This bug affects 23 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Critical
Colin Watson

Bug Description

quantal.

Errors were encountered while processing:
 /var/cache/apt/archives/python3-software-properties_0.84_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: python3-software-properties (not installed)
ProcVersionSignature: Ubuntu 3.5.0-1.1-generic 3.5.0-rc3
Uname: Linux 3.5.0-1-generic x86_64
ApportVersion: 2.2.5-0ubuntu2
Architecture: amd64
Date: Wed Jul 4 21:01:48 2012
DpkgTerminalLog:
 Unpacking python3-software-properties (from .../python3-software-properties_0.84_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/python3-software-properties_0.84_all.deb (--unpack):
  trying to overwrite '/usr/share/man/man1/add-apt-repository.1.gz', which is also in package python-software-properties 0.83
DuplicateSignature:
 Unpacking python3-software-properties (from .../python3-software-properties_0.84_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/python3-software-properties_0.84_all.deb (--unpack):
  trying to overwrite '/usr/share/man/man1/add-apt-repository.1.gz', which is also in package python-software-properties 0.83
ErrorMessage: trying to overwrite '/usr/share/man/man1/add-apt-repository.1.gz', which is also in package python-software-properties 0.83
SourcePackage: software-properties
Title: package python3-software-properties (not installed) failed to install/upgrade: trying to overwrite '/usr/share/man/man1/add-apt-repository.1.gz', which is also in package python-software-properties 0.83
UpgradeStatus: Upgraded to quantal on 2012-06-18 (16 days ago)

crf (chrisfahlman) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Rainer Rohde (rainer-rohde) wrote :

This happens to me as well, shortly after logging in.

tags: removed: need-duplicate-check
glmm (glmm-deactivatedaccount) wrote :

The following package was automatically installed and is no longer required:
  python-aptdaemon.gtk3widgets
Use 'apt-get autoremove' to remove it.
The following extra packages will be installed:
  python3-software-properties
The following NEW packages will be installed
  python3-software-properties
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
7 not fully installed or removed.
Need to get 0 B/20.3 kB of archives.
After this operation, 128 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
(Reading database ... 96079 files and directories currently installed.)
Unpacking python3-software-properties (from .../python3-software-properties_0.84_all.deb) ...
dpkg: error processing /var/cache/apt/archives/python3-software-properties_0.84_all.deb (--unpack):
 trying to overwrite '/usr/share/man/man1/add-apt-repository.1.gz', which is also in package python-software-properties 0.83
Processing triggers for man-db ...
Errors were encountered while processing:
 /var/cache/apt/archives/python3-software-properties_0.84_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

dino99 (9d9) wrote :

All software-properties 0.83 packages & their dependencies like python-software-properties needs to be manually purged first. Then new 0.84 can be installed smootly.

glmm (glmm-deactivatedaccount) wrote :

dino99 you're right, thanks

dino99 (9d9) on 2012-07-05
tags: added: i386
Colin Watson (cjwatson) on 2012-07-05
Changed in software-properties (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-properties - 0.85

---------------
software-properties (0.85) quantal; urgency=low

  * Ship add-apt-repository and its manual page only in
    software-properties-common, rather than having bits of it in
    python3-software-properties as well (LP: #1021122).
 -- Colin Watson <email address hidden> Thu, 05 Jul 2012 12:46:35 +0100

Changed in software-properties (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers