Crash in ui/gtk3/panes/historypane.py: "GError: Failed to load icon"

Bug #987321 reported by Matthew Paul Thomas on 2012-04-23
48
This bug affects 5 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Michael Vogt
Precise
Undecided
Unassigned

Bug Description

SRU TEST CASE:
This crash only occurs in certain configurations and so may not be directly reproducable. It is enough to verify that the updated version always works correctly.
1. Update to the version of software-center in precise-proposed.
2. Launch Ubuntu Software Center from the command line as shown:

    $ software-center

3. Click on the "History" toolbar button.
4. Verify that the history view is displayed correctly and that the crash shown below does not occur.

SRU REGRESSION POTENTIAL:
Regression risk is negligible. Fix just tightens a dependency on the needed icon theme.

---

Traceback (most recent call last):
  File "/usr/bin/software-center", line 142, in <module>
    app = SoftwareCenterAppGtk3(datadir, xapian_base_path, options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 305, in __init__
    self.datadir)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 78, in __init__
    self._get_emblems(self.icons)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py", line 192, in _get_emblems
    pb = icons.load_icon(emblem, self.ICON_SIZE, 0)
  File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in function
    return info.invoke(*args, **kwargs)
GError: Failed to load icon

Full crash data: http://paste.ubuntu.com/942544/

At 2012-04-23, this is the 6th most common crash in Ubuntu overall.

Related branches

Changed in software-center (Ubuntu):
importance: Undecided → High
Michael Vogt (mvo) on 2012-04-23
tags: added: ca-escalated
Changed in software-center (Ubuntu):
status: New → Confirmed
milestone: none → precise-updates
Michael Vogt (mvo) wrote :

The attached branch fixes it in one way. There are more ways we can do it.

Another one would be to include the needed icons into: "data/emblems/" and ship them as part of s-c. This requires
that we have the icons with the right copyright (i.e. with copyright assignment). If we can use the ones from the humanity-icon-theme I can add them and would actually prefer this approach.

Michael Vogt (mvo) on 2012-05-21
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michael Vogt (mvo)
tags: removed: ca-escalated

Hi,

i re-downloaded the latest distro and everything worked fine I had some had
sectors on my HDD(i replaced it)i can't tell if it has a relation with the
bug I have been experiencing

thanks and regards
alaa
On May 21, 2012 5:35 PM, "Michael Vogt" <email address hidden> wrote:

> ** Changed in: software-center (Ubuntu)
> Status: Confirmed => In Progress
>
> ** Changed in: software-center (Ubuntu)
> Assignee: (unassigned) => Michael Vogt (mvo)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (974088).
> https://bugs.launchpad.net/bugs/987321
>
> Title:
> Crash in ui/gtk3/panes/historypane.py: "GError: Failed to load icon"
>
> Status in “software-center” package in Ubuntu:
> In Progress
>
> Bug description:
> Traceback (most recent call last):
> File "/usr/bin/software-center", line 142, in <module>
> app = SoftwareCenterAppGtk3(datadir, xapian_base_path, options, args)
> File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line
> 305, in __init__
> self.datadir)
> File
> "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py",
> line 78, in __init__
> self._get_emblems(self.icons)
> File
> "/usr/share/software-center/softwarecenter/ui/gtk3/panes/historypane.py",
> line 192, in _get_emblems
> pb = icons.load_icon(emblem, self.ICON_SIZE, 0)
> File "/usr/lib/python2.7/dist-packages/gi/types.py", line 43, in
> function
> return info.invoke(*args, **kwargs)
> GError: Failed to load icon
>
> Full crash data: http://paste.ubuntu.com/942544/
>
> At 2012-04-23, this is the 6th most common crash in Ubuntu overall.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/987321/+subscriptions
>

description: updated

Hello Matthew, or anyone else affected,

Accepted software-center into precise-proposed. The package will build now and be available in a few hours. Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users. If this package fixes the bug for you please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case details of your testing will help us make a better decision. Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in software-center (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Gary Lasker (gary-lasker) wrote :

I have verified that software-center version 5.2.3 in precise-proposed fixes this bug per the test case given in the description.

Thanks!

tags: added: verification-done
removed: verification-needed
Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2.3

---------------
software-center (5.2.3) precise-proposed; urgency=low

  [ Robert Roth ]
  * lp:~evfool/software-center/lp987801:
    - Only show the version label once for each version in
      reviews (LP: #987801)
  * lp:~evfool/software-center/lp874430:
    - display tooltips for package titles in the application
      tiles of the lobby view (LP: #874430)
  * lp:~evfool/software-center/lp983831:
    - Avoid merging two words while normalizing description (LP: #983831)
  * lp:~evfool/software-center/lp822625:
    - Set default value for reviewstats histogram (LP: #822625)
  * lp:~evfool/software-center/lp875874:
    - Set word wrap with fallback to char wrapping for the review
      text label (LP: #875874)

  [ Gabor Kelemen ]
  * lp:~kelemeng/software-center/bug1001746:
    - merge i18n fix (LP: #1001746)

  [ Michael Vogt ]
  * lp:~mvo/software-center/lp872760-for-5.2:
    - fix translations for certain category names (LP: #872760)
  * lp:~mvo/software-center/lp987321:
    - fix dependency to ensure that we have humanity-icon-theme
      as we need it for the history view icons (LP: #987321)
  * lp:~mvo/software-center/test-catview-cleanup:
    - refactor unit tests for the catview
  * lp:~mvo/software-center/lp1002271:
    - fix regresion in 5.2.2 (LP: #1002271) for empty descriptions
  * lp:~mvo/software-center/lp1005104:
    - fix regression in 5.2.2 (LP: #1005104) in initial navigation
      history
  * lp:~mvo/software-center/client-lp1004417:
    - client side fix for when exhibit package names contain
      extra whitespace (LP: #1004417)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/fix-crash-lp1000238:
    - remove obsolete workaround for an old bug that has long since
      been fixed, this fixes a hard crash on Quantal (LP: #1000238)
  * lp:~gary-lasker/software-center/toolbar-buttons-insensitive-during-startup:
    - re-enable the fix for LP: #999486, LP: #994341 that was inadvertently
      disabled in the 5.2.2 release

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/fix-977931:
    - Unified package string parsing into a single method that will be
      used from either the command line arguments, or from the dbus method
      'bringToFront'. This way, search will be consistent between all
      entry points. LP: #977931
    - Also added proper test suites for the above.
  * lp:~nataliabidart/software-center/fix-965093:
    - Fixed the SpinnerNtebook show_spinner method so the spinner page is
      not shown until the configured threshold is reached (250ms since
      this branch). Plus proper test suite was added.
  * lp:~nataliabidart/software-center/fix-986563:
    - Filtered out those exhibits that do not their packages available
      in the db (LP: #986563)
 -- Michael Vogt <email address hidden> Mon, 04 Jun 2012 08:53:25 +0200

Changed in software-center (Ubuntu Precise):
status: Fix Committed → Fix Released
Darko (reloader) wrote :

How can I fix it in my elementaryOS system? I've tried updating from precise-proposed, but I get the 'Release 'precise-proposed' for 'software-center' was not found.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers