Software Center does not give the option of visualizing reviews in my locale (Spanish)

Bug #979013 reported by Nicolás Abel Carbone on 2012-04-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Michael Vogt

Bug Description

I am using Ubuntu 12.04 amd64 in Spanish.

When opening the Software Center, and going to the more information page of some app, it only gives me the option to see reviews in English (it says Ingles) and in other languages (Cualquier idioma).

On top of that, when I first enter the more information page, the reviews showed are in Spanish, even if the language option is set to "Ingles". If I choose "Cualquier idioma", only a few reviews are showed, sometimes in other languages than English or Spanish, sometimes some in Spanish or some in English, but never ALL the reviews. When, after this, I choose "Ingles" again, a lot of reviews are shown, all in English.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.14.2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu1
Architecture: amd64
Date: Wed Apr 11 12:18:50 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can reproduce this when running.
$ LANGUAGE=es_MX:es_ES:es_AR:es_ES:en ./software-center gparted
(from your ProcEnviron.txt)

It appears to be fine when using: LANGUAGE=es

I think the issue here is that its actually displaying "spanish" reviews and not "english" reviews and just
got confused about this.

Michael Vogt (mvo) wrote :

Looking at this it appears that the problem is that LANGUAGE contains the es_{MX,AR,ES} but no "es" as the generic fallback. The fallback that is then used is english causing the confusion.

I pushed a branch with a fix, but I wonder what application set LANGUAGE in your case as it should probably also be fixed.

Changed in software-center (Ubuntu):
status: New → In Progress
importance: Undecided → Low
Michael Vogt (mvo) wrote :

The issue is that by default the UI is using get_languages() but the backend is using get_langage() so this causes the inconsistent views.

Changed in software-center (Ubuntu):
assignee: nobody → Michael Vogt (mvo)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.2

---------------
software-center (5.2) precise; urgency=low

  [ Michael Vogt ]
  * debian/control:
    - recommend xz-lmza instead of lzma (LP: #878354)
  * lp:~mvo/software-center/track-axi-changes:
    - add a monitor for changes in the apt-xapian-index to ensure
      the DB is reopened if the cron job changes the apt-xapian-index
      database (LP: #507836)
  * lp:~mvo/software-center/lp970342:
    - do not crash if the parent goes away (and therefore the pipe)
      and the token can not be obtained (LP: #970342)
  * lp:~mvo/software-center/lp967036:
    - fix UnicodeDecodeError crash for apps with hardware
      requirements in the details view (LP: #967036)
  * lp:~mvo/software-center/list-a11y:
    - restore the a11y support for orca/accerciser/ldtp for
      the listview and treeview
  * lp:~mvo/software-center/lp979013:
    - fix a bug in the review display for certain language
      environments (LP: #979013)
  * lp:~mvo/software-center/appview-tweaks:
    - code cleanup in the sortmode code
  * lp:~mvo/software-center/lp772549:
    - fix a bug that can result in a blank software center
      screen on startup (LP: #772549)
  * lp:~mvo/software-center/lp914393:
    - adds an explicit sys.exit() to ensure all gtk event
      processing is stopped on application quit (LP: #914393)
  * lp:~mvo/software-center/lp976169:
    - do not crash if apt-xapian-index is not installed
      (LP: #976337)
    - ignore xapian.DatabaseOpeningError here (happens when
      there is no a-x-i so we don't care) (LP: #976169)
  * lp:~mvo/software-center/lp976525:
    - do not show "upgradable" button when there should be "remove"
      (LP: #976525)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/sorting-fix-lp969215:
    - fix sort combo box inconsistencies (LP: #969215)

  [ Dave Morley ]
  * lp:~davmor2/software-center/remove_two_lines:
    - small fixes for test script USC-start-stop-times.py

  [ Kiwinote ]
  * sc/ui/gtk3/widgets/apptreeview.py:
    - everyone tries to expand a category in the installed pane by clicking
      on the text rather than the expander arrow (LP: #877130)
 -- Michael Vogt <email address hidden> Fri, 13 Apr 2012 18:35:13 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers