"Show N technical items" doesn't look clickable

Bug #955030 reported by Alan Pope 🍺🐧🐱 🦄 on 2012-03-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Gary Lasker

Bug Description

The "Show 72 technical items" at the bottom of the screen looks like a status bar, and not a button. It was only when a designer was looking over my shoulder and pointed out that it's clickable that I then clicked it.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: software-center 5.1.12
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Wed Mar 14 13:26:51 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120203)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Kiwinote (kiwinote) wrote :

it is indeed pretty common that people don't realise they can click on this - making it orange and underlining it will probably go quite a while although in the future i wouldn't mind getting rid of the technical/non-technical altogether

Changed in software-center (Ubuntu):
importance: Undecided → High
status: New → Triaged
Michael Vogt (mvo) wrote :

This one is pretty confusing, e.g.
$ PYTHONPATH=. python softwarecenter/ui/gtk3/widgets/actionbar.py
and "set label" has the right label, there is a "<u>foo</u>" property at the right part of the label. And yet
its not displayed. Chaning it to '<span fgcolor="blue">%s</span>" works as expected.

Changed in software-center (Ubuntu):
milestone: none → ubuntu-12.04
Michael Vogt (mvo) wrote :

Running the same command PYTHONPATH=. python softwarecenter/ui/gtk3/widgets/actionbar.py"" under 11.10 shows a valid underline.

Michael Vogt (mvo) wrote :

Here is a small example how to reproduce this.

Michael Vogt (mvo) wrote :

While we are at it, we should use the '<a href="">text</a>" markup from Gtk.Label() in the actionbar code and remove the custom code that implements the same behavior (it was written when GtkLabel did not have this capability yet).

Changed in freetype (Debian):
status: Unknown → New
Changed in software-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Gary Lasker (gary-lasker)
summary: - "Show N technical items" doesnt look clickable
+ "Show N technical items" doesn't look clickable
Sebastien Bacher (seb128) wrote :

Not wanting to hijack that bug with the gtk (which turned to be a freetype) issue I opened bug #972223

affects: freetype (Debian) → software-center (Debian)
Changed in software-center (Debian):
importance: Unknown → Undecided
affects: software-center (Debian) → software-center
Gary Lasker (gary-lasker) wrote :

Thanks a lot, Seb! I see it is already fixed now in Precise (thanks kiwinote for pointing that out). :)

Kiwinote (kiwinote) on 2012-04-04
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
no longer affects: software-center
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.14.2

---------------
software-center (5.1.14.2) precise; urgency=low

  [ Michael Vogt ]
  * lp:~mvo/software-center/config-tweak:
    - cleanup concerning always having a 'general' section in the cfg file
  * lp:~mvo/software-center/pygi-properties-fixes:
    - properly initialize the properties in CellRendererAppView as required
      for pygi, fixes crash on network events (LP: #965937)
  * lp:~mvo/software-center/lp977889:
    - fix the disappearing list view sort combobox (LP: #977889)

  [ Gary Lasker ]
  * lp:~gary-lasker/software-center/recommends-more-button-lp971567:
    - correctly render 'more' button in recommendations panel (LP: #971567)
  * lp:~gary-lasker/software-center/show-technical-items-lp955030:
    - make 'show n technical items' appear clickable again (LP: #955030)
  * lp:~gary-lasker/software-center/fix-crash-lp969737:
    - fix an intermittent crash that can occur when saving the vertical
      position of the installed pane treeview on a cache refresh
      (LP: #969737)
  * lp:~gary-lasker/software-center/fix-crash-lp970157:
    - Small fix for a crash that can happen during the installed view
      treeview initialization (LP: #970157)
  * lp:~gary-lasker/software-center/fix-crash-lp968988:
    - Fix crash bug LP: #968988 by making sure that there is always
      a tree_view.selected_row_renderer
  * lp:~gary-lasker/software-center/remember-sort-preference-lp966878:
    - Fix for bug LP: #966878 to not reset the user's sorting preference
      if they have set one

  [ Nekhelesh Ramananthan ]
  * lp:~nik90/software-center/add_keywords_new:
    - added keywords to the desktop file for better search criteria
      (LP: #977175)

  [ Sebastian Heinlein ]
  * lp:~glatzor/software-center/fix-977020:
    - fix software-center error dialogs for errors other than
      ERROR_INVALID_PACKAGE_FILE and ERROR_UNAUTHENTICATED_PACKAGE
      (LP: #977020)
    - Allow to repair an incomplete installation (partially fixes
      LP: #659438)

  [ Kiwinote ]
  * lp:~kiwinote/software-center/lp951557:
    - don't duplicate text on paste (LP: #951557)
 -- Michael Vogt <email address hidden> Tue, 10 Apr 2012 19:21:21 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Pavlo Verba (pavlo.s.verba) wrote :

Was this fix made into an update yet? I am asking because it is November 2012 and I am still affected by this bug.

Matthew Paul Thomas (mpt) wrote :

Paul, yes, Ubuntu 12.04 was released with USC 5.2, which includes this fix. If you are using USC 5.1.14.2 or later and the link doesn't look underlined for you, please report a separate bug. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.