No search capability in Ubuntu software center app

Bug #897387 reported by keepitsimpleengr
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

No search box displayed.

Menu item Search in Edit menu does nothing.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: software-center 5.0.2ubuntu0.1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Mon Nov 28 12:08:31 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
PackageArchitecture: all
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
keepitsimpleengr (keepitsimpleengineer) wrote :
Revision history for this message
keepitsimpleengr (keepitsimpleengineer) wrote :
Revision history for this message
keepitsimpleengr (keepitsimpleengineer) wrote :

This is a show-stopper. Do I need to dump this install and redo (again)?

What if I do that and the error reoccurs?

Revision history for this message
Kiwinote (kiwinote) wrote :

Just a guess: you may find that the search box reappears if you make the window bigger either by maximising it or dragging the right window border slightly to the right.

Revision history for this message
Gary Lasker (gary-lasker) wrote :

Hi keepitsimpleengineer, thanks for your report. This seems a strange one and and I agree it's a serious problem not being able to access Software Center's search capability. Unfortunately, I can't seem to reproduce this myself. However, if you could provide some additional info, it should help us to debug this issue.

First, before you do anything else, could you please attach the following file to this report?

  ~/.config/software-center/softwarecenter.cfg

After that, could you please launch software-center from the command line and attach any output that you get to this bug?

  $ software-center

Finally, in the screenshot your Software Center window seems unusually narrow. Could you please maximize the window (or just make it wider), and let me know if the search bar appears? If it does not, please quit Software Center while it is maximized and restart. Does the search bar appear now?

Thanks very much for your help, it's much appreciated!
Gary

Revision history for this message
keepitsimpleengr (keepitsimpleengineer) wrote :
Revision history for this message
keepitsimpleengr (keepitsimpleengineer) wrote :

$ software-center
2011-11-30 16:25:45,825 - softwarecenter.ui.gtk3.em - INFO - EM's: 17 15 21
2011-11-30 16:25:51,071 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2011-11-30 16:25:51,681 - softwarecenter.ui.gtk3.utils - INFO - Softwarecenter style provider for ambiance Gtk theme: /usr/share/software-center/ui/gtk3/css/softwarecenter.css
2011-11-30 16:26:09,213 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0

It's back...?

Also now when launched from the totem icon. And the Edit/Search menu command moves the focus to the search text box.

Revision history for this message
keepitsimpleengr (keepitsimpleengineer) wrote :

here are the last few lines of /var/log/dpkg.log:
2011-11-20 18:09:35 status unpacked libxss1 1:1.2.1-2
2011-11-20 18:09:35 status half-configured libxss1 1:1.2.1-2
2011-11-20 18:09:35 status installed libxss1 1:1.2.1-2
2011-11-20 18:09:35 status triggers-pending libc-bin 2.13-20ubuntu5
2011-11-20 18:09:36 configure skype 2.2.0.35-0oneiric2 <none>
2011-11-20 18:09:36 status unpacked skype 2.2.0.35-0oneiric2
2011-11-20 18:09:36 status unpacked skype 2.2.0.35-0oneiric2
2011-11-20 18:09:36 status half-configured skype 2.2.0.35-0oneiric2
2011-11-20 18:09:36 status installed skype 2.2.0.35-0oneiric2
2011-11-20 18:09:36 trigproc libc-bin 2.13-20ubuntu5 <none>
2011-11-20 18:09:36 status half-configured libc-bin 2.13-20ubuntu5
2011-11-20 18:09:36 status installed libc-bin 2.13-20ubuntu5

Revision history for this message
Gary Lasker (gary-lasker) wrote :

Hi again keepitsimpleengr, thanks for getting back with the info! Ok, it seems that once the window was resized the search bar has reappeared. I'm not quite sure how the window would have gotten to that small size as it is constrained to always be large enough to show the search bar widget.

In any case, I will close this bug based on your comment #7 and your screenshot. Please be sure to reopen if this problem appears again, and please report any other issues or problems you may encounter as you use Software Center. Your help is very much appreciated!

Best regards,
Gary

Changed in software-center (Ubuntu):
status: New → Invalid
sokolov (daniel-sokolov)
Changed in software-center (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
sokolov (daniel-sokolov) wrote :

ON my freshly installed 12.04 Beta 2 the same issue is present - no search box in the software center. Running the software-center from the command line did not change anything.

I don't think it is a mere graphical problem: Choosing "search" from the menu or hitting Ctrl+F do not appear to have any effect.

Revision history for this message
sokolov (daniel-sokolov) wrote :

I think it is Unity related. After upgrading my Ubuntu 12.04 from Unity to Gnome 3, the search box is back.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

sokolov, as shown in the screenshots, this bug was fixed -- it was probably a duplicate of bug 876653. If you are experiencing a similar problem in 12.04, please report a separate bug with screenshots and steps to reproduce it. Thanks.

Changed in software-center (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers