Position in app list not remembered when navigating back from More Info screen

Bug #852763 reported by Jay Ó Broin on 2011-09-17
86
This bug affects 22 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Kiwinote

Bug Description

software-center 4.1.23.2, Ubuntu 11.10 beta

1. From the home screen, search for "photo".
2. Scroll through the list of apps, click on one, and press More Info, then press the back button.

What you expected to happen: Be returned to the same position in the list I was at before.
What happened instead: I was returned to the top of the list.

<https://wiki.ubuntu.com/SoftwareCenter#navigation-back-forward>: "Each item in the history should remember its scroll position ... These attributes should persist if you return to the screen using Back/Forward navigation, but not if you navigate to the screen any other way."

See also bug 828887, about the "Installed" screen.

Related branches

Jay Ó Broin (ismise) wrote :
description: updated
Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
description: updated
Ricardo Graça (devius) wrote :

I believe that bug #828913 has a broader description of the problem, and so this should be marked as duplicate of that bug. In that bug report all forward/back actions are reported to exhibit this behaviour.

Kiwinote (kiwinote) on 2012-02-16
Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
importance: Medium → High
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.1.10

---------------
software-center (5.1.10) precise; urgency=low

  [ Michael Vogt ]
  * revert again:
    lp:~gary-lasker/software-center/temp-disable-lobby-recommendations-view
  * lp:~mvo/software-center/lp917096:
    - fix crash when opening a debfile and add regression test
      (LP: #917096)
  * softwarecenter/region.py:
    - trivial change to make region tag prefix "iso3166::" to align
      with the latest debtags upstream plans

  [ Kiwinote ]
  * softwarecenter/ui/gtk3/app.py:
    - disable navigating back by pressing the backspace key because it has
      started showing dodgy side effects - use ctrl+[ or alt+LEFT instead
  * remember the scroll position when navigating back to a list view,
    this only works in the available pane (LP: #852763)
  * correctly theme the channel selector menus (LP: #921477)
  * trigger pot file rebuild

  [ Barneedhar (jokerdino) ]
  * softwarecenter/hw.py:
    - fix broken string (LP: #936403)

  [ Stéphane Graber ]
  * utils/piston-helpers/x2go_helper.py: Fix weblive helper to work with
    Precise's python-x2go.
 -- Michael Vogt <email address hidden> Thu, 23 Feb 2012 16:58:30 +0100

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers