software-center crashed with UnicodeDecodeError in __str__(): 'ascii' codec can't decode byte 0xc8 in position 2: ordinal not in range(128)

Bug #847050 reported by George Silviu Enea on 2011-09-11
126
This bug affects 17 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker
Oneiric
Medium
Gary Lasker

Bug Description

trying to install from Mozilla Firefox through apt, example: apt:love

Test case for Oneiric SRU:
1. Launch software-center using a local that requires unicode (e.g. French).
2. Type "love" into the search bar and navigate to the details view for the LÖVE package.
3. Verify this crash does not occur.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.22
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
Date: Sun Sep 11 17:18:39 2011
ExecutablePath: /usr/share/software-center/software-center
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center apt:love
PythonArgs: ['/usr/bin/software-center', 'apt:love']
SourcePackage: software-center
Title: software-center crashed with UnicodeDecodeError in __str__(): 'ascii' codec can't decode byte 0xc8 in position 2: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: removed: need-duplicate-check
visibility: private → public
Robert Roth (evfool) wrote :

Thank you for taking the time to report this bug. I can not reproduce this using software-center 4.1.22, opening software-center with apt:love works, the only problem is that in the description LOVE is displayed as L?VE. Can you still reproduce this issue, does software-center still crash for you when opening with apt-love?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in software-center (Ubuntu):
status: New → Incomplete

Using apt: from a browser will make Software Center to freeze, or randomly crash... last time I checked, freezed Software Center...

Changed in software-center (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Changed in software-center (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Please upload all these fixes from the proposed SRU to precise first. Thanks!

Changed in software-center (Ubuntu Oneiric):
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released

Hello George, or anyone else affected,

Accepted software-center into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Michal Predotka (mpredotka) wrote :

Thanks Martin.
I've been told to follow this bug but my problem was slightly different. When I clicked the big banner with an app, nothing happened. After this update, clicking the banner brings me to the app description. For me it is fixed.

Gary Lasker (gary-lasker) wrote :

Thanks for your comment, mmiicc! That's a possible effect of this bug actually, so it sounds like this update has fixed it for you.

description: updated
Gary Lasker (gary-lasker) wrote :

I have verified using the French locale that version 5.0.3.1 of software-center in oneiric-proposed fixes this issue for me. Thanks!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 5.0.3.1

---------------
software-center (5.0.3.1) oneiric-proposed; urgency=low

  * softwarecenter/ui/gtk3/views/purchaseview.py:
    - set transient parent when creating a new webview to better
      support PayPal (LP: #893988)

software-center (5.0.3) oneiric-proposed; urgency=low

  [ Michael Vogt ]
  * Improve icon extenstion detection, some iconnames are already
    without extenstion with still with a "." in the name, some are not.
    This fixes the icons display for wesnoth and xpuzzles (LP: #878707)

  [ Gary Lasker ]
  * softwarecenter/ui/gtk3/app.py:
    - fix potential dbus crash when accessing the list of previous
      purchases (LP: #863898)
  * softwarecenter/ui/gtk3/session/navhistory.py:
    - fix UnicodeDecodeError in NavigationItem __str__ (LP: #847050)
  * softwarecenter/ui/gtk3/panes/softwarepane.py:
    - fix UnicodeDecodeError in DisplayState __str__ (LP: #873046)
  * softwarecenter/ui/gtk3/models/pendingstore.py:
    - fix UnicodeDecodeError in _render_status_text (LP: #862029)
  * softwarecenter/distro/__init__.py:
    - fix UnicodeDecodeError in get_install_warning_text (LP: #857416)
  * softwarecenter/db/application.py:
    - fix UnicodeDecodeError in __str__ (LP: #871088)

  [ Gabor Kelemen ]
  * Fix misplaced parentheses and localize the app name
    using the app-install-data-ubuntu domain. LP: #880257
  * Display the success message properly localized. LP: #872823
  * Display failure message properly localized. LP: #872812
 -- Michael Vogt <email address hidden> Thu, 24 Nov 2011 10:10:25 +0100

Changed in software-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Extender (msveshnikov) wrote :

Bug is reappeared again in Ubuntu Quantal Beta 1

Extender (msveshnikov) wrote :

Software Center stop opening after first open of suggested app in non-English locale

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers