software-center-gtk3 crashed with AttributeError in copy(): 'NoneType' object has no attribute 'copy'

Bug #834196 reported by Aslam Muhammad on 2011-08-25
644
This bug affects 135 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Kiwinote

Bug Description

software center crashed while switching between installation and update in history tab of new software-center
and when trying to install a .deb package esp. vbox 4

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: software-center 4.1.20
ProcVersionSignature: Ubuntu 3.0.0-9.14-generic 3.0.3
Uname: Linux 3.0.0-9-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Fri Aug 26 01:43:09 2011
ExecutablePath: /usr/share/software-center/software-center-gtk3
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110806)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center-gtk3
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_IN.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/bin/software-center-gtk3']
SourcePackage: software-center
Title: software-center-gtk3 crashed with AttributeError in copy(): 'NoneType' object has no attribute 'copy'
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Aslam Muhammad (aslamckra) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Kiwinote (kiwinote) wrote :

Hi! Thanks for your bug report. The bug you describe has been fixed in the branch I have linked and should be available in the next release. Please continue to report any bugs you may find in software-center. Thanks again for your help!

visibility: private → public
Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
importance: Undecided → High
status: Confirmed → Fix Committed
tags: removed: bugpattern-needed
Markcortbass (markcortbass) wrote :

Bug at Software center.
software center crashed while switching between 'every software' and 'progress' button.

Petr Hlozek (ok2cqr) wrote :

Software center crashed after I clicked to Installed icon.

H-w25-c25 (h-w25-c25) wrote :

I fixed the problem just now
sudo emacs /usr/share/software-center/softwarecenter/ui/gtk3/panes/softwarepane.py
line 145
add
if self.filter != None:
state.filter = self.filter.copy()
else:
state.filter = None

I added the lines after line 145, but then Software Center didn't start.

Where exactly shall I enter the code?

def copy(self):
         state = DisplayState()
         state.channel = self.channel
         state.category = self.category
         state.subcategory = self.subcategory
         state.search_term = self.search_term
         state.application = self.application
         state.limit = self.limit
         state.filter = self.filter.copy()
         return state

     def reset(self):

On 08/27/2011 10:35 AM, H-w25-c25 wrote:
> sudo emacs /usr/share/software-center/softwarecenter/ui/gtk3/panes/softwarepane.py

Aaron Peachey (aaronp) wrote :

Hi,
If you don't know how to write python code, it's probably best not to try modifying the code, as you will need to get the indents correct etc.
The issue has been fixed and will be available in the next software-center update, so my strong advice is to wait for that.

However if you are intent on fixing it before then, it's best to get the entire updated softwarepane.py file from here:
http://bazaar.launchpad.net/~kiwinote/software-center/tweaks/download/kiwinote%40gmail.com-20110826110015-fobea07so04vh5kv/softwarepane.py-20110705095105-hkqkaog02375crmg-28/softwarepane.py

Then copy it into your current installation (i.e. /usr/share/software-center/softwarecenter/ui/gtk3/panes/) using sudo. (I would make a backup copy of your existing softwarepane.py file first)
Note, this could break your installation temporarily and may also have other unintended effects so attempt it at your own risk.

cheers
Aaron

Per-Inge (per-inge-hallin) wrote :

To copy worked fine.

Thanks/Per-Inge

On 08/27/2011 12:29 PM, Aaron Peachey wrote:
> Hi,
> If you don't know how to write python code, it's probably best not to try modifying the code, as you will need to get the indents correct etc.
> The issue has been fixed and will be available in the next software-center update, so my strong advice is to wait for that.
>
> However if you are intent on fixing it before then, it's best to get the entire updated softwarepane.py file from here:
> http://bazaar.launchpad.net/~kiwinote/software-center/tweaks/download/kiwinote%40gmail.com-20110826110015-fobea07so04vh5kv/softwarepane.py-20110705095105-hkqkaog02375crmg-28/softwarepane.py
>
> Then copy it into your current installation (i.e. /usr/share/software-center/softwarecenter/ui/gtk3/panes/) using sudo. (I would make a backup copy of your existing softwarepane.py file first)
> Note, this could break your installation temporarily and may also have other unintended effects so attempt it at your own risk.
>
> cheers
> Aaron
>

Ahmad Zain (am-zain) on 2011-08-27
description: updated
crtm (carlosrtm) wrote :

software center crashed

iGadget (igadget) wrote :

It crashes on my system when switching to the 'progress' section while installing any package.

Hugo Venhorst (yougo) wrote :

i downloaded a .deb with firefox and tried to open it with Software Center (automatically). SC crashed before opening a window

Gary Lasker (gary-lasker) wrote :

Thanks very much for your fix, kiwinote! Your branch is merged to trunk now and this fix will be available soon in the next development release of Software Center.

macice (neall-mclaren) wrote :

Crashed for me while switching from "all Software" to "installed" tab in Software Centre - running 11.10 beta 30/08 (64 bit) under virtualbox 4.1.2 (Windows Host)

tags: added: iso-testing
Kenny Strawn (realkstrawn93) wrote :

Seems that the fix didn't work in my case; various movements between UI elements of the Software Center seems to cause this crash.

Changed in software-center (Ubuntu):
status: Fix Committed → Confirmed
Matthew Paul Thomas (mpt) wrote :

No version of USC containing the fix has been released yet. Please don't comment that the bug is still occurring, unless you are using a version of trunk later than when the branch was merged. Thanks.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Committed
tags: added: bugpattern-needed
Gary Lasker (gary-lasker) wrote :

Requesting a bugpattern as beta-1 will include this bug (the fix will be released immediately after beta freeze ends).

Richie Ward (richies) wrote :

Crashed after I pressed the X to exit the program.

Ydjluv-u (ydjluv-u) wrote :

Crashed while installing a deb package but it kept running and installed the package.. seems as if you guys are aware of the issue..

Pedro Villavicencio (pedro) wrote :

Bug pattern is already in place, removing the tag, thanks!.

tags: removed: bugpattern-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.21

---------------
software-center (4.1.21) oneiric; urgency=low

  [ Kiwinote ]
  * AUTHORS:
    - add credits for the new icon (LP: #834882)
  * a stash of unicode fixes to make s-c-gtk3 usable around the world
    (LP: #831865, LP: #834409, LP: #834312)
  * softwarecenter/db/update.py:
    - fix reinstall previous purchases (LP: #834984)
  * softwarecenter/ui/gtk3/panes/availablepane.py:
    - set title for 'previous purchases' list view (LP: #833960)
  * softwarecenter/ui/gtk3/panes/softwarepane.py:
    - fix None.copy() such that switching panes works again (LP: #834196)
  * softwarecenter/ui/gtk3/widgets/buttons.py:
    - escape application name in tiles (LP: #835876)

  [ Jacob Johan Edwards ]
  * softwarecenter/ui/gtk3/panes/softwarepane.py:
    - fix the spinner display when loading slow views (LP: #830682)

  [ Gabor Kelemen ]
  * po/POTFILES.in,
    po/POTFILES.skip:
    - update per latest configuration, add new gtk3 files

  [ Matthew McGowan ]
  * softwarecenter/ui/gtk3/widgets/buttons.py :
    - resize fix for Top Rated and What's New tiles (LP: #833697)
  * softwarecenter/ui/gtk3/views/catview_gtk.py,
    softwarecenter/ui/gtk3/widgets/containers.py:
    - disable the rendering of the checkboard pattern in the
      grid views (at request of mpt)
   * lp:~mmcg069/software-center/description-tweaks:
     - fix badly rendered package descriptions, other tweaks
       (LP: #833954)
   * lp:~mmcg069/software-center/globalpane-themeability:
     - various theming fixes (LP: #828092, LP: #830681,
       LP: #830738 and LP: #838382)

  [ Gary Lasker ]
  * software-center,
    software-center-gtk3,
    softwarecenter/db/update.py:
    - enable CJK support in Xapian (LP: #745243)
  * po/software-center.pot:
    - refresh .pot file
  * softwarecenter/ui/gtk/widgets/thumbnail.py:
    - fix missing icon in theme to let non-gtk3 version
      launch again, also fixes all gtk unit tests
  * test/test_database.py:
    - update unit test

  [ Didier Roche ]
  * softwarecenter/ui/gtk3/panes/installedpane.py,
    softwarecenter/ui/gtk3/views/appview.py,
    softwarecenter/ui/gtk3/widgets/menubutton.py,
    softwarecenter/ui/gtk3/widgets/oneconfviews.py,
    softwarecenter/db/appfilter.py,
    softwarecenter/ui/gtk3/app.py,
    data/ui/gtk3/SoftwareCenter.ui:
    - brings back OneConf to software center gtk3 with a fresh new design
      (LP: #838623)
  * debian/control:
    - depends on latest oneconf
 -- Gary Lasker <email address hidden> Thu, 01 Sep 2011 11:55:14 -0400

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Rich Evans (o0rebelious0o) wrote :

This bug is definitely not fixed. I've upgraded to the latest beta release with the new package and whenever switching to the "progress" screen while software installs are running, this crash is occuring

Gary Lasker (gary-lasker) wrote :

Hi Richard, this fix actually was released after beta-1, and so is to be available as an update. Please look for the fix in Software Center version 4.1.21, which was uploaded just a couple of hours ago and so may not be available in the archives yet. Please give it a couple of hours and then check for it with update-manager.

Thanks!

It also crashes when you try to update sources to install VLC on the live disk.

Samuel Marks (samuelmarks) wrote :

Crashes 11.10 Beta when installing various .deb in a row (mplayer dependencies). Downloaded .deb in Firefox, running them 1 at a time in Software Centre.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers