update-apt-xapian-index crashed with ValueError in index(): invalid null reference in method 'Document_add_value', argument 3 of type 'std::string const &'

Bug #810552 reported by userdce on 2011-07-14
422
This bug affects 34 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Zeeshan Malik
Oneiric
High
Kiwinote

Bug Description

apt-xapian-index

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: apt-xapian-index 0.43ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Thu Jul 14 00:08:43 2011
ExecutablePath: /usr/sbin/update-apt-xapian-index
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/sbin/update-apt-xapian-index --batch-mode --force
ProcEnviron:

PythonArgs: ['/usr/sbin/update-apt-xapian-index', '--batch-mode', '--force']
SourcePackage: apt-xapian-index
Title: update-apt-xapian-index crashed with ValueError in index(): invalid null reference in method 'Document_add_value', argument 3 of type 'std::string const &'
UpgradeStatus: Upgraded to oneiric on 2011-07-12 (1 days ago)
UserGroups:

userdce (userdce) wrote :
tags: removed: need-duplicate-check
Steve Beattie (sbeattie) on 2011-07-15
visibility: private → public
Changed in apt-xapian-index (Ubuntu Oneiric):
importance: Undecided → Medium
Changed in apt-xapian-index (Ubuntu):
status: New → Confirmed
Changed in apt-xapian-index (Ubuntu Oneiric):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
importance: Medium → High
Jeremy Bicha (jbicha) wrote :

As I said in my duplicate bug, this is preventing me from running Synaptic or Ubuntu Software Center.

Brian Murray (brian-murray) wrote :

The plugin that the crash is occurring in is actually provided by software-center.

affects: apt-xapian-index (Ubuntu Oneiric) → software-center (Ubuntu Oneiric)
Changed in software-center (Ubuntu Oneiric):
assignee: Canonical Foundations Team (canonical-foundations) → Michael Vogt (mvo)
Kiwinote (kiwinote) wrote :

This should hopefully be fixed in the branch linked.

@jbicha: I'm actually quite interested in seeing what caused this bug, would you perhaps be able to post a complete list of all your sources.list entries (only the deb lines are of interest)? Thanks in advance!

Changed in software-center (Ubuntu Oneiric):
assignee: Michael Vogt (mvo) → Kiwinote (kiwinote)
status: Confirmed → Fix Committed
Jeremy Bicha (jbicha) wrote :

Sure, I'd be happy to help out. My list is a bit embarrassing because it's so long but nearly all of them have been disabled for quite a while. Attached.

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :

Hi, unfortunately this still doesn't fix my Synaptic. I applied the 1-line fix to my Ubuntu.py and Synaptic still crashes on start.

I also removed software-center, aptdaemon, apt-xapian-index and Synaptic still crashes. I submitted bug 818382 as it has the crash info but it may be a duplicate of bug 807771.

I don't believe my Synaptic crash has anything to do with apt-xapian-index but I can't figure out what's not working right on this computer. I'm tempted to do a clean install but then y'all wouldn't be able to confirm that whatever is broken gets fixed.

Jeremy Bicha (jbicha) wrote :

Ok, just as a followup, my issue in bug 807771 seems to be because of a conflict with the On Screen Keyboard.

And I believe kiwinote's fix for this apt-xapian-index bug works too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.11

---------------
software-center (4.1.11) oneiric; urgency=low

  [ Michael Vogt ]
  * utils/show_top_rated_for_various_powers.py:
    - add helper to help with the parameterization of the top-rated
      algorithm
  * some cleanup and new test/gtk3/test_navhistory.py
  * merged from lp:~aaronp/software-center/more-top-rated, many
    thanks to Aaron Peachey!
  * move the AppEnquire code from ui.gtk3 into the generic db space
    and add gobject query-complete signal
  * test/gtk3/test_purchase.py:
    - add tests for reinstall previous purchase
  * softwarecenter/ui/gtk3:
    - use datadir for the gtk3 art and css

  [ Gary Lasker ]
  * softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - port recent crash fixes and the standalone deb install
      startup time improvements to the gtk3 branch
  * softwarecenter/ui/gtk/appdetailsview_gtk.py,
    softwarecenter/ui/gtk3/views/appdetailsview_gtk.py:
    - fix incorrect display of command line launch details
      (LP: #817524)
  * utils/submit_review.py:
    - display app name rather than package name in the edit
      review dialog title (LP: #818306)

  [ Kiwinote ]
  * softwarecenter/distro/Ubuntu.py:
    - ensure get_downloadable_icon_url() returns a string (LP: #810552)
  * softwarecenter/ui/gtk/appview.py:
    - lowlevel cache isn't available on startup, so query it only on demand
    - fix normal cache to correctly filter out unavailable pkgs (LP: #799713)

  [ Aaron Peachey ]
  * lp:~aaronp/software-center/more-top-rated:
    - support top rated carousel for subcategories like Games or
      Development Tools
 -- Michael Vogt <email address hidden> Mon, 01 Aug 2011 16:15:31 +0200

Changed in software-center (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in software-center (Ubuntu):
assignee: Kiwinote (kiwinote) → nobody
assignee: nobody → Zeeshan Malik (zeeshan-m-malik)
To post a comment you must log in.