An option to Purchase software is not visible in Ubuntu 11.04 S/w center

Bug #774590 reported by Sai Ranjan on 2011-05-01
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Gary Lasker
Natty
Undecided
Unassigned

Bug Description

Binary package hint: software-center

Option to view paid softwares available in Software center is not present which was in previous versions.

TEST CASE for SRU:

This is a usability fix that simply always expands the left pane's "Get Software" item on launch so that its subitems are always visible and available. To test this fix:

1. Update to Software Center 4.0.3 in natty-proposed.
2. Open Software Center and verify that the "Get Software" item is expanded.
3. Collapse both the "Get Software" and "Installed Software" items.
4. Close Software Center.
5. Reopen Software Center and verify that the "Get Software" item is expanded while the "Installed Software" item remains collapsed.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 4.0
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Sun May 1 08:07:32 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: No upgrade log present (probably fresh install)

Sai Ranjan (sairanjank) wrote :
Robert Roth (evfool) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

* Is this reproducible?
* If so, what specific steps should we take to recreate this bug?

This will help us to find and resolve the problem.

Changed in software-center (Ubuntu):
status: New → Incomplete
Sai Ranjan (sairanjank) wrote :

No sir it is not reproducible. It is a new installation. I haven't tweaked anything. Please see the attached image

Gary Lasker (gary-lasker) wrote :

Hi sairanjan, thanks for reporting back and for including the screenshot. It seems all you need to do is to expand the "Get Software" item in the treeview to the left (where you have circled in the screenshot). Once you do that, you'll reveal the "For Purchase" subitem. Just select that and you should see the list of software items available.

Please see the screenshot I've attached.

Please be sure to let us know if this doesn't solve the issue, and thank you!

Gary Lasker (gary-lasker) wrote :

For now I'll mark this one as invalid based on my previous comment #4. Thanks again!

Changed in software-center (Ubuntu):
status: Incomplete → Invalid

It worked

On Fri, May 6, 2011 at 9:24 PM, Gary Lasker <email address hidden>wrote:

> For now I'll mark this one as invalid based on my previous comment #4.
> Thanks again!
>
> ** Changed in: software-center (Ubuntu)
> Status: Incomplete => Invalid
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/774590
>
> Title:
> An option to Purchase software is not visible in Ubuntu 11.04 S/w
> center
>
> Status in “software-center” package in Ubuntu:
> Invalid
>
> Bug description:
> Binary package hint: software-center
>
> Option to view paid softwares available in Software center is not
> present which was in previous versions.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.04
> Package: software-center 4.0
> ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
> Uname: Linux 2.6.38-8-generic i686
> Architecture: i386
> Date: Sun May 1 08:07:32 2011
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
> (20110427.1)
> PackageArchitecture: all
> ProcEnviron:
> LANGUAGE=en_US:en
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: software-center
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/774590/+subscribe
>

--
Sai Ranjan Kalchar

Gary Lasker (gary-lasker) wrote :

Reopening this one as this really seems a usability deficiency that we ought to fix. We discussed this and other viewswitcher usability issues at UDS Budapest and the consensus for this case was that we ought to always expand the "Get Software" node by default. This will ensure that the "For Purchase" and "Independent" nodes (two particularly interesting/important ones) are always visible and available.

Changed in software-center (Ubuntu):
assignee: nobody → Gary Lasker (gary-lasker)
importance: Undecided → Low
status: Invalid → Triaged
Changed in software-center (Ubuntu):
status: Triaged → In Progress
Changed in software-center (Ubuntu):
status: In Progress → Fix Committed
description: updated
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.1.3

---------------
software-center (4.1.3) oneiric; urgency=low

  [ Michael Vogt ]
  * merged lp:~mvo/software-center/refactor, no user visible
    changes, only code cleanup
  * merged lp:~mvo/software-center/pyflakes, no user visible
    changes, only code cleanup
  * enforce pyflakes cleaness on bzr-buildpackage
  * merged lp:~mvo/software-center/review-language-fallback
    to support fallback to other languages if there are no
    reviews in the native language
  * merged lp:~evfool/software-center/fix506419, many thanks!
    (LP: #506419)

  [ Gary Lasker ]
  * softwarecenter/app.py:
    - expand the "Get Software" item in the viewswitcher by default
      so that its subitems are always visible and available
      (LP: #774590)
  * merged lp:~aaronp/software-center/refactoring, many thanks
    to Aaron Peachey
  * softwarecenter/app.py,
    softwarecenter/backend/restfulclient.py,
    softwarecenter/backend/rnrclient.py,
    softwarecenter/db/update.py:
    - fix some root logger warnings, other cleanup
  * merged lp:~evfool/software-center/carouseltransition, very
    nice effect, many thanks Robert Roth (LP: #633193)
  * softwarecenter/ui/gtk/availablepane.py,
    softwarecenter/ui/gtk/catview_gtk.py:
    - jumpstart Featured and What's New carousel transitions
      on launch (LP: #786403)
 -- Michael Vogt <email address hidden> Tue, 24 May 2011 12:10:09 +0200

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released

Accepted software-center into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in software-center (Ubuntu Natty):
status: New → Fix Committed
tags: added: verification-needed
Matthew Paul Thomas (mpt) wrote :

As originally reported, this bug is Invalid. It is not necessary to expand the "Get Software" branch to access paid applications: they are included in the overall "Get Software" collection.

Nor is it necessary to expand the branch to access Independent applications: they too are included in the overall "Get Software" collection.

The reason I specified that the branches should be collapsed on first launch <https://wiki.ubuntu.com/SoftwareCenter#channels> is that the child items are interesting only to people who need to see which items are in which repository, and distracting to the majority who do not. I think expanding them by default would be a regression.

And the reason I specified that the expanded or collapsed state should persist between sessions is that remembering state is generally the right thing to do. So I think resetting to expanded state on each launch would be a regression too.

If we really thought all sources should be visible on each launch, there would be little use in them being nested items at all -- they could be top-level items, with a separator between the "Get Software" group and the "Installed" group.

So, I would prefer it if the upload could be removed from -proposed, and this particular change reverted from both 4.0.x and trunk. I'm sorry I didn't see that this bug report had been reopened until now, because I was busy working on the USC5 design. Incidentally, it is likely the "Get Software" tree branch may be replaced by a single toolbar button, hiding the individual sources even further.

Gary Lasker (gary-lasker) wrote :

Hey mpt, thanks for your insights on this. This came up as an issue at the UDS session for UI Enhancements and there was discussion about it, see the raw session notes here:

  https://wiki.ubuntu.com/SoftwareCenter/UDSOneiricSessionNotes

Specifically, check the last two lines of the following section:

 * Simplify the UI (this may be a big topic and so we might move this to its own blueprint)
   * Remove the left navigation pane, it takes a lot of space but where to put the information
    * the expander is tiny and often unnoticed
    * should expand by default, especially Get Software

It's for this reason this work item was added to the spec. (Note that I was the one who originally set this bug as Invalid, but it was the opinions put forth at the session that made me reconsider).

Indeed it is true that the For Purchase items are available from Get Software, but it is not possible to easily browse *only* the available For Purchase apps from that section, I think a lot of people want to do just that. Since the expander for Get Software in the treeview is small, however, it's easily overlooked and so the contained items remain invisible.

In fact, this bug was originally filed for this use case; the reporter wanted to browse items for purchase but was unable to find the For Purchase subitem to select it (likely for him this node had gotten collapsed at some point).

Fwiw, I don't think *all* sources should be available, but the For Purchase and Independent nodes are special cases and I do think we ought to make them visible by default. What is the use of hiding them? People are interested in those specifically, and they are delivered by default with Ubuntu (unlike PPA nodes, that are added by the user).

I guess I don't see how it hurts to expand Get Software by default, but I do see how it helps (as described above). Note also that the Installed Software item is collapsed by default and its expansion state persisted as before.

Maybe we should wait to see if we get any complaints about Get Software being expanded by default?

Please let me know what you think. Thanks!

Pedro Villavicencio (pedro) wrote :

Thanks for the proposed package, I've tested it and it now works as expected in the test case, so marking this as verification-done, Thanks all!.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.0.3

---------------
software-center (4.0.3) natty-proposed; urgency=low

  [ Gary Lasker ]
  * softwarecenter/app.py:
    - expand the "Get Software" item in the viewswitcher by default
      so that its subitems are always visible and available
      (LP: #774590)
  * softwarecenter/view/availablepane.py,
    softwarecenter/view/catview_gtk.py:
    - jumpstart Featured and What's New carousel transitions
      on launch (LP: #786403)

  [ Michael Vogt ]
  * merge lp:~mvo/software-center/4.0-pagination to properly
    support pagination (LP: #788688)
 -- Michael Vogt <email address hidden> Thu, 26 May 2011 17:55:10 +0200

Changed in software-center (Ubuntu Natty):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers