have to hurry to click "add to launcher"

Bug #765389 reported by Martin Pool on 2011-04-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Gary Lasker

Bug Description

Binary package hint: software-center

steps to reproduce:
* navigate to a not-yet-installed application in the software centre (i used radio-tray)
* click install
* modal dialog appears asking me to enter my password to authenticate; in the background a ribbon appears at the bottom of the window asking if i want to add the application to the launcher or not
* enter password and press enter
* application installs (in this case quite quickly)

What happens then:
* the "do you want to add it to the launcher" ribbon disappears

What should happen:
* It should persist until I leave this page (at least)

The problem is that there is potentially only a very short window (1-2 seconds in this case) between approving installation and the ribbon disappearing.

Kind of related to bug 670403.

Related branches

Aaron Peachey (aaronp) wrote :

I have experienced the same with a fast installing app and agree that it can probably escape you too quickly. It's also a valid point that you wouldn't necessarily want to add the app to your launcher immediately upon installing it, and may do so later after you try it out. This does seem to invalidate the current functionality in many use-cases.

It appears the other bug # 670403 has a few trains of thought on how to implement.
I believe we should keep the current implementation for convenience (i.e. when you're installing an app that you know you want to add to the launcher) but also add another place in USC where you can choose which installed apps to add to the launcher, at any later time.
However, I believe this begs the question of whether this is functionality that should exist in USC or in Unity (or both?).
After software has actually been downloaded/installed/upgraded via USC it would seem that USC's role is over - I'm leaning towards this actually being something that should be achievable via Unity directly as it seems like quite a significant usability issue if we were to force users to open up USC just to add a new icon to their launcher. It would be a matter of convenience for a user to be able to achieve this in a central place in USC but I think this should be secondary option only.

Just my thoughts.

Changed in software-center (Ubuntu):
status: New → Opinion
Gary Lasker (gary-lasker) wrote :

Hey Martin, thanks for your report. I completely agree; it's annoying to have the offer to install disappear right at the end of the installation, particularly if the installation is really quick.

I'm working on a branch now that will keep the offer to install available for the duration of time the details view is showing.

Changed in software-center (Ubuntu):
status: Opinion → Triaged
importance: Undecided → Medium
assignee: nobody → Gary Lasker (gary-lasker)
status: Triaged → In Progress

@Aaron if you've tried an application and you like it, you can keep it
in the launcher by right-clicking and choosing 'keeping in launcher'.

Also, Launchpad's "opinion" status means "that's your opinion but
we're not going to fix it." If you agree with the bug, choose
"confirmed." <http://blog.launchpad.net/bug-tracking/new-bugs-status-opinion>

Aaron Peachey (aaronp) wrote :

Thanks Martin, I misinterpreted the 'Opinion' status. I was trying to say I didn't think we were ready to fix the bug with the info that we had but wanted to promote some discussion from others to get to a point where we agree on what the actual issue is so we can fix it. Anyway, looks like Gary has it under control. Thanks!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 4.0

---------------
software-center (4.0) natty; urgency=low

  [ Gary Lasker ]
  * softwarecenter/view/softwarepane.py:
    - display the offer to add an application to the launcher
      for the duration of the time that the details view
      is showing (LP: #765389)

  [ Michael Vogt ]
  * test/test_unity_launcher_integration.py:
    - update tests
  * update version number for natty-final
 -- Michael Vogt <email address hidden> Wed, 20 Apr 2011 14:03:25 +0200

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Gary Lasker (gary-lasker) wrote :

Hi Aaron and Martin! So, I have to admit that I had the same (mis)understanding of the "opinion" status as Aaron, so I also appreciate Martin's clarification. In any case, the solution to the general problem described in the original bug 670403 is still very much in flux; clearly we will need to refine it based on feedback and user testing of what we have now. I expect that this will be an ongoing discussion for Oneiric and so for me Aaron's comments in this bug are a part of that discussion.

Regarding the specific issue that you highlighted in this report, that was a side-effect of the implementation of the original design (for various reasons the implementation of this feature has morphed quite a bit over the course of the Natty cycle). It was a TODO of mine to take care of this and your bug report gave me the excuse to do it now. I'm very glad for that as I think it's a very nice improvement indeed.

Many thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers