support file:///path/pkgname.deb syntax

Bug #752376 reported by Martin Eve on 2011-04-06
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Robert Roth

Bug Description

Binary package hint: software-center

Downloaded the dropbox deb file and attempted to open with software center.

Expected result: installer launches.

Actual result: "There isn't a software package called "File:" in your current software sources."

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.25
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Wed Apr 6 11:36:28 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100831.2)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to natty on 2011-04-05 (1 days ago)

Related branches

Martin Eve (martineve) wrote :
Daniel Holbert (dholbert) wrote :

This appears to be because Software-Center doesn't accept file:/// URIs, which appears to be is the type of URI that Firefox passes to it, when you do "Open With: [Ubuntu Software Center]" in the file-download dialog.

Simpler steps to reproduce:
 1. Download a deb to e.g. /tmp/foo.deb
 2. Run in a terminal: "software-center file:///tmp/foo.deb"
 3. Close software-center
 4. Run in a terminal: software-center /tmp/foo.deb"

Step 2 is broken, step 4 works.

Daniel Holbert (dholbert) wrote :

(Compare to e.g. "file-roller" and "eog", both of which handle file:/// URIs just fine.)

Daniel Holbert (dholbert) wrote :

(For anyone hitting this, a simple workaround is just to double-click the file in a file manager like nautilus.)

FWIW, I filed https://bugzilla.mozilla.org/show_bug.cgi?id=652863 for this on the Mozilla side -- I'm not sure what will result of that though - it may end up being resolved as not-a-bug-in-Firefox.

Daniel Holbert (dholbert) wrote :
Changed in software-center (Ubuntu):
status: New → Confirmed
Philip Wright (kinsago) wrote :

I get this error when I download and try to install a .deb in LXDE. If I change from pacman to nautilus I don't have the same problem. I've changed to using Gdebi for installing from .deb files but I don't count this as a 'fix'

Kiwinote (kiwinote) on 2012-05-02
summary: - Software center won't allow install from .deb file
+ support file:///path/pkgname.deb syntax
Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Bryan Quigley (bryanquigley) wrote :

Note to Lubuntu users, it appears PCManFM hits this case (as does Chromium). So you can just do software-center debname.deb

Robert Roth (evfool) on 2012-06-03
Changed in software-center (Ubuntu):
assignee: nobody → Robert Roth (evfool)
status: Triaged → In Progress

Triggered this installing SpiderOak.

Dmitry Shachnev (mitya57) wrote :

software-center (5.3.1) quantal; urgency=low

  [ Robert Roth ]
  * lp:~evfool/software-center/lp752376:
    - Updated the code to also work with file:// style deb filenames
      (LP: LP #752376)
  * lp:~evfool/software-center/lp1011605:
    - update copyright date in the About window (LP: #1011605)
  * lp:~evfool/software-center/lp1011567:
    - add F1 key as accelerator for opening Help (LP: #1011567)

  [ Gary Lasker ]
  * debian/control:
    - remove recommends for gir1.2-launchpad-integration-3.0 as it is no
      longer needed (many thanks Robert Ancell)

  [ Natalia Bidart ]
  * lp:~nataliabidart/software-center/the-organizer:
    + Tests cleanup:
      - Renamed test/ dir to tests/.
      - Moved the testutils module to tests/utils.py.
      - Removed all unnecessary logging setup per test file.
      - Removed all unnecessary shebangs in test files.
      - Isolated test code into tests/ directory, including moving all the
        get_test_window_foo from the gtk3 production modules to
        tests/gtk3/windows.py module.
      - Removed all the calls to Gtk.main() in gtk3 tests since that blocks the
        execution of the suite.
      - Pep8 and pyflakes fixes in the files already modified in this branch.
      - Minor bug fix in the softwarecenter/log.py module when trying to
        create a log dir with proper perms.
  * lp:~nataliabidart/software-center/cant-stop-the-music.trunk:
    - Stop the video if user navigates away from an app details page
      (LP: #1003954).
    - Refactored ViewManager so page displaying calls a leave_page before
      changing a page, and a enter_page when navigating into a page.

  [ Adam Conrad ]
  * xz-lzma has been rolled into xz-utils, as of 5.1.1alpha+20120614-1

  [ Michael Vogt ]
  * lp:~mvo/software-center/python-apt-0.8 :
    - fix some leftover python-apt 0.7 API usage that will get removed
      in quantal
  * lp:~mvo/software-center/add-profile-cmdline
    - add new --profile option to the app that writes out a cProfile
      logfile
    - add new dbus method com.ubuntu.SoftwarecenterIFace.writeMemoryDump
      to write meliae memory dump for analyizing memleaks/cycles
  * lp:~mvo/software-center/more-performance-measurement:
    - add more fine grained data in --measure-startup-time and
      suppresses times <0.1s in the output

Changed in software-center (Ubuntu):
status: In Progress → Fix Released
Cameron (camthemusician) wrote :

Is a fix being released for Ubuntu 12.04 LTS (precise)?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.