custom list doesn't find some apps when comma delimited

Bug #746954 reported by Patrick Wright on 2011-04-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

Steps:
1 Search for gobby
versions 0.4 and 0.5 are listed

2 Search for gobby,9base

Actual: only gobby 0.4 is listed

Expected:
- the lastest version 0.5 (I might be wrong but that seems logical)
- Plan 9 should be listed

3 Search for 9base
* Plan 9 app is listed

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: software-center 3.1.24.4
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Thu Mar 31 20:56:55 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110302)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
UpgradeStatus: Upgraded to natty on 2011-03-31 (0 days ago)

Patrick Wright (patrickmwright) wrote :
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Robert Roth (evfool) wrote :

The second case seems to be a regression, as on Maverick with software-center 3.0.7 Plan 9 is listed when searching for gobby,9base.

Gary Lasker (gary-lasker) wrote :
Download full text (3.9 KiB)

Hey Patrick! Custom lists were broken for a time (indeed, Robert, a regression) but this feature was fixed by kiwinote in version 3.1.25. Things seem to be working fine now. I'll attached screenshots just for the heck of it! :)

software-center (3.1.25) natty; urgency=low

  [ Kiwinote ]
  * data/ui/SoftwareCenter.ui:
    - mark the back/forward actions as translatable (LP: #742129)
  * softwarecenter/db/database.py,
    softwarecenter/models/appstore.py,
    softwarecenter/view/availablepane.py,
    others:
    - make custom lists work (LP: #712903)
  * softwarecenter/app.py,
    softwarecenter/distro/Ubuntu.py,
    softwarecenter/view/widgets/pathbar_gtk_atk.py:
    - when the supported filter is set to supported_only, navigate up if:
      - we are in a details view of an app which is not supported (LP: #480827)
      - we are in a list view which becomes empty
  * softwarecenter/app.py,
    softwarecenter/view/catview_gtk.py:
    - correctly count the nr of apps displayed in the recommended category and
      update it when needed (LP: #735634)
    - only display subcategories if they are non-empty (LP: #419270)
  * softwarecenter/backend/weblive.py:
    - don't crash if we try to delete a non-existent file (LP: #743511)
  * softwarecenter/db/reviews.py,
    softwarecenter/distro/Ubuntu.py:
    - fallback to ReviewLoaderJsonAsync when we can't use multiprocessing
      (LP: #741069)
    - fixes to make ReviewLoaderJsonAsync 'work' (ie most common cases)
  * softwarecenter/db/update.py:
    - don't import softwarecenter.log
  * softwarecenter/view/appdetailsview_gtk.py:
    - don't draw random boxes when we have an error layout (LP: #739269)
    - retire share button as we now have full microblogging support in the
      review dialog (LP: #592619, LP: #743765)
  * softwarecenter/view/appview.py:
    - correctly refresh listview when supported filters are changed
  * softwarecenter/view/catview.py:
    - if a category has subcategories, then category.query should include all
      items included in the subcategories, not a subset of these
  * softwarecenter/view/widgets/pathbar_gtk_atk.py:
    - avoid having a half-height pathbar (LP: #743614)
  * refresh .pot file

  [ Gary Lasker ]
  * softwarecenter/view/widgets/reviews.py:
    - fix crash if app_version is not defined when
      calling upstream_version_compare (LP: #746120)
  * softwarecenter/view/purchaseview.py:
    - disconnect webkit signal handlers when the webkit view
      is not showing (LP: #696861)
    - support 'user_cancelled' from the software-center-agent
      (LP: #641321)
  * softwarecenter/view/softwarepane.py,
    softwarecenter/view/widgets/actionbar.py:
    - animate the action bar show/hide
  * softwarecenter/view/appview.py:
    - in the AppViewFilter, also consider apps in the for-purchase
      channel as available; this allows them to show up in
      e.g. What's New (LP: #746679)

  [ Michael Vogt ]
  * softwarecenter/db/update.py:
    - ensure the iconname that comes from the software-center-agent
      does not contain a ".", the icon cache gets confused otherwise
  * merged lp:~evfool/software-center/sfix672229, many thanks to
    Robert Roth (LP: #6722...

Read more...

Changed in software-center (Ubuntu):
status: New → Fix Released
Gary Lasker (gary-lasker) wrote :

This first screenshot shows the result when building a custom list for "gobby,9base". Note that it returns Gobby version 0.4, since that version uses the package name "gobby". See next screenshot for how to show Gobby 0.5.

Gary Lasker (gary-lasker) wrote :

This one shows Gobby 0.5. Since Gobby 0.5 uses a different package name, you have to specify it as "gobby-0.5,9base".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers