Review window stuck at "signing in"

Bug #713648 reported by Bart on 2011-02-05
58
This bug affects 9 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: software-center

Hello,
We click on 'write your own review", the review window opens but stays in "signing" in state.
I also updated the software-center to the latest daily build, and has the same problem.
The internet connection works of course (else I couldn't write this :p) .

OS details:
Distributor ID: Ubuntu
Description: Ubuntu natty (development branch)
Release: 11.04
Codename: natty

Desktop (informational):
KDE 4.6

Software center version:
3.1.16~bzr1461~natty1

Screenshot:
http://tinypic.com/r/1733wz/7

Aaron Peachey (aaronp) wrote :

Hi Bart, thanks for reporting this. Can you please run software-center from a terminal, try to reproduce the bug (i.e. try to sign in by submitting a review) and then attach the terminal output here. We can then investigate further. Thanks

Changed in software-center (Ubuntu):
status: New → Incomplete
Bart (bart-schelstraete) wrote :
  • logs Edit (865.5 KiB, application/x-tar)

Hi,

This was already part of the screenshot :)
I now attached "log.tgz" with 3 files:

log.txt -> terminal output
debug.txt -> debug output
strace.txt -> strace output (maybe useless)

Aaron Peachey (aaronp) wrote :

Thanks Bart, I looked at your image and saw the output in the background but couldn't read what it says. Thanks for following up.
The output doesn't help me investigate as much as I'd hoped. I'll take a look and see what I can figure out but might come back to ask for more info if possible.

Bart (bart-schelstraete) wrote :

Aaron,
For your information: I just tried on another machine, and there it works (same software-center version).
So it's not a 'global' problem, and therefore it's not really blocking.

I will also check if I can do some extra tracing.

Thanks Bart. I'm glad it's working for you because the traceback gave me
nothing to work with.

It's still an issue we'd like to look at so we can fix it for you and any
other people who have the same problem, so if you can do anything else to
provide more info, please do.

On 06/02/2011 9:35 AM, "Bart" <email address hidden> wrote:
> Aaron,
> For your information: I just tried on another machine, and there it works
(same software-center version).
> So it's not a 'global' problem, and therefore it's not really blocking.
>
> I will also check if I can do some extra tracing.
>
> --
> You received this bug notification because you are subscribed to
> software-center in ubuntu.
> https://bugs.launchpad.net/bugs/713648
>
> Title:
> Review window stuck at "signing in"
>
> Status in “software-center” package in Ubuntu:
> Incomplete
>
> Bug description:
> Binary package hint: software-center
>
> Hello,
> We click on 'write your own review", the review window opens but stays in
"signing" in state.
> I also updated the software-center to the latest daily build, and has the
same problem.
> The internet connection works of course (else I couldn't write this :p) .
>
>
> OS details:
> Distributor ID: Ubuntu
> Description: Ubuntu natty (development branch)
> Release: 11.04
> Codename: natty
>
> Desktop (informational):
> KDE 4.6
>
> Software center version:
> 3.1.16~bzr1461~natty1
>
> Screenshot:
> http://tinypic.com/r/1733wz/7
>
>

Launchpad Janitor (janitor) wrote :

[Expired for software-center (Ubuntu) because there has been no activity for 60 days.]

Changed in software-center (Ubuntu):
status: Incomplete → Expired
trampster (trampster) wrote :

I am having exactly the problem described here, let me know if I can provide any extra info.

trampster (trampster) wrote :

Changed back to new as this bug still exists in 12.04.

If I run from the terminal I get:

2012-05-11 21:12:57,771 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2012-05-11 21:12:57,773 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2012-05-11 21:12:57,937 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file
2012-05-11 21:12:58,256 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()

(software-center:14375): Gtk-WARNING **: Unable to show 'none': Operation not supported
2012-05-11 21:13:30,307 - softwarecenter.ui.gtk3.app - INFO - software-center-agent finished with status 0
2012-05-11 21:13:30,307 - softwarecenter.db.database - INFO - reopen() database
2012-05-11 21:13:30,308 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True

I have tried deleting /home/daniel/.cache/software-center and /home/daniel/.config/software-center and then reinstalling this does not help.

Changed in software-center (Ubuntu):
status: Expired → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2012-05-26
tags: added: client-server natty oneiric precise
removed: signin software-center stuck
Changed in software-center (Ubuntu):
importance: Undecided → Medium
dino99 (9d9) on 2013-07-08
tags: removed: natty oneiric
Simon Reed (xubuntu-o) wrote :
Download full text (4.2 KiB)

I am getting the same symptoms in Xubuntu 13.10, GNOME 3.8.4, Kernel 3.11.0-18-generic, GCC version 4.8 (x86_64-linux-gnu), Xorg version 1.14.5 (17 December 2013 10:06:15AM).

It is Ubuntu Software Centre 13.10

Loading it from the command prompt, selection Transmission, and clicking on 'Write your own review' gives this:

$ software-center
2014-03-31 21:15:26,716 - softwarecenter.backend.zeitgeist_logger - WARNING - Support for Zeitgeist disabled
2014-03-31 21:15:26,738 - softwarecenter.ui.gtk3.app - INFO - setting up proxy 'None'
2014-03-31 21:15:26,937 - softwarecenter.region - WARNING - failed to use geoclue: 'org.freedesktop.DBus.GLib.UnmappedError.GeoclueErrorQuark.Code1: Geoclue master client has no usable Address providers'
2014-03-31 21:15:27,308 - softwarecenter.plugin - INFO - activating plugin '<module 'webapps_activation' from '/usr/share/software-center/softwarecenter/plugins/webapps_activation.pyc'>'
2014-03-31 21:15:27,314 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/importer.py', 51, 'find_module')'
2014-03-31 21:15:27,313 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2014-03-31 21:15:27,359 - softwarecenter.db.pkginfo_impl.aptcache - INFO - aptcache.open()
2014-03-31 21:15:29,718 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/share/software-center/softwarecenter/utils.py', 271, 'get_title_from_html')'
2014-03-31 21:15:29,718 - root - WARNING - failed to parse: '<div style="background-color: #161513; width:1680px; height:200px;">
 <div style="background: url('/site_media/exhibits/2013/09/AAMFP_Leaderboard_700x200_1.jpg') top left no-repeat; width:700px; height:200px;"></div>
</div>' ('ascii' codec can't encode character u'\xa0' in position 70: ordinal not in range(128))
2014-03-31 21:15:29,719 - softwarecenter.ui.gtk3.views.lobbyview - WARNING - skipping exhibit for: 'u'amnesia-amfp'' not available
2014-03-31 21:15:29,721 - softwarecenter.backend.login_impl.login_sso - ERROR - _on_credentials_error for Ubuntu One: dbus.Dictionary({dbus.String(u'errtype'): dbus.String(u'GUINotAvailableError'), dbus.String(u'message'): dbus.String(u'Can not find a GUI to present to the user (tried with "(\'ubuntu-sso-login-qt\', \'ubuntu-sso-login-qt\')"). Aborting.')}, signature=dbus.Signature('ss')) ()
2014-03-31 21:15:29,721 - softwarecenter.backend.login_impl.login_sso - ERROR - _on_credentials_error for Ubuntu One: dbus.Dictionary({dbus.String(u'errtype'): dbus.String(u'GUINotAvailableError'), dbus.String(u'message'): dbus.String(u'Can not find a GUI to present to the user (tried with "(\'ubuntu-sso-login-qt\', \'ubuntu-sso-login-qt\')"). Aborting.')}, signature=dbus.Signature('ss')) ()

(software-center:11339): Gdk-WARNING **: /build/buildd/gtk+3.0-3.8.6/./gdk/x11/gdkwindow-x11.c:5304 drawable is not a native X11 window

(software-center:11339): Gdk-WARNING **: /build/buildd/gtk+3.0-3.8.6/./gdk/x11/gdkwindow-x11.c:5304 drawable is not a native X11 window

(software-center:11339): Gdk-WARNING **: /build/buildd/gtk+3.0-3.8.6/./gdk/x11/gdkwindow-x11.c:5304 drawable is not a native X11 window
2014-03-31 21:15:32,172 - softwarecenter.region - WAR...

Read more...

Urs Fleisch (ufleisch) wrote :

I am using Lubuntu and had to install the ubuntu-sso-login-qt package to fix this problem. This package is in the dependencies of ubuntu-desktop, but not of software-center. Maybe its dependences have to be fixed.

LambdaFox (lambdafox) wrote :

I had this problem on Ubuntu GNOME 14.04 LTS [AMD64 with Softare Center Version 13.10.

I followed Urs Fleisch suggestion to install the ubuntu-sso-login-qt package and it solved this problem for me too.

It appears that software-center's dependencies should include that package.

LambdaFox (lambdafox) wrote :

This dependency error also affected me. I am running a fresh install of Xubuntu Core 15.10. The package I had to install was named: ubuntu-sso-client-qt

dobey (dobey) on 2015-12-18
no longer affects: software-center
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments