Ubuntu Software Center is very slow

Bug #641899 reported by ubuntosaure
218
This bug affects 52 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
High
Unassigned

Bug Description

Ubuntu software center in the Maverick update become a very slow program.
For some, it has been slow since Lucid, for others it started with Maverick.

Seems like all operations are terribly slow.
Installing is the worst one, and is not just slow, the interface does not updates correctly.
The description of any package gets very slow, and when installing by this screen, the installation never finishes (or just don't update the status), going back one level, it stills says Install button, reselecting it it updates to Remove button.
GDebi is much faster in everything, a comparison of opening a package:

software-center: 34 secondes
GDebi: 10 secondes

It takes a long time to start. This is really bad and must be solved if it is wanted to be used as a gdebi replacement.

Navigating is insanely slow. Not only that takes a long time to display software lists, but also when scrolling it lags a lot: You scroll, you stop moving the scroll wheel and keeps on scrolling a few seconds.

When you click install, it freezes a few seconds (window turns grey), or it just does nothing for a few seconds, until it is added to the queue.

There is an attached video so that everyone can see.

Thank you

Revision history for this message
ubuntosaure (ubuntosaure) wrote :
Changed in software-center (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Kiwinote (kiwinote)
Changed in software-center (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
3esmit (3esmit)
summary: - Software-center is very slow in front of gdebi!
+ Software-center is very slow
Revision history for this message
3esmit (3esmit) wrote : Re: Software-center is very slow

I ve updated the description based in duplicates that I also marked, but check all duplicates comments also, there are more information and attachments there. I hope everyone agrees with this. Thank you.

description: updated
summary: - Software-center is very slow
+ Ubuntu Software Center is very slow
tags: added: iso-testing
Revision history for this message
Andrea Cimitan (cimi) wrote :

It's actually a blocking issue (waiting 30 seconds to load software center on a netbook is something we can't ignore), software center feels like the slowest application shipping in ubuntu, even slower than openoffice.

I guess part of this issue is the choice of python as the language, but of course, I'm not proposing a rewrite.

Maybe we could make the software center a bit more modular, like it loads modules only when needed.
For example: there's no reason to load the whole software center if you're double clicking a deb downloaded from the web (skype, adobeair, dropbox whatever), you could just provide a small window with app name and description, so it will be lighter to load (then provide a button to load the whole software center with sidebars and whatever).

Revision history for this message
Kiwinote (kiwinote) wrote :

Hi everyone! I am entirely agreed that the startup time of s-c is something that needs improving. This is something that I am dedicated to 'fixing' during the natty cycle. Some of you may know that I worked on this a bit during the summer; In an experimental branch I managed to reduce warm startup time from about 3s to 1s and cold startups from 14s to 8s. The branch is unsuitable for merging, but it allowed me to get a feeling for where the slowness lies and what to do about it. Since then much of the code has changed (eg the startup speed of trunk has increased due to new features), so I will need to do the work again - although I will make similar changes to what I made back then (and also a few other crucial changes which I have come up with since then). I think that 1.5s and 10s startup times are realistically achievable without creating a 'minimal' interface. 1s and 5s startup times are the ultimate goal which should be achievable with further tweaks to the existing model. This is just a quick message to let you know that the issue of startup speed isn't being ignored - it will probably be December before I have time to work on this though. Feel free to ping me at UDS about any of this. Cheers.

Revision history for this message
MillenniumBug (millenniumbug) wrote :

Good to know that there is focus on this problem. Just to inform that it is not new:
https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/535292
I stopped at 10.04, but for people on 10.10: Please add your findings, if you are using older hardware.

I think the option of having a minimal interface, as Kiwinote mentions in #4, would be a great solution to many users.

Revision history for this message
Ignacio Marcoux (ignacio-dm10) wrote :

It's not about removing features to USC. USC is already very minimal and simple, and being so slow makes no sense. Instead, it should be optimized (I mean, the inferface is just a simple list, it's impossible that such thing can't run perfectly in modest hardware)

Revision history for this message
Kiwinote (kiwinote) wrote :

@Martin: Just for clarity - what I was trying to say in #4 is that we can improve startup speed significantly without having to create a minimal interface - much as what Ignacio mentions in #6.

Revision history for this message
3esmit (3esmit) wrote : Re: [Bug 641899] Re: Ubuntu Software Center is very slow

@Martin: I never had problems of slowness in 10.04, maybe they where already
there, but as I have good hardware, never noticed. But now even in good
hardware the problem is showing up. Im using Software Center since 9.10.

Revision history for this message
Ignacio Marcoux (ignacio-dm10) wrote :

@3esmit: In netbook's hardware, the problem was also in 10.04, and I'm not sure if even in 9.10.

I think that this bug should be high importance also, this slowness totally breaks user experience.

Revision history for this message
3esmit (3esmit) wrote :

I agree with Ignacio, this should be high importance, due netbook user experience.

Revision history for this message
Gary Lasker (gary-lasker) wrote :

Agreed, the long startup time in particular is a serious usability problem on netbooks running Unity

Changed in software-center (Ubuntu):
importance: Medium → High
description: updated
Revision history for this message
Matthew Paul Thomas (mpt) wrote :

I'm keen on Ubuntu Software Center being much faster. However, It is not useful to have a single "Ubuntu Software Center is very slow" bug report, because most performance problems will be fixed separately from each other.

If launching on benchmark hardware takes more than two seconds, that should be its own bug report.
If navigating from one screen to another takes more than half a second, that should be its own bug report.
If USC is much slower on one architecture than the others, that should be its own bug report.
And so on.

So, I'm unmarking all the duplicates, and marking this bug report as Invalid. Please report individual performance problems separately.

Changed in software-center (Ubuntu):
status: Triaged → Invalid
Revision history for this message
Jesper (koudelkaa) wrote :

as it is right now, my computer boots faster than it can start software center.

Revision history for this message
Patrick Thomas Magill (pmagill) wrote :

Is anything going on as regards improving the Software Centre? I mean what was the point in building the thing if you are not going to actually make it usable.. Impressions so far from people I have moved to Ubuntu are that the software centre sucks basically

Revision history for this message
Tuomas Lähteenmäki (lahtis) wrote :

This sowtware center is too slow. Synaptic is fast.

Changed in software-center (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Chris Graham (chrisgraham) wrote :

It's definitely important to stress test things on a poor quality slow connection.

Imagine a new user setting up Ubuntu for a first time, already a bit overwhelmed by everything, and they've just got Dropbox setup and hogging network resources as it downloads many GB of data, while they continue to search for and install apps.

There are a few different issues I'm seeing, which I agree would be best posted separately (triage?), but as this issue already exists I'll post it in here...

1) The Install button really needs to be smart. If you go back and forward again, it needs to be at least greyed out if the software in question is already installing or in a queue to be installed.

2) If you do a search, the progress spinner should activate immediately. Currently it lags a bit. A user on a slow connection and bogged down machine has no idea if the extended lag is due to bugs, failed searches, back-logged search requests, or system slow-down.

3) I believe (but could be wrong) that in the current implementation it's possible for a search to come in after the search field has been changed to something else already, due to lag. That should never be possible - if the activate contents of the search field is not a superstring of what a search result has come in for, don't show that search result.

4) Ideally there would also be an installation queue tab so you can see what's in progress. You don't know as a user what has stalled, vs what is just being slow, vs what is back-logged.

Revision history for this message
FR. Loïc (hackurx) wrote :

Ubuntu Team impresses me.... This fucking bug is 9 years old!
Close all bugs reports after one year if you don't know how to fix them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers