100% processor load for 6 minutes or more

Bug #535292 reported by MillenniumBug on 2010-03-09
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: software-center

On a lot of occasions, Software Centre pulls 100% processor load, for example:

Open Gkrellm or another tool for watching processor activity.
Open Ubuntu Software Centre.
In the pane to the right, single-click on 'System'.

The processor load reaches 100% in several minutes. It happens on two different computers.
---
Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100126)
Package: software-center 1.1.16.1
PackageArchitecture: all
ProcEnviron:
 LANG=da_DK.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.24-generic
Tags: lucid
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

MillenniumBug (millenniumbug) wrote :

Description: Ubuntu lucid (development branch)
Release: 10.04

software-center:
Installed: 1.1.16.1
Candidate: 1.1.16.1
Version table:
*** 1.1.16.1 0

tekstr1der (tekstr1der) on 2010-03-09
Changed in software-center (Ubuntu):
status: New → Confirmed

apport information

tags: added: apport-collected
description: updated
tags: added: lucid
dinamic (dinamic6661) wrote :

i have the same problem amd xp 2500+ nvidia 7600 GS. 100% processor load, and lags badly when i scroll.

Matthew Paul Thomas (mpt) wrote :

This bug may well be fixed by whatever fixes bug 524567.

lavinog (lavinog) wrote :

Just noticed this today on my lucid -32bit machine.

Open software center, maximize the window, choose a package and click more info. Cpu usage jumps really high until you restore the window size or get out of the info page.

lavinog (lavinog) wrote :

I guess my issue requires a separate bug report.
The issue I have only occurs when you view details of a package when the package doesn't have a screenshot and the window is maximized.

lavinog (lavinog) wrote :

Strike my last comment, it does it with packages that do have a screenshot. Openoffice.org Word Processor is one.

I can confirm this bug.

In my case is only a few seconds (10 to 15), but I think that this is because of my processor (AMD X2 4400+). I'm using Lucid 64 Beta1 with all the updates applied.

The problem occurs when you select a large section, like "System", or "Provided by Ubuntu", the application turns unresponsive (the window turns grey) and one of the cores have a 100% utilization.

MillenniumBug (millenniumbug) wrote :

Now in version 1.1.23, it takes 30 seconds on my old machine. An improvement, but still annoying. Just opening Software Centre from the menu takes another 30 seconds with full load.

I wonder: Do the developers ever test their work on a machine as in the official minimal requirements?
https://help.ubuntu.com/community/Installation/SystemRequirements

Dennis (dxmecca) wrote :

Not running anything other than a browser and noticed the laptop became extremely hot to the touch. I checked the System Monitor and found everything under processes as "sleeping" with the exception of the System Monitor. The CPU was maxed at 100% and all other readings appeared normal. No hard drive activity during this event. The only way to I found to remedy the problem was to cold boot. Now it's back to normal range between 0 and 25%.

Kiwinote (kiwinote) wrote :

List views are now considerably faster.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
MillenniumBug (millenniumbug) wrote :

Well, it is going somewhat faster now, but I will still stick to Synaptic, in which I have never found a single bug.

Besides that: I think that original poster should be the one to close a bug report.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers