software-center no longer installs external packages

Bug #634060 reported by Colin Mills on 2010-09-09
108
This bug affects 12 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Kiwinote

Bug Description

Binary package hint: software-center

After the most recent update of the Ubuntu 10.10 software-centrerI am nolonger able to install .deb packages from the Internet.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: software-center 2.1.17
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Sep 9 15:03:31 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center

Colin Mills (cm006a5077) wrote :
Kiwinote (kiwinote) wrote :

Hi Colin! Thanks a lot for your bug report. The bug you describe has been fixed in the branch I have linked and should be available in the next release. It was a regression caused by the new dependency dialogs... Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: New → Fix Committed
Kiwinote (kiwinote) wrote :

software-center (2.1.17.1) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/backend/aptd.py:
    - use the system-wide proxy instead of the gnome
      one by default (LP: #628823)
    - when installing a purchase only update from the just
      added repository to avoid breaking if other sources.list
      entries are incorrect
    - fix signal emite in TransactionStopped
  * debian/control:
    - depend on current aptdaemon

  [ Kiwinote ]
  * software-center:
    - import Decimal before we need it as a workaround for (LP: #607705)
      (testcase: LANGUAGE=tr_TR LC_ALL=tr_TR.utf8 ./software-center)
  * softwarecenter/apt/apthistory.py:
    - use ascii_lower() rather than lower()
      much thanks to M. Vefa Bicakci via bug 581207
      (testcase: LANGUAGE=tr_TR LC_ALL=tr_TR.utf8 ./software-center)
  * software-center/db/application.py:
    - reset app.pkgname once we know deb.pkgname
  * softwarecenter/view/dependency_dialogs.py:
    - fail nicely if pkg not in cache (ie all deb files...) (LP: #634060)

Date: Thu, 09 Sep 2010 17:07:29 +0200
Changed-By: Michael Vogt <michael.vogt at ubuntu.com>
Maintainer: Michael Vogt <mvo at ubuntu.com>
https://launchpad.net/ubuntu/maverick/+source/software-center/2.1.17.1

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
Kiwinote (kiwinote) wrote :

Hi everyone who I just marked as duplicates of this bug report! Much thanks for your bug report. The bug you describe has been fixed in the latest development version of software-center (2.1.17.1). Once again, sorry for this regression. Please continue to report any bugs you may find in software-center. Thanks again for your help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers