Duplicate underscore characters

Bug #626718 reported by Gabor Kelemen on 2010-08-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Kiwinote

Bug Description

Binary package hint: software-center

The second underscore characters are unnecessary here:
_Hide %i technical item_
_Hide %i technical items_
Located in ../softwarecenter/view/availablepane.py:437 ../softwarecenter/view/channelpane.py:256

_Show %i technical item_
_Show %i technical items_
Located in ../softwarecenter/view/availablepane.py:442 ../softwarecenter/view/channelpane.py:261

Kiwinote (kiwinote) wrote :

Hi Gabor! Thanks for your bug report. In these strings we use the underscores to indicate which part of the string acts as a link. Although strictly speaking we do not need the second underscore, I have left it there for clarity. I have however added translators comments to explain what we are doing here (in the branch linked). Please continue to report any bugs you may find in software-center. Thanks again for your help!

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package software-center - 2.1.15

---------------
software-center (2.1.15) maverick; urgency=low

  [ Michael Vogt ]
  * softwarecenter/view/purchasedialog.py:
    - fix size and title for additional webkit windows (LP: #625385)
  * softwarecenter/db/update.py:
    - fix screenshot url and thumbnail url loading
  * softwarecenter/enums.py:
    - switch default to buy-host to software-center.ubuntu.com
    - allow override via the SOFTWARE_CENTER_BUY_HOST environment
      (useful for testing)
  * softwarecenter/backend/aptd.py:
    - make defaults for addons_{install,remove} empty lists instead
      of None to prevent crash when called with a empty argument
    - use AptClinet.install_packages() instead of commit_packages()
      for the install of commercial stuff to get the benefit of
      aptdaemons 03_auth_me_less patch
  * softwarecenter/backend/restfulclient.py:
    - point SERVICE_ROOT for the internal login service to production
  * softwarecenter/view/appdetailsview_gtk.py:
    - minor logging improvements
  * merged lp:~mmcg069/software-center/pathbar-clip-fix that ensures
    proper clipping for the pathbar, many thanks!
  * softwarecenter/view/channelpane.py:
    - fix flicker in channelspane on db-reopen and add regression
      test
  * merged lp:~mvo/software-center/less-flicker that fixes some
    UI flicker/ghost activity (LP: #626733)
  * softwarecenter/backend/aptd.py:
    - if reload() fails when adding a commercial PPA that may be
      because there is a 5 min delay between software-center-agent
      telling us its available and it becoming availalbe in launchpad.
      In this case, retry up to 5 minutes to get the repo
      (LP: #627608)
  * merged lp:~mmcg069/software-center/prelight-icon-onhover
    (many thanks!)
  * merged lp:~mmcg069/software-center/cat-flags to support
    internal flags in the menu files

  [ Gary Lasker ]
  * merge lp:~mmcg069/software-center/misbehaving-pathbar-fix, fixes
    pathbar no longer shrinking to available width (LP: #625210),
    many thanks Matthew McGowan!
  * softwarecenter/view/viewswitcher.py:
    - only update the channel list when a model is available
      (LP: #628394)

  [ Kiwinote ]
  * data/dialogs.ui:
    - only display vscrollbar if needed for dependency removal alert
    - tweak window properties for dependency removal alert
  * data/SoftwareCenter.ui:
    - tweak window properties for the rebuilding window
  * po/POTFILES.in:
    - mark data/ui/dialogs.ui for translation
  * software-center:
    - fix typo, thanks Jeremy Bicha! (LP: #625729)
  * softwarecenter/app.py:
    - always make s-c sensitive again after catalog is rebuilt (LP: #626513)
  * softwarecenter/apt/aptcache.py:
    - don't crash when no LANGPACK_PKGDEPENDS file exists (LP: #625562)
    - speed improvements for get_addons()
    - don't allow randompkg-something to list randompkg as an add-on
  * softwarecenter/db/application.py:
    - fail nicely if a deb file can't be opened
  * softwarecenter/view/appdetailsview_gtk.py:
    - don't use capitalize() on add-on names, much thanks to Severin Heiniger!
      lp:~lantash/ubuntu/maverick/software-center/fixes-626067 (LP: #62...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers