Comment 14 for bug 545134

I also had this issue in Ubuntu 10.10 32bit, however I was able to mostly resolve it by modifying my /etc/apt/apt.conf according to zerozone's post in the following link:

http://ubuntuforums.org/archive/index.php/t-83401.html

I wasn't able to see any "For Purchase" apps, however I was able to install and update from both the Update Manager and the Ubuntu Software Centre. Unfortunately this doesn't seem to resolve the Empathy issue.

For reference, here is what my apt.conf looks like:

APT::Authentication::TrustCDROM "true";
Acquire::http::proxy "http://domain\username:<email address hidden>:port/";
Acquire::ftp::proxy "http://domain\username:<email address hidden>:port/";
Acquire::https::proxy "http://domain\username:<email address hidden>:port/";