Ubuntu software center show crash message , but the program doesn't crash really.

Bug #532652 reported by lory on 2010-03-05
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: software-center

in Ubuntu 10.04 alpha 3, whit the last update , Ubuntu software center show crash message , but the program doesn't crash really.this bug is affected when a new program is installed via Ubuntu Software Center

ProblemType: Bug
Architecture: i386
Date: Fri Mar 5 14:49:10 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
NonfreeKernelModules: snd_hda_codec_nvhdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq snd_timer snd_seq_device snd nvidia snd_page_alloc
Package: software-center 1.1.16.1
PackageArchitecture: all
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic-pae
SourcePackage: software-center
Uname: Linux 2.6.32-15-generic-pae i686

lory (lorenzo-themax) wrote :
Chris Johnston (cjohnston) wrote :

I can confirm that I have had this same problem.

Changed in software-center (Ubuntu):
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

The individual occasions when the crash message appears are real bugs that need to be fixed. The best way to get them fixed is to go ahead with the bug reporting process, even though Ubuntu Software Center is still open and running.

That leaves the general problem described here, that Apport says USC has "closed" when it hasn't. Perhaps this is really a bug in Apport.

Gary Lasker (gary-lasker) wrote :

My guess is that this is a dupe of bug #531780, an annoying bug that has been fixed but not yet released and which many people have been hitting. However, without the Python stacktrace I can't tell for sure. As mpt suggested, when this occurs please go ahead and report the bug via the crash dialog that is displayed. This will insure that the stacktrace will be attached to the bug and we can determine if this is a duplicate or is something different.

I'll mark as Incomplete in hopes that one of the reporters will upload a stacktrace after reproducing this bug. Another way to send a stacktrace is to simply open software-center in a terminal window (type "software-center" at the prompt), and when the error occurs, just copy and paste the terminal output here.

Thanks!

Changed in software-center (Ubuntu):
status: Confirmed → Incomplete
Omer Akram (om26er) wrote :

Thanks for taking time to report this bug and help make ubuntu better. Can you pleae confirm if this is still an issue with software center 1.1.26?

Changed in software-center (Ubuntu):
importance: Undecided → Low
Omer Akram (om26er) wrote :

Closing this bug now. If you face the crash with again please report the bug using the crash reporting tool which appears when the crash happens

Changed in software-center (Ubuntu):
status: Incomplete → Invalid
Alessandro Losavio (alo21) wrote :

I have the same problem with Ubuntu 11.04 alph1 amd 64

Alessandro Losavio (alo21) wrote :

Xubuntu alpha2 11.04 amd64 ( see attachment for more information )

tags: added: iso-testing
Kate Stewart (kate.stewart) wrote :

Updating the status so this gets looked at again. This sort of thing needs to be cleaned up to give a good user experience using the software center.

Changed in software-center (Ubuntu Natty):
status: Invalid → New
importance: Low → Undecided
Michael Vogt (mvo) wrote :

Thanks Alessandro! Did you get any more info from the crash? Like a traceback in ~/.xsession-errors or anything like this? The bug.log unfortunately does not contain a stacktrace so its really hard to diagnose what went wrong.

Gary Lasker (gary-lasker) wrote :

Hi Alessandro, thanks for your report. As mentioned in comments earlier in this report, the best thing to do if you get one of these crash dialogs is to go ahead and report the bug via the dialog itself. This will insure that we get a stacktrace and other information that we need to debug and fix the problem that you are encountering.

Note that these crash dialogs will only be displayed be default when you are running a development (pre-release) version of Ubuntu, as you are now with Natty. Despite the wording in the dialog, the appearance of this dialog often does not indicate that Software Center has literally crashed (that is, disappeared, froze up, or otherwise stopped working). Rather, it just indicates that an exception of some kind has been detected in the program, and that it's something that we need to know about and fix.

Nevertheless, the dialog is very valuable in that is provides a means for us to gather the needed debug information automatically, without the reporter having to locate and upload logs, etc. So if you encounter this problem again, please go ahead and report the bug using the dialog and we will be able to diagnose the problem and fix it.

And thank you again for your help, it's very much appreciated!

Changed in software-center (Ubuntu Natty):
status: New → Incomplete
Gary Lasker (gary-lasker) wrote :

There is a good chance that the current manifestation of this bug is in actuality one of either bug 688991 or bug 694836. These are our current "crashers" with duplicates for which the fix has not yet been released (the first is fix committed now and the second has a fix under review). The stacktrace will let us know for sure.

Thanks again!

Alessandro Losavio (alo21) wrote :

I don't know if is the same, because over there is not specified if after ubuntu-software center crashes really

alessandro, please report a new bug by using the erorr window of the crash
that pops

On Mon, Feb 7, 2011 at 2:28 AM, Alessandro Losavio <
<email address hidden>> wrote:

> I don't know if is the same, because over there is not specified if
> after ubuntu-software center crashes really
>
> --
> You received this bug notification because you are subscribed to
> software-center in ubuntu.
> https://bugs.launchpad.net/bugs/532652
>
> Title:
> Ubuntu software center show crash message , but the program doesn't
> crash really.
>
> Status in “software-center” package in Ubuntu:
> Incomplete
> Status in “software-center” source package in Natty:
> Incomplete
>
> Bug description:
> Binary package hint: software-center
>
> in Ubuntu 10.04 alpha 3, whit the last update , Ubuntu software center
> show crash message , but the program doesn't crash really.this bug is
> affected when a new program is installed via Ubuntu Software Center
>
> ProblemType: Bug
> Architecture: i386
> Date: Fri Mar 5 14:49:10 2010
> DistroRelease: Ubuntu 10.04
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100224.1)
> NonfreeKernelModules: snd_hda_codec_nvhdmi snd_hda_codec_realtek
> snd_hda_intel snd_hda_codec snd_hwdep snd_pcm_oss snd_mixer_oss snd_pcm
> snd_seq_dummy snd_seq_oss snd_seq_midi snd_rawmidi snd_seq_midi_event
> snd_seq snd_timer snd_seq_device snd nvidia snd_page_alloc
> Package: software-center 1.1.16.1
> PackageArchitecture: all
> ProcEnviron:
> LANG=it_IT.utf8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.32-15.22-generic-pae
> SourcePackage: software-center
> Uname: Linux 2.6.32-15-generic-pae i686
>
>
>

Paolo Sammicheli (xdatap1) wrote :

Discussed with Alessandro on IRC. The bug he noticed is not this one, my apologize.

Changed in software-center (Ubuntu Natty):
status: Incomplete → Invalid
Gary Lasker (gary-lasker) wrote :

Ok, thanks for the update, Paolo and Alessandro!

To recap what I mentioned above, in many cases the crash dialog will appear even though Software Center itself has not "crashed" (in the sense of disappearing, freezing, etc.). Rather, it simply indicates that an internal error has been detected in the program that the developers need to know about, and the crash (apport) dialog is the means that allows us to gather the necessary info to diagnose and fix the problem. So, it is not a bug that the program doesn't crash, really. :) The real bug is whatever error condition occurred that caused the crash dialog to be displayed, and that will be tracked in its own bug when the crash info is uploaded via the dialog.

Thanks again for your help!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers