Empty categories are still displayed

Bug #419270 reported by Kiwinote on 2009-08-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Low
Kiwinote

Bug Description

s-c rev707

Launch s-c and set the 'view' filter to 'Canonical-maintained software'. Now browse to graphics > 3d and notice that the list is empty.

<https://wiki.ubuntu.com/SoftwareCenter#lobby>: "The “Departments” section of the lobby screen should list alphabetically all departments, as defined and sorted under “Genre”, which contain any items matching the current repositories and view options."

<https://wiki.ubuntu.com/SoftwareCenter#department>: "If a department has any subsections and at least one of those subsections contains any items matching the current repositories and view options … the department screen should have two panes … presenting alphabetically those subsections that contain any items matching the current repositories and view options."

Andrew (and471) on 2009-08-27
Changed in software-store (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) wrote :

Its not entirely trivial to do that, because it means quering the xapian database for each category on startup (something we do only on-demand now). The xapian.Enquire class supports get_mset() with maxitems=0 to get only a quick approximation of the result. That may be something useful.

Changed in software-store (Ubuntu):
importance: Undecided → Low
Matthew Paul Thomas (mpt) wrote :

So for version 2.0 I can think of three design solutions:

1. An extension of the current behavior. Departments with no available items are still displayed, but navigating to one shows only the centered text "No items are available in this department."
    + Simple.
    + No performance penalty.
    – Frustrating ("why did you even bother showing it?").
    – Cluttersome for users in corporate etc environments if they have been granted permission to install items from existing software sources but not to change sources ("this department is always empty and I can't change that").

2. The lobby screen is empty except for a spinner and progress bar, until the Store has surveyed all departments and worked out which ones have items available. Then all non-empty departments are displayed at once.
    + Appropriately cinematic.
    – Slow: even if you want to choose something from the first department, you have to wait until all of them have been queried.

3. The departments are surveyed in alphabetical order. As each is surveyed, if it is non-empty it is displayed in the “Departments” section. As long as there are departments remaining to be surveyed, a spinner is displayed in the spot where the next department will appear.
    + Minimum delay.
    – Future versions of the Store will have more than just “Departments” on the front page, and the lower sections will jump around nastily if the departments appear incrementally.
    – Especially jerky if the window width and software sources are such that the spinner for surveying “Other” takes up a line by itself, only to collapse when the Store discovers there are no items in the “Other” department.

Are there any other solutions? Could there be some way of caching the list of non-empty departments, invalidating that cache whenever the list of software sources change?

Changed in software-store (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Kiwinote (kiwinote) wrote :

This issue seems to have been fixed in the latest stable release of Ubuntu.

Due to a different design this is no longer an issue.

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
Kiwinote (kiwinote) wrote :

This bug did become invalid in karmic due to design changes made before karmic was released (as the install view was no longer categorised and all categories in the 'get software' view were not empty). However with the introduction of subcategories in lucid this issue has been reintroduced.

Changed in software-center (Ubuntu):
status: Fix Released → Confirmed
description: updated
summary: - Empty categories should not be displayed
+ Empty categories are still displayed
Matthew Paul Thomas (mpt) wrote :

Michael showed me last week that USC can now, very quickly, count the number of items in each department and subsection. So we can now just hide departments/subsections that contain no items with your current repositories and view options. I've updated the specification to match. <https://wiki.ubuntu.com/SoftwareCenter?action=diff&rev2=370&rev1=369>

description: updated
Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in software-center (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
Robert Roth (evfool) wrote :

There are many subsections affected by this : Developertools/Debugging, DeveloperTools/Haskell, DeveloperTools/Profiling, Games/Roleplaying, Games/Simulation, Graphics/3D, Science &Engineering/Biology, Science &Engineering/Electronics, Science &Engineering/Engineering, Science &Engineering/Geology.

Kiwinote (kiwinote) wrote :

Fixed in linked branch. Sweetness :)

Changed in software-center (Ubuntu):
assignee: nobody → Kiwinote (kiwinote)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.7 KiB)

This bug was fixed in the package software-center - 3.1.25

---------------
software-center (3.1.25) natty; urgency=low

  [ Kiwinote ]
  * data/ui/SoftwareCenter.ui:
    - mark the back/forward actions as translatable (LP: #742129)
  * softwarecenter/db/database.py,
    softwarecenter/models/appstore.py,
    softwarecenter/view/availablepane.py,
    others:
    - make custom lists work (LP: #712903)
  * softwarecenter/app.py,
    softwarecenter/distro/Ubuntu.py,
    softwarecenter/view/widgets/pathbar_gtk_atk.py:
    - when the supported filter is set to supported_only, navigate up if:
      - we are in a details view of an app which is not supported (LP: #480827)
      - we are in a list view which becomes empty
  * softwarecenter/app.py,
    softwarecenter/view/catview_gtk.py:
    - correctly count the nr of apps displayed in the recommended category and
      update it when needed (LP: #735634)
    - only display subcategories if they are non-empty (LP: #419270)
  * softwarecenter/backend/weblive.py:
    - don't crash if we try to delete a non-existent file (LP: #743511)
  * softwarecenter/db/reviews.py,
    softwarecenter/distro/Ubuntu.py:
    - fallback to ReviewLoaderJsonAsync when we can't use multiprocessing
      (LP: #741069)
    - fixes to make ReviewLoaderJsonAsync 'work' (ie most common cases)
  * softwarecenter/db/update.py:
    - don't import softwarecenter.log
  * softwarecenter/view/appdetailsview_gtk.py:
    - don't draw random boxes when we have an error layout (LP: #739269)
    - retire share button as we now have full microblogging support in the
      review dialog (LP: #592619, LP: #743765)
  * softwarecenter/view/appview.py:
    - correctly refresh listview when supported filters are changed
  * softwarecenter/view/catview.py:
    - if a category has subcategories, then category.query should include all
      items included in the subcategories, not a subset of these
  * softwarecenter/view/widgets/pathbar_gtk_atk.py:
    - avoid having a half-height pathbar (LP: #743614)
  * refresh .pot file

  [ Gary Lasker ]
  * softwarecenter/view/widgets/reviews.py:
    - fix crash if app_version is not defined when
      calling upstream_version_compare (LP: #746120)
  * softwarecenter/view/purchaseview.py:
    - disconnect webkit signal handlers when the webkit view
      is not showing (LP: #696861)
    - support 'user_cancelled' from the software-center-agent
      (LP: #641321)
  * softwarecenter/view/softwarepane.py,
    softwarecenter/view/widgets/actionbar.py:
    - animate the action bar show/hide
  * softwarecenter/view/appview.py:
    - in the AppViewFilter, also consider apps in the for-purchase
      channel as available; this allows them to show up in
      e.g. What's New (LP: #746679)

  [ Michael Vogt ]
  * softwarecenter/db/update.py:
    - ensure the iconname that comes from the software-center-agent
      does not contain a ".", the icon cache gets confused otherwise
  * merged lp:~evfool/software-center/sfix672229, many thanks to
    Robert Roth (LP: #672229)
  * merged lp:~alexeftimie/software-center/fix-704719-briefly-wrong-display,
    many thanks to Alex Eftimie (LP: #704719)
  * softwarecenter/view/purc...

Read more...

Changed in software-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers