package software-center 13.10-0ubuntu8 failed to install/upgrade: triggers looping, abandoned

Bug #1494184 reported by nico on 2015-09-10
248
This bug affects 51 people
Affects Status Importance Assigned to Milestone
software-center (Ubuntu)
Critical
Adam Conrad

Bug Description

je ne sais pas ce qu'il se passe

ProblemType: Package
DistroRelease: Ubuntu 15.10
Package: software-center 13.10-0ubuntu8
ProcVersionSignature: Ubuntu 4.2.0-9.9-generic 4.2.0
Uname: Linux 4.2.0-9-generic x86_64
ApportVersion: 2.18-0ubuntu9
AptOrdering:
 app-install-data: Install
 app-install-data: Configure
 NULL: ConfigurePending
Architecture: amd64
Date: Thu Sep 10 10:35:53 2015
DuplicateSignature: package:software-center:13.10-0ubuntu8:triggers looping, abandoned
ErrorMessage: triggers looping, abandoned
PackageArchitecture: all
RelatedPackageVersions:
 dpkg 1.18.2ubuntu3
 apt 1.0.9.10ubuntu6
SourcePackage: software-center
Title: package software-center 13.10-0ubuntu8 failed to install/upgrade: triggers looping, abandoned
UpgradeStatus: No upgrade log present (probably fresh install)

nico (ponte-nicolas) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
jerrylamos (jerrylamos) wrote :

Booted, did manual Wily update same as every day

#!/bin/bash
sudo apt-get update
sudo apt-get dist-upgrade
exit 0

then got this error.

Repeated a while later seemed to work as normal.

Got this just now running the Software Updater on Wily.

Mathieu Marquer (slasher-fun) wrote :

During apt-get dist-upgrade:
Traitement des actions différées (« triggers ») pour libc-bin (2.21-0ubuntu4) ...
dpkg: boucle détectée durant le traitement des actions différées :
 listes des paquets qui en sont responsables (normalement) :
  software-center -> software-center
 paquets bloqués par le traitement impossible d'actions différées requises :
  software-center: /usr/share/app-install/desktop
dpkg: erreur de traitement du paquet software-center (--configure) :
 bloqué en boucle sur le traitement des actions différées (« triggers »), abandon
Des erreurs ont été rencontrées pendant l'exécution :
 software-center
E: Sub-process /usr/bin/dpkg returned an error code (1)

Solved with:
mathieu_@xxx:~$ sudo dpkg --configure -a
Paramétrage de software-center (13.10-0ubuntu8) ...
Updating software catalog...this may take a moment.
INFO:softwarecenter.db.pkginfo_impl.aptcache:aptcache.open()
Software catalog update was successful.

After running it for the second time this bug appears to be gone!

So a temporary fix would be to just repeat the upgrade.

QIII (qiii) wrote :

Doing the upgrade over does seem to work. Meh.

John Belton (jbelton1950) wrote :

It worked for me to, perhaps there is a minor timing or sequencing error in the update list.

Brian Smith (brian-smith-i) wrote :

I have this too as from the latest update

Adam Conrad (adconrad) on 2015-09-11
Changed in software-center (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package software-center - 13.10-0ubuntu9

---------------
software-center (13.10-0ubuntu9) wily; urgency=medium

  * Switch to noawait triggers to avoid trigger loops (LP: #1494184)

 -- Adam Conrad <email address hidden> Fri, 11 Sep 2015 11:06:28 -0600

Changed in software-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers