Some packages say "not available for your current Ubuntu version" when viewed from purchase list

Bug #1052721 reported by William Grant on 2012-09-19
32
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Software Center Agent
Medium
Unassigned
software-center (Ubuntu)
Medium
Unassigned

Bug Description

From the "Reinstall Previous Purchases" page of Software Center on precise/amd64, some packages say "Purchased on YYYY-MM-DD but not available for your current Ubuntu version." when they in fact are. For example, Shatter and Space Pirates and Zombies say this today, while Dustforce installs fine. It's perhaps notable that the /subscriptions?complete_only=True listing for the two broken games returns an archless package name and just "multiarch" as the architecture.

It also affects installation from the HIB page on software-center.ubuntu.com. The issue can be worked around by searching for the software in the "For Purchase" section and clicking "Buy..." instead of using the "(already purchased)" item.

I'm using software-center 5.2.6, in case that's relevant.

David Pitkin (dpitkin) on 2012-09-19
tags: added: ca-escalated
Michael Nelson (michael.nelson) wrote :

The attached sca branch only fixes the HIB thank-you page on software-center-agent (so that when buying an app that is multi-arch using Chromium, you won't be told that it's not available yet).

We also discussed on irc [1] whether sca could potentially provide a work-around for USC's "Reinstall previous purchases" by appending :i386 to all multi-arch apps, but in the end it seems this isn't possible, because at that point (the /subscriptions/ api handler), sca does not currently know the client distroseries (and whether it will understand :i386 suffixes) [2].

So it looks like USC will need an update, whether it's to provide the distroseries to the /subscriptions/ call so sca knows it can append the suffix (a work-around), or to update the re-install previous purchases USC functionality to understand multiarch (I assume the proper fix, but mvo will know the pros and cons).

[1] https://irclogs.canonical.com/2012/09/19/%23ca-internal.html#t06:40
[2] That is, the user could purchase on precise, then go to reinstall apps on a natty machine.

Changed in software-center-agent:
status: New → Fix Committed
Michael Nelson (michael.nelson) wrote :

Another point (thanks Anthony): although the sca fix above ensures that buyers will no longer see a "Not available for your version" for multiarch apps, when they click on the Install button:

 * for i386 users, everything should work fine
 * for amd64 users, they will currently see a Not found response in USC, as the apt url provided does not include the :i386 suffix (and that isn't a problem sca can solve - as we can't know definitively the arch of the user... we do know this for chromium users, and may be able to help them).

USC would ultimately need to recognise an apt://foopackage as a possible multi-arch when searching.

On Wed, 19 Sep 2012 08:31:45 -0000, Michael Nelson <email address hidden> wrote:
> The attached sca branch only fixes the HIB thank-you page on software-
> center-agent (so that when buying an app that is multi-arch using
> Chromium, you won't be told that it's not available yet).
>
> We also discussed on irc [1] whether sca could potentially provide a
> work-around for USC's "Reinstall previous purchases" by appending :i386
> to all multi-arch apps, but in the end it seems this isn't possible,
> because at that point (the /subscriptions/ api handler), sca does not
> currently know the client distroseries (and whether it will understand
> :i386 suffixes) [2].

Will an old distroseries that doesn't understand that syntax be able to
install that package if it can find it?

Thanks,

James

Michael Nelson (michael.nelson) wrote :

On Wed, Sep 19, 2012 at 2:40 PM, James Westby <email address hidden> wrote:
> On Wed, 19 Sep 2012 08:31:45 -0000, Michael Nelson <email address hidden> wrote:
>> We also discussed on irc [1] whether sca could potentially provide a
>> work-around for USC's "Reinstall previous purchases" by appending :i386
>> to all multi-arch apps, but in the end it seems this isn't possible,
>> because at that point (the /subscriptions/ api handler), sca does not
>> currently know the client distroseries (and whether it will understand
>> :i386 suffixes) [2].
>
> Will an old distroseries that doesn't understand that syntax be able to
> install that package if it can find it?

It will have it's own native package which I assume would install :)
I'm not sure I've understood the question, but if you look at the
available precise apps for any arch [1], the package 'irukandji' is
multiarch for precise and oneiric, but has i386 and amd64 builds for
natty and maverick. Does that make more sense?

[1] http://software-center.ubuntu.com/api/2.0/applications/en/ubuntu/precise/any/

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-center (Ubuntu):
status: New → Confirmed
Michael Vogt (mvo) on 2012-10-02
Changed in software-center (Ubuntu):
importance: Undecided → Medium
Dave Morley (davmor2) on 2012-10-02
Changed in software-center-agent:
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

Anthony suggested that the client should simply support ":$arch" (e.g. foo:i386) all the time, regardless of i386/amd64. Which makes perfect sense and just needs a bit of client work to ensure that on a non-multiarch system its interpreted correctly.

Mark Swenson (herrmoody) wrote :

I just rebuilt a system with Xubuntu (32-bit) which was previously running Ubuntu (32-bit) and none of my four purchased applications are available for installation (The Clockwork Man, Gratuitous Space Battles, Fluendo DVD Player, and Magical Diary: Horse Hall). Several of these were installed on the same system when it was running Ubuntu. From everything I can tell at least Fluendo should run fine on Xubuntu, if not the others (GSB probably is too much for this particular machine, but that's not a major concern here). I'm guessing that this is the same bug. Is there some kind of workaround at the moment or do I have to wait for a Software Center patch?

Dane Mutters (dmutters) wrote :

I just got this message while trying to install apps in Linux Mint 13 (AMD64) from the Humble Indie Bundle 7. I can install previous Ubuntu purchases, such as "Monster RPG 2," "Super Meat Boy," and "SpaceChem," some of which I purchased from previous HIBs. I also can't use the humblebundle.com link from my private download page to install these games through the Ubuntu Software Center.

The specific games I'm trying to install now are:
Legend of Grimrock
Closure
Snapshot

I'd greatly appreciate anything that can be done about this bug.

Perhaps this one is related?
https://bugs.launchpad.net/elementaryos/+bug/1084529

Thanks for your time and effort.

oldrocker99 (fhwri99) wrote :

I purchased Majesty Gold Edition 2012-10-17, and still am getting the "not available for your Ubuntu version" message, after a couple of software-center upgrades. My current version is 5.4.1.3. For something that was a committed bug, this is getting a bit irritating. I only want the game I purchased; if I'd bought it from Desura, I'd be able to play it.

When will I be able to download the game I PAID for?

oldrocker99 (fhwri99) wrote :

I should mention: Acer Aspire 5516, 4 GB RAM, Lubuntu 12.10. I have also installed kubuntu-desktop, ubuntu-desktop, xubuntu-desktop, and MATE. I use Lubuntu 90% of the time.

John Pugh (jpugh) wrote :

@fhwri99 you didn't include the arch, but I'll assume amd64. We'll upload a new package that will fix it for you.

@dmutters not sure what you are running into, but all of the ones you've listed have native i386 and amd64 packages. This bug is specifically about i386 only packages being installed on amd64 architecture.

Dane Mutters (dmutters) wrote :

Thanks for the reply, John.

I managed to fix the problem I had; it turns out I just had something misconfigured. Please disregard my previous post.

Thanks.

Dane Mutters (dmutters) wrote :

Just to preempt further posts related to my problem but not related to this bug, the solution is here:
http://www.linuxquestions.org/questions/showthread.php?p=4868804#post4868804

John Pugh (jpugh) wrote :

@fhwri99 you *should* be able to see Majesty Gold now. We've updated the app.

oldrocker99 (fhwri99) wrote :

I discovered it today, and downloaded through the SC. I got the error on installation: "Unable to download key file. Please check your Internet connection." I deinstalled and reinstalled, but no keyfile. Looking in /opt/majesty-gold/ revealed nothing. Inasmuch as this is, as I feared, the LGP version, it won't run without the keyfile.

Dave Morley (davmor2) wrote :

oldrocker99
This has no file to write which is what triggers the error. If you check your email for the app the key is there or goto https://software-center.ubuntu.com/subscriptions and click on majesty gold and you'll see your key there.

Jim Raredon (decoy-umd) wrote :

This long-lasting bug is back in Ubuntu 13.10. There are many games I have purchased that are "not available for your current Ubuntu version."

oldrocker99 (fhwri99) wrote :

This is getting ridiculous. Running 15.10 Ubuntu MATE and not even Linux Format Magazine can be downloaded, with the familiar damned "not available for your Ubuntu version" message. For a PDF MAGAZINE?

Changed in software-center-agent:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers