[SRU] 2.54

Bug #1955137 reported by Michael Vogt
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
snapd (Ubuntu)
Fix Released
Undecided
Unassigned
Bionic
Fix Released
Undecided
Unassigned
Focal
Fix Released
Undecided
Unassigned
Hirsute
Fix Committed
Undecided
Unassigned
Impish
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Unassigned

Bug Description

This is a new version of snapd.

The changelog is available here https://github.com/snapcore/snapd/blob/2.54.2/packaging/ubuntu-16.04/changelog, the raw git changelog is available here: https://github.com/snapcore/snapd/commits/2.54.2 (note that the debian changelog is auto-generated from the merges of the git commits so there is usually no need to look at the raw git commits).

The snappy team released a new release that we want SRU into bionc+. The new process described in https://wiki.ubuntu.com/SnapdUpdates was used and we have done integration-tests on the snappy images, autopkgtests on classic and unit tests.

GitHub Actions test runs can be found at https://github.com/snapcore/snapd/actions?query=branch%3Arelease%2F2.54.2

Michael Vogt (mvo)
description: updated
Changed in snapd (Ubuntu Jammy):
status: New → Fix Committed
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Michael, or anyone else affected,

Accepted snapd into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+21.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Impish):
status: New → Fix Committed
tags: added: verification-needed verification-needed-impish
Changed in snapd (Ubuntu Hirsute):
status: New → Fix Committed
tags: added: verification-needed-hirsute
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+21.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+20.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in snapd (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

I did not handle the xenial upload as I suppose those will go through xenial ESM.

From other notes to SRU reviewers and verifiers: one thing to make sure to keep some eyes out is the new functionality in snapd to write conf files to /etc/modprobe.d/. We have this policy that any new packaging/filesystem-configuration changes should be looked out for, and this new snapd introduced it here:
https://github.com/snapcore/snapd/pull/10977/files

Also, the switch to golang-1.13 means that for bionic snapd now build-depends on an universe source package (as golang-1.13 is still in universe on bionic). But that is fine as it should not result in any universe binary dependencies.

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (snapd/2.54.2+21.10)

All autopkgtests for the newly accepted snapd (2.54.2+21.10) for impish have finished running.
The following regressions have been reported in tests triggered by the package:

snapd/2.54.2+21.10 (ppc64el, amd64, arm64, s390x)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/impish/update_excuses.html#snapd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (snapd/2.54.2+21.04)

All autopkgtests for the newly accepted snapd (2.54.2+21.04) for hirsute have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-image/1.11+21.04ubuntu2 (armhf)
snapd/2.54.2+21.04 (ppc64el, amd64, arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/hirsute/update_excuses.html#snapd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (snapd/2.54.2+20.04)

All autopkgtests for the newly accepted snapd (2.54.2+20.04) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

snapd/2.54.2+20.04 (ppc64el, arm64, s390x, amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#snapd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (snapd/2.54.2+18.04)

All autopkgtests for the newly accepted snapd (2.54.2+18.04) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

snapd/2.54.2+18.04 (amd64, s390x, i386, arm64, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#snapd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.54.2+22.04ubuntu1

---------------
snapd (2.54.2+22.04ubuntu1) jammy; urgency=medium

  * New upstream release, LP: #1955137
    - fix missing prepare in autopkgtest setup, this fixes the
      autopkgest failure from the previous upload

 -- Michael Vogt <email address hidden> Fri, 14 Jan 2022 17:23:34 +0100

Changed in snapd (Ubuntu Jammy):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Michael, or anyone else affected,

Accepted snapd into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+21.10ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+21.04ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+20.04ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Michael, or anyone else affected,

Accepted snapd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+18.04ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (snapd/2.54.2+21.04)

All autopkgtests for the newly accepted snapd (2.54.2+21.04) for hirsute have finished running.
The following regressions have been reported in tests triggered by the package:

ubuntu-image/1.11+21.04ubuntu2 (armhf)
snapd/2.54.2+21.04 (amd64, arm64, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/hirsute/update_excuses.html#snapd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Niklas Sombert (ytvwld) wrote :

It would be really nice if someone could take a look at https://bugs.launchpad.net/ubuntu/+source/snapd/+bug/1958022 before this gets widely released to Focal.

I guess this part in data/env/snapd.fish.in is the culprit:

+# Expand $PATH to include the directory where snappy applications go.
+set -u snap_bin_path "@SNAP_MOUNT_DIR@/bin"
+fish_add_path -aP $snap_bin_path

Revision history for this message
Sergio Cazzolato (sergio-j-cazzolato) wrote :
tags: added: verification-done verification-done-bionic verification-done-focal verification-done-hirsute verification-done-impish
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-hirsute verification-needed-impish
Revision history for this message
Brian Murray (brian-murray) wrote :

If there is nothing private about the logfile added in JIRA it would be better to just attach that to the Launchpad bug report. Additionally, could you explain the following output to me? as it looks like there were a few failures.

2022-01-19 12:40:29 Successful tasks: 2208
244472022-01-19 12:40:29 Aborted tasks: 4
244482022-01-19 12:40:29 Failed tasks: 5
24449 - google-sru:ubuntu-18.04-64:tests/main/snap-userd-reexec
24450 - google-sru:ubuntu-18.04-64:tests/main/snaps-state
24451 - google-sru:ubuntu-20.04-64:tests/main/snaps-state
24452 - google-sru:ubuntu-21.04-64:tests/main/snaps-state
24453 - google-sru:ubuntu-21.10-64:tests/main/snaps-state
244542022-01-19 12:40:29 Failed task prepare: 4
24455 - google-sru:ubuntu-18.04-64:tests/main/snapd-snap:lxd
24456 - google-sru:ubuntu-18.04-64:tests/regression/lp-1871652
24457 - google-sru:ubuntu-20.04-64:tests/main/snapd-snap:lxd
24458 - google-sru:ubuntu-21.04-64:tests/main/snapd-snap:lxd
244592022-01-19 12:40:29 Failed task restore: 1
24460 - google-sru:ubuntu-18.04-64:tests/regression/lp-1871652
24461error: unsuccessful run

Revision history for this message
Łukasz Zemczak (sil2100) wrote :

@Sergio could you address Brian's comment in #18? Are those 'known failures' or something?

Revision history for this message
Brian Murray (brian-murray) wrote :

I've set the tags back to verification-needed to prevent the accidental release of this while we wait for some details about the testing results.

tags: added: verification-needed verification-needed-bionic verification-needed-focal verification-needed-hirsute verification-needed-impish
removed: verification-done verification-done-bionic verification-done-focal verification-done-hirsute verification-done-impish
Revision history for this message
Sergio Cazzolato (sergio-j-cazzolato) wrote :

Hi, these test failures are not issues in snapd, those are related to the tests, I'll work on adapting those tests to make then work for SRU validation.

When we run tests for sru validation, reexec is disabled and the snapd deb package is not generated as usual, this is making some tests fail in this case.

Thanks for the review.

tags: added: verification-done verification-done-bionic verification-done-focal verification-done-hirsute verification-done-impish
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-hirsute verification-needed-impish
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Michael, or anyone else affected,

Accepted snapd into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/snapd/2.54.2+20.04ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal
removed: verification-done verification-done-focal
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (snapd/2.54.2+20.04ubuntu2)

All autopkgtests for the newly accepted snapd (2.54.2+20.04ubuntu2) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

livecd-rootfs/2.664.37 (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#snapd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Sergio Cazzolato (sergio-j-cazzolato) wrote :
tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.54.2+21.10ubuntu1

---------------
snapd (2.54.2+21.10ubuntu1) impish; urgency=medium

  * New upstream release, LP: #1955137
    - fix missing prepare in autopkgtest setup, this fixes the
      autopkgest failure from the previous upload

 -- Michael Vogt <email address hidden> Fri, 14 Jan 2022 17:23:34 +0100

Changed in snapd (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for snapd has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.54.2+20.04ubuntu2

---------------
snapd (2.54.2+20.04ubuntu2) focal; urgency=medium

  * New upstream release, LP: #1955137
    - cherry-pick https://github.com/snapcore/snapd/pull/11325
      to fix timeout during the riscv64 builds on focal

 -- Michael Vogt <email address hidden> Tue, 01 Feb 2022 17:59:58 +0100

Changed in snapd (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package snapd - 2.54.2+18.04ubuntu1

---------------
snapd (2.54.2+18.04ubuntu1) bionic; urgency=medium

  * New upstream release, LP: #1955137
    - fix missing prepare in autopkgtest setup, this fixes the
      autopkgest failure from the previous upload

 -- Michael Vogt <email address hidden> Fri, 14 Jan 2022 17:23:34 +0100

Changed in snapd (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers